You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-bindgen0.59/bindgen-fix-metadata.diff

29 lines
729 B

--- bindgen-0.59.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bindgen-0.59.2/Cargo.toml 2022-11-21T21:02:01.697126+00:00
@@ -24,15 +24,11 @@
categories = ["external-ffi-bindings", "development-tools::ffi"]
license = "BSD-3-Clause"
repository = "https://github.com/rust-lang/rust-bindgen"
+autobins = false
[lib]
path = "src/lib.rs"
-[[bin]]
-name = "bindgen"
-path = "src/main.rs"
-doc = false
-required-features = ["clap"]
[dependencies.bitflags]
version = "1.0.3"
@@ -100,7 +96,7 @@
version = "3"
[features]
-default = ["logging", "clap", "runtime", "which-rustfmt"]
+default = ["logging", "clap", "which-rustfmt"]
logging = ["env_logger", "log"]
runtime = ["clang-sys/runtime"]
static = ["clang-sys/static"]