Initial import (bindgen 0.59 compat package)

epel9
Fabio Valentini 2 years ago
parent ba7e745251
commit ca0e645ec5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/bindgen-0.59.2.crate

@ -1,3 +0,0 @@
# rust-bindgen0.59
The rust-bindgen0.59 package

@ -0,0 +1,28 @@
--- bindgen-0.59.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bindgen-0.59.2/Cargo.toml 2022-11-21T21:02:01.697126+00:00
@@ -24,15 +24,11 @@
categories = ["external-ffi-bindings", "development-tools::ffi"]
license = "BSD-3-Clause"
repository = "https://github.com/rust-lang/rust-bindgen"
+autobins = false
[lib]
path = "src/lib.rs"
-[[bin]]
-name = "bindgen"
-path = "src/main.rs"
-doc = false
-required-features = ["clap"]
[dependencies.bitflags]
version = "1.0.3"
@@ -100,7 +96,7 @@
version = "3"
[features]
-default = ["logging", "clap", "runtime", "which-rustfmt"]
+default = ["logging", "clap", "which-rustfmt"]
logging = ["env_logger", "log"]
runtime = ["clang-sys/runtime"]
static = ["clang-sys/static"]

@ -0,0 +1,240 @@
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate bindgen
Name: rust-bindgen0.59
Version: 0.59.2
Release: %autorelease
Summary: Automatically generates Rust FFI bindings to C and C++ libraries
License: BSD-3-Clause
URL: https://crates.io/crates/bindgen
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * do not build bindgen binary from compat package
# * default to linking with libclang instead of using dlopen
Patch: bindgen-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Automatically generates Rust FFI bindings to C and C++ libraries.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+clap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+clap-devel %{_description}
This package contains library source intended for building other packages which
use the "clap" feature of the "%{crate}" crate.
%files -n %{name}+clap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+env_logger-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+env_logger-devel %{_description}
This package contains library source intended for building other packages which
use the "env_logger" feature of the "%{crate}" crate.
%files -n %{name}+env_logger-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages which
use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+runtime-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+runtime-devel %{_description}
This package contains library source intended for building other packages which
use the "runtime" feature of the "%{crate}" crate.
%files -n %{name}+runtime-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static-devel %{_description}
This package contains library source intended for building other packages which
use the "static" feature of the "%{crate}" crate.
%files -n %{name}+static-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+testing_only_docs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_docs-devel %{_description}
This package contains library source intended for building other packages which
use the "testing_only_docs" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_docs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+testing_only_extra_assertions-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_extra_assertions-devel %{_description}
This package contains library source intended for building other packages which
use the "testing_only_extra_assertions" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_extra_assertions-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+testing_only_libclang_3_9-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_3_9-devel %{_description}
This package contains library source intended for building other packages which
use the "testing_only_libclang_3_9" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_3_9-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+testing_only_libclang_4-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_4-devel %{_description}
This package contains library source intended for building other packages which
use the "testing_only_libclang_4" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_4-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+testing_only_libclang_5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_5-devel %{_description}
This package contains library source intended for building other packages which
use the "testing_only_libclang_5" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+testing_only_libclang_9-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing_only_libclang_9-devel %{_description}
This package contains library source intended for building other packages which
use the "testing_only_libclang_9" feature of the "%{crate}" crate.
%files -n %{name}+testing_only_libclang_9-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+which-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+which-devel %{_description}
This package contains library source intended for building other packages which
use the "which" feature of the "%{crate}" crate.
%files -n %{name}+which-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+which-rustfmt-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+which-rustfmt-devel %{_description}
This package contains library source intended for building other packages which
use the "which-rustfmt" feature of the "%{crate}" crate.
%files -n %{name}+which-rustfmt-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (bindgen-0.59.2.crate) = 14c49879c7443191b877957a4fd405c7f10a1e8b70016d91bf5fe33861fc5d71982a1c685c190e4f7922cedb6c8aefadac3b0b68cbe5578da791a8da6bfedf44
Loading…
Cancel
Save