You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
73 lines
1.7 KiB
73 lines
1.7 KiB
# Generated by rust2rpm 26
|
|
%bcond_without check
|
|
|
|
%global crate bindgen-cli
|
|
|
|
Name: rust-bindgen-cli
|
|
Version: 0.69.5
|
|
Release: %autorelease
|
|
Summary: Automatically generates Rust FFI bindings to C and C++ libraries
|
|
|
|
License: BSD-3-Clause
|
|
URL: https://crates.io/crates/bindgen-cli
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Automatically generates Rust FFI bindings to C and C++ libraries.}
|
|
|
|
%description %{_description}
|
|
|
|
%package -n %{crate}
|
|
Summary: %{summary}
|
|
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
|
# Apache-2.0
|
|
# Apache-2.0 OR MIT
|
|
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
|
# BSD-3-Clause
|
|
# ISC
|
|
# MIT
|
|
# MIT OR Apache-2.0
|
|
# Unlicense OR MIT
|
|
License: BSD-3-Clause AND Apache-2.0 AND ISC AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (Unlicense OR MIT)
|
|
# LICENSE.dependencies contains a full license breakdown
|
|
|
|
# /usr/bin/bindgen was moved from bindgen to bindgen-cli with v0.61
|
|
Provides: bindgen = %{version}-%{release}
|
|
Obsoletes: bindgen < 0.61
|
|
|
|
# /usr/bin/bindgen requires libclang.so at runtime
|
|
Requires: clang-libs
|
|
|
|
%description -n %{crate} %{_description}
|
|
|
|
%files -n %{crate}
|
|
%license LICENSE
|
|
%license LICENSE.dependencies
|
|
%doc README.md
|
|
%{_bindir}/bindgen
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires -a
|
|
|
|
%build
|
|
%cargo_build
|
|
%{cargo_license_summary}
|
|
%{cargo_license} > LICENSE.dependencies
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|