Build with support for dlopening libclang.so at runtime

epel9 imports/e9/rust-bindgen-cli-0.68.1-2.el9
Fabio Valentini 1 year ago
parent de6440eba2
commit f4ded3ea7d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,22 +0,0 @@
--- bindgen-cli-0.68.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bindgen-cli-0.68.1/Cargo.toml 2023-09-17T13:49:25.158864+00:00
@@ -46,7 +46,11 @@
features = [
"__cli",
"experimental",
+ "logging",
+ "prettyplease",
+ "which-rustfmt",
]
+default-features = false
[dependencies.clap]
version = "4"
@@ -72,7 +76,6 @@
__testing_only_libclang_9 = ["bindgen/__testing_only_libclang_9"]
default = [
"logging",
- "runtime",
"which-rustfmt",
]
logging = [

@ -11,9 +11,6 @@ Summary: Automatically generates Rust FFI bindings to C and C++ libraries
License: BSD-3-Clause
URL: https://crates.io/crates/bindgen-cli
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * default to linking with libclang instead of using dlopen
Patch: bindgen-cli-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
@ -29,16 +26,20 @@ Summary: %{summary}
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# BSD-3-Clause
# ISC
# MIT
# MIT OR Apache-2.0
# Unlicense OR MIT
License: BSD-3-Clause AND Apache-2.0 AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (Unlicense OR MIT)
License: BSD-3-Clause AND Apache-2.0 AND ISC AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown
# /usr/bin/bindgen was moved from bindgen to bindgen-cli with v0.61
Provides: bindgen = %{version}-%{release}
Obsoletes: bindgen < 0.61
# /usr/bin/bindgen requires libclang.so at runtime
Requires: clang-libs
%description -n %{crate} %{_description}
%files -n %{crate}

Loading…
Cancel
Save