You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-below/below-fix-metadata.diff

30 lines
1.2 KiB

--- below-0.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ below-0.4.0/Cargo.toml 2021-10-27T17:40:41.373826+00:00
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below"
version = "0.4.0"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
@@ -108,3 +108,17 @@
[features]
enable_backtrace = []
+
+[patch.crates-io]
+cgroupfs = { path = "patched-crates/cgroupfs" }
+common = { path = "patched-crates/below-common", package = "below-common" }
+config = { path = "patched-crates/below-config", package = "below-config" }
+dump = { path = "patched-crates/below-dump", package = "below-dump" }
+libbpf-rs = { path = "patched-crates/libbpf-rs" }
+libbpf-cargo = { path = "patched-crates/libbpf-cargo" }
+model = { path = "patched-crates/below-model", package = "below-model" }
+procfs = { path = "patched-crates/fb_procfs", package = "fb_procfs" }
+store = { path = "patched-crates/below-store", package = "below-store" }
+view = { path = "patched-crates/below-view", package = "below-view" }
+derive = { path = "patched-crates/below_derive", package = "below_derive" }
+render = { path = "patched-crates/below-render", package = "below-render" }