import #1972804
parent
e82f595b8a
commit
98291417e8
@ -0,0 +1 @@
|
||||
/below-model-0.2.0.crate
|
@ -0,0 +1,20 @@
|
||||
--- below-model-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ below-model-0.2.0/Cargo.toml 2021-06-16T16:31:32.715340+00:00
|
||||
@@ -31,7 +31,7 @@
|
||||
version = "0.3"
|
||||
|
||||
[dependencies.os_info]
|
||||
-version = "=2.0.1"
|
||||
+version = "3.0.6"
|
||||
|
||||
[dependencies.procfs]
|
||||
version = "0.2.0"
|
||||
@@ -41,7 +41,7 @@
|
||||
version = "1.4.2"
|
||||
|
||||
[dependencies.serde]
|
||||
-version = "=1.0.118"
|
||||
+version = "1.0.126"
|
||||
features = ["derive", "rc"]
|
||||
|
||||
[dependencies.serde_json]
|
@ -0,0 +1,76 @@
|
||||
# Generated by rust2rpm 17
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate below-model
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Model crate for below
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/below-model
|
||||
Source: %{crates_source}
|
||||
# Bump serde to 1.0.126 and os_info to 3.0.6
|
||||
Patch0: below-model-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Model crate for below.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.2.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue