parent
2f36e68918
commit
db4428ed21
@ -0,0 +1 @@
|
||||
/below-config-0.3.0.crate
|
@ -0,0 +1,10 @@
|
||||
--- below-config-0.3.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ below-config-0.3.0/Cargo.toml 2021-07-29T21:20:40.995503+00:00
|
||||
@@ -29,6 +29,6 @@
|
||||
features = ["derive", "rc"]
|
||||
|
||||
[dependencies.toml]
|
||||
-version = "=0.5.7"
|
||||
+version = "0.5.8"
|
||||
[dev-dependencies.tempdir]
|
||||
version = "0.3"
|
@ -0,0 +1,75 @@
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate below-config
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.3.0
|
||||
Release: %autorelease
|
||||
Summary: Configerations for below
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/below-config
|
||||
Source: %{crates_source}
|
||||
# Bump toml to 0.5.8
|
||||
Patch0: below-config-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Configerations for below.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue