Update to version 0.3.69; Fixes RHBZ#2218705

epel9 imports/e9/rust-backtrace-0.3.69-1.el9
Fabio Valentini 1 year ago
parent 16bfa49d52
commit db626ecfe0
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -26,3 +26,4 @@
/backtrace-0.3.64.crate
/backtrace-0.3.66.crate
/backtrace-0.3.67.crate
/backtrace-0.3.69.crate

@ -1,6 +1,6 @@
--- backtrace-0.3.67/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.67/Cargo.toml 2023-03-30T21:35:36.293509+00:00
@@ -127,18 +127,5 @@
--- backtrace-0.3.69/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.69/Cargo.toml 2023-11-29T18:35:10.063960+00:00
@@ -104,16 +104,6 @@
std = []
unix-backtrace = []
verify-winapi = [
@ -16,6 +16,11 @@
- "winapi/winnt",
]
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.addr2line]
@@ -140,6 +130,3 @@
]
default-features = false
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-optional = true

@ -1,14 +1,6 @@
--- backtrace-0.3.67/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.67/Cargo.toml 2023-03-30T21:36:01.225600+00:00
@@ -25,6 +25,7 @@
readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/backtrace-rs"
+exclude = ["/ci/"]
[[example]]
name = "backtrace"
@@ -48,17 +49,7 @@
--- backtrace-0.3.69/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.69/Cargo.toml 2023-11-29T18:35:41.541100+00:00
@@ -49,17 +49,7 @@
edition = "2018"
[[test]]

@ -1,26 +1,25 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate backtrace
Name: rust-backtrace
Version: 0.3.67
Version: 0.3.69
Release: %autorelease
Summary: Library to acquire a stack trace (backtrace) at runtime in a Rust program
License: MIT OR Apache-2.0
URL: https://crates.io/crates/backtrace
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: backtrace-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop "accuracy" test (requires crates to be built in dylib mode)
# * drop "current-exe-mismatch" test (fails on i686 for unknown reasons)
# * exclude files for upstream CI
Patch: backtrace-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A library to acquire a stack trace (backtrace) at runtime in a Rust
@ -152,12 +151,12 @@ use the "std" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# drop "accuracy" test (requires crates to be built in dylib mode)
# drop "current-exe-mismatch" test (fails on i686 for unknown reasons)
rm -r tests/accuracy/
rm tests/current-exe-mismatch.rs
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires

@ -1,9 +0,0 @@
[DEFAULT]
unwanted-features =
coresymbolication
dbghelp
dladdr
kernel32
libunwind
unix-backtrace
verify-winapi

@ -0,0 +1,14 @@
[package]
summary = "Library to acquire a stack trace (backtrace) at runtime in a Rust program"
[features]
hide = [
"coresymbolication",
"dbghelp",
"dladdr",
"kernel32",
"libunwind",
"unix-backtrace",
"verify-winapi",
]

@ -1 +1 @@
SHA512 (backtrace-0.3.67.crate) = 8603a3b63f4f08be315176908134243680bf1a4b0e6cb26ed81f5fc1060279126ca0ef28f209a10289e1a85214b35db6b496affd71ad21524094f3ee3acd31b6
SHA512 (backtrace-0.3.69.crate) = 6e86de53e1c5003ef68b6a85479cde1e70bf416bdc50e6e32ead9f9f070fa30ad46de22574041c844ddfeabd5d15de01ef746f19f8cb7f257c491ef0bf071244

Loading…
Cancel
Save