Update to version 0.3.73; Fixes RHBZ#2270886

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel10
Michel Lind 7 months ago committed by Fabio Valentini
parent d623e1a813
commit 1ebd7c0501
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -27,3 +27,4 @@
/backtrace-0.3.66.crate
/backtrace-0.3.67.crate
/backtrace-0.3.69.crate
/backtrace-0.3.73.crate

@ -1,6 +1,6 @@
--- backtrace-0.3.69/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.69/Cargo.toml 2023-11-29T18:35:10.063960+00:00
@@ -104,16 +104,6 @@
--- backtrace-0.3.73/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.73/Cargo.toml 2024-07-24T18:48:04.168995+00:00
@@ -121,18 +121,6 @@
std = []
unix-backtrace = []
verify-winapi = [
@ -14,13 +14,19 @@
- "winapi/tlhelp32",
- "winapi/winbase",
- "winapi/winnt",
- "winapi/winnls",
- "winapi/stringapiset",
]
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.addr2line]
@@ -140,6 +130,3 @@
@@ -160,9 +148,6 @@
]
default-features = false
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-optional = true
-
[lints.rust]
unexpected_cfgs = "allow"
+

@ -1,20 +1,32 @@
--- backtrace-0.3.69/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.69/Cargo.toml 2023-11-29T18:35:41.541100+00:00
@@ -49,17 +49,7 @@
edition = "2018"
--- backtrace-0.3.73/Cargo.toml 1970-01-01T00:00:01+00:00
+++ backtrace-0.3.73/Cargo.toml 2024-07-24T18:48:25.715217+00:00
@@ -61,20 +61,8 @@
edition = "2021"
[[test]]
-name = "accuracy"
-path = "tests/accuracy/main.rs"
-required-features = ["std"]
-edition = "2018"
-edition = "2021"
-
-[[test]]
name = "concurrent-panics"
path = "tests/concurrent-panics.rs"
-harness = false
-required-features = ["std"]
-
-[[test]]
-name = "current-exe-mismatch"
-path = "tests/current-exe-mismatch.rs"
harness = false
required-features = ["std"]
@@ -124,7 +112,7 @@
]
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.addr2line]
-version = "0.22.0"
+version = "0.24.0"
default-features = false
[target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.libc]

@ -1,11 +1,11 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate backtrace
Name: rust-backtrace
Version: 0.3.69
Version: 0.3.73
Release: %autorelease
Summary: Library to acquire a stack trace (backtrace) at runtime in a Rust program
@ -17,6 +17,7 @@ Patch: backtrace-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop "accuracy" test (requires crates to be built in dylib mode)
# * drop "current-exe-mismatch" test (fails on i686 for unknown reasons)
# * bump addr2line from 0.22.0 to 0.24.0
Patch: backtrace-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
@ -66,40 +67,16 @@ use the "cpp_demangle" feature of the "%{crate}" crate.
%files -n %{name}+cpp_demangle-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+gimli-symbolize-devel
%package -n %{name}+dl_iterate_phdr-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+gimli-symbolize-devel %{_description}
%description -n %{name}+dl_iterate_phdr-devel %{_description}
This package contains library source intended for building other packages which
use the "gimli-symbolize" feature of the "%{crate}" crate.
use the "dl_iterate_phdr" feature of the "%{crate}" crate.
%files -n %{name}+gimli-symbolize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libbacktrace-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libbacktrace-devel %{_description}
This package contains library source intended for building other packages which
use the "libbacktrace" feature of the "%{crate}" crate.
%files -n %{name}+libbacktrace-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc-serialize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc-serialize-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc-serialize" feature of the "%{crate}" crate.
%files -n %{name}+rustc-serialize-devel
%files -n %{name}+dl_iterate_phdr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
@ -114,18 +91,6 @@ use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-rustc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serialize-rustc-devel %{_description}
This package contains library source intended for building other packages which
use the "serialize-rustc" feature of the "%{crate}" crate.
%files -n %{name}+serialize-rustc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-serde-devel
Summary: %{summary}
BuildArch: noarch
@ -169,10 +134,12 @@ rm tests/current-exe-mismatch.rs
%if %{with check}
%check
# https://github.com/rust-lang/backtrace-rs/issues/204
# * https://github.com/rust-lang/backtrace-rs/issues/204
# * tests/smoke.rs/smoke_test_frames: fails on all architectures
# * tests/smoke.rs/sp_smoke_test: crashes when frame pointers are enabled on x86_64
# * backtrace_new_unresolved_should_start_with_call_site_trace: fails on aarch64, ppc64le, s390x
# * tests/smoke.rs/sp_smoke_test: crashes when frame pointers are enabled on
# x86_64
# * backtrace_new_unresolved_should_start_with_call_site_trace: fails on
# aarch64, ppc64le, s390x
%cargo_test -- -- --skip smoke_test_frames --skip sp_smoke_test --skip backtrace_new_unresolved_should_start_with_call_site_trace
%endif

@ -12,3 +12,23 @@ hide = [
"verify-winapi",
]
[scripts]
prep.post = [
"# drop \"accuracy\" test (requires crates to be built in dylib mode)",
"# drop \"current-exe-mismatch\" test (fails on i686 for unknown reasons)",
"rm -r tests/accuracy/",
"rm tests/current-exe-mismatch.rs",
]
[tests]
skip = [
"smoke_test_frames",
"sp_smoke_test",
"backtrace_new_unresolved_should_start_with_call_site_trace",
]
comments = [
"https://github.com/rust-lang/backtrace-rs/issues/204",
"tests/smoke.rs/smoke_test_frames: fails on all architectures",
"tests/smoke.rs/sp_smoke_test: crashes when frame pointers are enabled on x86_64",
"backtrace_new_unresolved_should_start_with_call_site_trace: fails on aarch64, ppc64le, s390x",
]

@ -1 +1 @@
SHA512 (backtrace-0.3.69.crate) = 6e86de53e1c5003ef68b6a85479cde1e70bf416bdc50e6e32ead9f9f070fa30ad46de22574041c844ddfeabd5d15de01ef746f19f8cb7f257c491ef0bf071244
SHA512 (backtrace-0.3.73.crate) = dacedfd32cb91fe408e4f395441baf09c0a4b3bc4ba8f79d088359455cc903c93d24969567c7c5b2feb806433ffbb63a526d73f53caa4bee9c51961b61f831d9

Loading…
Cancel
Save