Update to version 0.9.1; Fixes RHBZ#2067947

epel9 imports/e9/rust-av-metrics-0.9.1-1.el9
Fabio Valentini 2 years ago
parent 33fa5983e7
commit 4123018eb4
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/testfiles.tar.gz
/av-metrics-0.6.2.crate
/av-metrics-0.7.2.crate
/av-metrics-0.9.1.crate

@ -0,0 +1,20 @@
The MIT License (MIT)
Copyright (c) 2019 Joshua Holmer
Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal in
the Software without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
of the Software, and to permit persons to whom the Software is furnished to do
so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

@ -1,22 +1,32 @@
--- av-metrics-0.7.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ av-metrics-0.7.2/Cargo.toml 2023-03-12T20:42:38.038076+00:00
@@ -22,10 +22,6 @@
--- av-metrics-0.9.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ av-metrics-0.9.1/Cargo.toml 2023-06-27T17:40:10.392321+00:00
@@ -14,7 +14,7 @@
name = "av-metrics"
version = "0.9.1"
authors = ["Josh Holmer <jholmer.in@gmail.com>"]
-include = ["src/**/*"]
+include = ["src/**/*", "LICENSE"]
description = "A collection of algorithms for measuring audio/video metrics"
license = "MIT"
repository = "https://github.com/rust-av/av-metrics"
@@ -22,11 +22,6 @@
[lib]
bench = false
-
-[[bench]]
-name = "bench"
-path = "benches/bench.rs"
-harness = false
[dependencies.crossbeam]
version = "0.8"
@@ -51,8 +47,6 @@
@@ -54,8 +49,5 @@
[dependencies.v_frame]
version = "0.2.0"
-[dev-dependencies.criterion]
-version = "0.3"
version = "0.3.1"
-[dev-dependencies.criterion]
-version = "0.4"
-
[dev-dependencies.y4m]
version = "0.7.0"
version = "0.8.0"

@ -5,14 +5,15 @@
%global crate av-metrics
Name: rust-av-metrics
Version: 0.7.2
Version: 0.9.1
Release: %autorelease
Summary: Collection of algorithms for measuring audio/video metrics
# https://github.com/rust-av/av-metrics/issues/215
License: MIT
URL: https://crates.io/crates/av-metrics
Source: %{crates_source}
Source0: %{crates_source}
# https://github.com/rust-av/av-metrics/pull/297
Source1: https://github.com/rust-av/av-metrics/raw/1d43898/av_metrics/LICENSE
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: av-metrics-fix-metadata.diff
@ -34,6 +35,7 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/src/video/ciede/delta_e/LICENSE
%license %{crate_instdir}/src/video/ciede/rgbtolab/LICENSE
%{crate_instdir}/
@ -65,6 +67,7 @@ use the "serde" feature of the "%{crate}" crate.
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} .
%generate_buildrequires
%cargo_generate_buildrequires

@ -1 +1 @@
SHA512 (av-metrics-0.7.2.crate) = b98571f685a0a3eadf28b2e889964b0a7ac2853405e179e7af349d416506beb8fe18b39cb9cd452a2c0167054d2203d2fc7914e6eefab164b5973f67a0ffcd61
SHA512 (av-metrics-0.9.1.crate) = 5d9c408a4ff66ef2e163a2d83eea91fc317c80d7e36fc782f4a8b577d6a7e930d9d657f924dabb8ca28c1b2c674fe7f3348b28d6012e1fd592aa857fe98c784f

Loading…
Cancel
Save