parent
48f9a67986
commit
80a8fc3492
@ -0,0 +1 @@
|
||||
/async-process-1.8.1.crate
|
@ -0,0 +1,16 @@
|
||||
--- async-process-1.8.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ async-process-1.8.1/Cargo.toml 2024-01-05T20:41:24.864025+00:00
|
||||
@@ -61,13 +61,3 @@
|
||||
]
|
||||
default-features = false
|
||||
|
||||
-[target."cfg(windows)".dependencies.blocking]
|
||||
-version = "1.0.0"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.48"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Threading",
|
||||
-]
|
||||
-default-features = false
|
@ -0,0 +1,72 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate async-process
|
||||
|
||||
Name: rust-async-process1
|
||||
Version: 1.8.1
|
||||
Release: %autorelease
|
||||
Summary: Async interface for working with processes
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/async-process
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: async-process-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Async interface for working with processes.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue