parent
54020a4dd5
commit
90d9be9098
@ -0,0 +1 @@
|
||||
/async-io-1.13.0.crate
|
@ -0,0 +1,8 @@
|
||||
--- async-io-1.13.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ async-io-1.13.0/Cargo.toml 2024-01-05T18:50:54.134141+00:00
|
||||
@@ -112,5 +112,3 @@
|
||||
[target."cfg(target_os = \"linux\")".dev-dependencies.timerfd]
|
||||
version = "1"
|
||||
|
||||
-[target."cfg(windows)".dev-dependencies.uds_windows]
|
||||
-version = "1"
|
@ -0,0 +1,73 @@
|
||||
# Generated by rust2rpm 25
|
||||
# * resolve circular dependency between async-{channel,net} and async-io
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate async-io
|
||||
|
||||
Name: rust-async-io1
|
||||
Version: 1.13.0
|
||||
Release: %autorelease
|
||||
Summary: Async I/O and timers
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/async-io
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: async-io-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Async I/O and timers.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,4 @@
|
||||
[tests]
|
||||
run = ["none"]
|
||||
comments = ["resolve circular dependency between async-{channel,net} and async-io"]
|
||||
|
Loading…
Reference in new issue