parent
69319bfda1
commit
4c6faea583
@ -0,0 +1 @@
|
||||
/async-fs-1.6.0.crate
|
@ -0,0 +1,9 @@
|
||||
--- async-fs-1.6.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ async-fs-1.6.0/Cargo.toml 2024-01-05T18:36:13.800729+00:00
|
||||
@@ -48,6 +48,3 @@
|
||||
[target."cfg(unix)".dev-dependencies.libc]
|
||||
version = "0.2.78"
|
||||
|
||||
-[target."cfg(windows)".dev-dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = ["winbase"]
|
@ -0,0 +1,72 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate async-fs
|
||||
|
||||
Name: rust-async-fs1
|
||||
Version: 1.6.0
|
||||
Release: %autorelease
|
||||
Summary: Async filesystem primitives
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/async-fs
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: async-fs-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Async filesystem primitives.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue