You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
275 lines
7.5 KiB
275 lines
7.5 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate askama_derive
|
|
|
|
Name: rust-askama_derive
|
|
Version: 0.12.1
|
|
Release: %autorelease
|
|
Summary: Procedural macro package for Askama
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/askama_derive
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Procedural macro package for Askama.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+basic-toml-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+basic-toml-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "basic-toml" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+basic-toml-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+config-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+config-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "config" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+config-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+humansize-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+humansize-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "humansize" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+humansize-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+markdown-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+markdown-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "markdown" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+markdown-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+num-traits-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+num-traits-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "num-traits" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+num-traits-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-json-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-json-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde-json" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-json-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-yaml-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-yaml-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde-yaml" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-yaml-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+urlencode-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+urlencode-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "urlencode" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+urlencode-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-actix-web-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-actix-web-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-actix-web" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-actix-web-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-axum-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-axum-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-axum" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-axum-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-gotham-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-gotham-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-gotham" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-gotham-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-hyper-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-hyper-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-hyper" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-hyper-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-mendes-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-mendes-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-mendes" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-mendes-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-rocket-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-rocket-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-rocket" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-rocket-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-tide-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-tide-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-tide" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-tide-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-warp-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-warp-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-warp" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-warp-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|