You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-alphanumeric-sort/rust-alphanumeric-sort.spec

82 lines
1.8 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate alphanumeric-sort
Name: rust-alphanumeric-sort
Version: 1.5.3
Release: %autorelease
Summary: Can help you sort order for files and folders whose names contain numerals
License: MIT
URL: https://crates.io/crates/alphanumeric-sort
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
This crate can help you sort order for files and folders whose names
contain numerals.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog