parent
7bae531435
commit
ef3e2fd490
@ -0,0 +1 @@
|
||||
/aho-corasick-0.6.3.crate
|
@ -0,0 +1,11 @@
|
||||
--- aho-corasick-0.6.3/Cargo.toml 2017-03-17T01:43:22+01:00
|
||||
+++ aho-corasick-0.6.3/Cargo.toml 2017-11-08T17:21:47.059390+01:00
|
||||
@@ -21,7 +21,7 @@
|
||||
bench = false
|
||||
|
||||
[dependencies]
|
||||
-memchr = "1"
|
||||
+memchr = "2"
|
||||
|
||||
[dev-dependencies]
|
||||
csv = "0.15"
|
@ -0,0 +1,88 @@
|
||||
# Generated by rust2rpm
|
||||
# aho-corasick(dev) -> quickcheck(opt) -> env_logger(opt) -> regex -> aho-corasick
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate aho-corasick
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.3
|
||||
Release: 3%{?dist}
|
||||
Summary: Fast multiple substring searching with finite state machines
|
||||
|
||||
License: Unlicense or MIT
|
||||
URL: https://crates.io/crates/aho-corasick
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * bump memchr to 2, https://github.com/BurntSushi/aho-corasick/commit/c880e210269d5f35bb64cf0e78071e6ea990d14e
|
||||
Patch0: aho-corasick-0.6.3-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(csv) >= 0.15.0 with crate(csv) < 0.16.0)
|
||||
BuildRequires: (crate(docopt) >= 0.7.0 with crate(docopt) < 0.8.0)
|
||||
BuildRequires: (crate(memmap) >= 0.5.0 with crate(memmap) < 0.6.0)
|
||||
BuildRequires: (crate(quickcheck) >= 0.4.0 with crate(quickcheck) < 0.5.0)
|
||||
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.4.0)
|
||||
BuildRequires: (crate(rustc-serialize) >= 0.3.0 with crate(rustc-serialize) < 0.4.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Fast multiple substring searching with finite state machines.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license UNLICENSE LICENSE-MIT COPYING
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/{ctags.rust,session.vim}
|
||||
%exclude %{_bindir}/aho-corasick-dot
|
||||
|
||||
%changelog
|
||||
* Wed Nov 08 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-3
|
||||
- Bump memchr to 2
|
||||
|
||||
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-2
|
||||
- Port to use rust-packaging
|
||||
|
||||
* Thu Mar 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.3-1
|
||||
- Update to 0.6.3
|
||||
|
||||
* Sat Mar 11 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.2-3
|
||||
- Rename with rust prefix
|
||||
- Don't ship useless binary
|
||||
|
||||
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.2-2
|
||||
- Use rich dependencies
|
||||
|
||||
* Sat Feb 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.2-1
|
||||
- Initial package
|
Loading…
Reference in new issue