Update to version 0.8.6; Fixes RHBZ#2245597

epel10
Fabio Valentini 1 year ago
parent 916a374014
commit a4bc0669ab
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -11,3 +11,5 @@
/ahash-0.7.6.crate
/ahash-0.8.2.crate
/ahash-0.8.3.crate
/ahash-0.8.5.crate
/ahash-0.8.6.crate

@ -1,3 +0,0 @@
# rust-ahash
The rust-ahash package

@ -1,50 +1,21 @@
--- ahash-0.8.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ahash-0.8.3/Cargo.toml 2023-02-21T12:39:50.969193+00:00
@@ -48,22 +48,10 @@
]
features = ["std"]
--- ahash-0.8.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ahash-0.8.6/Cargo.toml 2023-10-27T12:03:48.887092+00:00
@@ -79,11 +79,6 @@
path = "tests/bench.rs"
harness = false
-[profile.bench]
-opt-level = 3
+[profile.release]
lto = "fat"
-codegen-units = 1
-debug = false
-debug-assertions = false
-
-[profile.release]
-opt-level = 3
-lto = "fat"
-codegen-units = 1
-debug = false
-debug-assertions = false
[profile.test]
-opt-level = 2
lto = "fat"
[lib]
@@ -73,16 +61,6 @@
doctest = true
bench = true
doc = true
-
-[[bench]]
-name = "ahash"
-path = "tests/bench.rs"
-harness = false
-
-[[bench]]
-name = "map"
-path = "tests/map_tests.rs"
-harness = false
-
[dependencies.atomic-polyfill]
version = "1.0.1"
@@ -102,10 +80,6 @@
[dependencies.serde]
version = "1.0.117"
optional = true
@@ -107,10 +102,6 @@
version = "0.7.14"
features = ["simd"]
default-features = false
-
-[dev-dependencies.criterion]
-version = "0.3.2"

@ -1,11 +1,11 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate ahash
Name: rust-ahash
Version: 0.8.3
Version: 0.8.6
Release: %autorelease
Summary: Non-cryptographic hash function using AES-NI for high performance
@ -14,7 +14,6 @@ URL: https://crates.io/crates/ahash
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused benchmarks and benchmark-only criterion dev-dependency
# * drop profiles which set incompatible compiler flags
Patch: ahash-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
@ -149,7 +148,7 @@ use the "std" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# remove benchmark sources from non-standard path in tests/
rm tests/{bench.rs,map_tests.rs}

@ -1 +1 @@
SHA512 (ahash-0.8.3.crate) = cf2d2f1201ac0969cf4e2a0c47090bee971b2287ac44b5e091c90a9eced03cf6ff56d7900cc0f529d4acedc30bd400261c15e50efabdd1731f79951b449af53e
SHA512 (ahash-0.8.6.crate) = 46428b27e96be1f30058b9383a94988beeb5064dfb4df04d6959b451d0c77ef69fc51f07fdf9511ab9728295eb6beee7783c31a2297f9e473fc537883e722b73

Loading…
Cancel
Save