Update to version 0.10.1; Fixes RHBZ#2112728

epel9
Fabio Valentini 2 years ago
parent 96d79320d5
commit 9fc7eb688c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/aes-gcm-0.8.0.crate
/aes-gcm-0.9.2.crate
/aes-gcm-0.9.4.crate
/aes-gcm-0.10.1.crate

@ -1,3 +0,0 @@
[DEFAULT]
unwanted-features =
heapless

@ -1,16 +0,0 @@
--- aes-gcm-0.9.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ aes-gcm-0.9.4/Cargo.toml 2021-09-29T15:56:16.778431+00:00
@@ -44,11 +44,11 @@
default-features = false
[dependencies.subtle]
-version = ">=2, <2.5"
+version = "2"
default-features = false
[dependencies.zeroize]
-version = ">=1, <1.4"
+version = "1"
optional = true
default-features = false
[dev-dependencies.aead]

@ -1,33 +1,24 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate aes-gcm
Name: rust-%{crate}
Version: 0.9.4
Name: rust-aes-gcm
Version: 0.10.1
Release: %autorelease
Summary: Pure Rust implementation of the AES-GCM AEAD Cipher
# Upstream license specification: Apache-2.0 OR MIT
License: ASL 2.0 or MIT
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/aes-gcm
Source: %{crates_source}
# Initial patched metadata
# * relax subtle and zeroize dependencies
Patch0: aes-gcm-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Pure Rust implementation of the AES-GCM (Galois/Counter Mode) Authenticated
Encryption with Associated Data (AEAD) Cipher with optional architecture-
specific hardware acceleration.}
Pure Rust implementation of the AES-GCM (Galois/Counter Mode)
Authenticated Encryption with Associated Data (AEAD) Cipher with
optional architecture-specific hardware acceleration.}
%description %{_description}
@ -37,13 +28,15 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -51,11 +44,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aes-devel
Summary: %{summary}
@ -63,11 +56,11 @@ BuildArch: noarch
%description -n %{name}+aes-devel %{_description}
This package contains library source intended for building other packages
which use "aes" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "aes" feature of the "%{crate}" crate.
%files -n %{name}+aes-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
@ -75,35 +68,35 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+armv8-devel
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+armv8-devel %{_description}
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages
which use "armv8" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+armv8-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+force-soft-devel
%package -n %{name}+heapless-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+force-soft-devel %{_description}
%description -n %{name}+heapless-devel %{_description}
This package contains library source intended for building other packages
which use "force-soft" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "heapless" feature of the "%{crate}" crate.
%files -n %{name}+force-soft-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%files -n %{name}+heapless-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -111,11 +104,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stream-devel
Summary: %{summary}
@ -123,11 +116,11 @@ BuildArch: noarch
%description -n %{name}+stream-devel %{_description}
This package contains library source intended for building other packages
which use "stream" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "stream" feature of the "%{crate}" crate.
%files -n %{name}+stream-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize-devel
Summary: %{summary}
@ -135,11 +128,11 @@ BuildArch: noarch
%description -n %{name}+zeroize-devel %{_description}
This package contains library source intended for building other packages
which use "zeroize" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.
%files -n %{name}+zeroize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (aes-gcm-0.9.4.crate) = 68cb984c1b29a6266ce5286295fd944183c32a88c1f63b8ad38a0899cb312a00a67bdff8a9d09d8193ff579d7f61f14fd3eb92fbd9f647efc004e610069c424b
SHA512 (aes-gcm-0.10.1.crate) = aae1fc8e9e7fece42c09f94bce384db851f38a813487d68fa404c69b536d01a1f5487848f4e9a6450b1737a77642d03aed62224b0142366c9462d5cdd5fe495f

Loading…
Cancel
Save