You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-aead/rust-aead.spec

193 lines
5.0 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate aead
Name: rust-aead
Version: 0.5.2
Release: %autorelease
Summary: Traits for Authenticated Encryption with Associated Data
License: MIT OR Apache-2.0
URL: https://crates.io/crates/aead
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Traits for Authenticated Encryption with Associated Data (AEAD)
algorithms, such as AES-GCM as ChaCha20Poly1305, which provide a high-
level API.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arrayvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arrayvec-devel %{_description}
This package contains library source intended for building other packages which
use the "arrayvec" feature of the "%{crate}" crate.
%files -n %{name}+arrayvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blobby-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blobby-devel %{_description}
This package contains library source intended for building other packages which
use the "blobby" feature of the "%{crate}" crate.
%files -n %{name}+blobby-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "bytes" feature of the "%{crate}" crate.
%files -n %{name}+bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dev-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dev-devel %{_description}
This package contains library source intended for building other packages which
use the "dev" feature of the "%{crate}" crate.
%files -n %{name}+dev-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+heapless-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+heapless-devel %{_description}
This package contains library source intended for building other packages which
use the "heapless" feature of the "%{crate}" crate.
%files -n %{name}+heapless-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand_core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_core-devel %{_description}
This package contains library source intended for building other packages which
use the "rand_core" feature of the "%{crate}" crate.
%files -n %{name}+rand_core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stream-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+stream-devel %{_description}
This package contains library source intended for building other packages which
use the "stream" feature of the "%{crate}" crate.
%files -n %{name}+stream-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog