You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
84 lines
2.8 KiB
84 lines
2.8 KiB
From 6d094deb4f79d2d343bcc6c77b1c1d32cd17ede4 Mon Sep 17 00:00:00 2001
|
|
From: Fabio Valentini <decathorpe@gmail.com>
|
|
Date: Tue, 24 Sep 2024 18:58:57 +0200
|
|
Subject: [PATCH 1/6] drop Windows- and macOS-specific dependencies
|
|
|
|
---
|
|
crates/red_knot_server/Cargo.toml | 3 ---
|
|
crates/ruff/Cargo.toml | 3 ---
|
|
crates/ruff_benchmark/Cargo.toml | 3 ---
|
|
crates/ruff_db/Cargo.toml | 3 ---
|
|
crates/ruff_server/Cargo.toml | 3 ---
|
|
5 files changed, 15 deletions(-)
|
|
|
|
diff --git a/crates/red_knot_server/Cargo.toml b/crates/red_knot_server/Cargo.toml
|
|
index a2bfef6..262fd4e 100644
|
|
--- a/crates/red_knot_server/Cargo.toml
|
|
+++ b/crates/red_knot_server/Cargo.toml
|
|
@@ -32,8 +32,5 @@ tracing-subscriber = { workspace = true }
|
|
|
|
[dev-dependencies]
|
|
|
|
-[target.'cfg(target_vendor = "apple")'.dependencies]
|
|
-libc = { workspace = true }
|
|
-
|
|
[lints]
|
|
workspace = true
|
|
diff --git a/crates/ruff/Cargo.toml b/crates/ruff/Cargo.toml
|
|
index cb7e991..fb3fb93 100644
|
|
--- a/crates/ruff/Cargo.toml
|
|
+++ b/crates/ruff/Cargo.toml
|
|
@@ -76,9 +76,6 @@ test-case = { workspace = true }
|
|
# Used via macro expansion.
|
|
ignored = ["chrono"]
|
|
|
|
-[target.'cfg(target_os = "windows")'.dependencies]
|
|
-mimalloc = { workspace = true }
|
|
-
|
|
[target.'cfg(all(not(target_os = "windows"), not(target_os = "openbsd"), any(target_arch = "x86_64", target_arch = "aarch64", target_arch = "powerpc64")))'.dependencies]
|
|
tikv-jemallocator = { workspace = true }
|
|
|
|
diff --git a/crates/ruff_benchmark/Cargo.toml b/crates/ruff_benchmark/Cargo.toml
|
|
index 9df32cd..3712134 100644
|
|
--- a/crates/ruff_benchmark/Cargo.toml
|
|
+++ b/crates/ruff_benchmark/Cargo.toml
|
|
@@ -62,8 +62,5 @@ workspace = true
|
|
[features]
|
|
codspeed = ["codspeed-criterion-compat"]
|
|
|
|
-[target.'cfg(target_os = "windows")'.dev-dependencies]
|
|
-mimalloc = { workspace = true }
|
|
-
|
|
[target.'cfg(all(not(target_os = "windows"), not(target_os = "openbsd"), any(target_arch = "x86_64", target_arch = "aarch64", target_arch = "powerpc64")))'.dev-dependencies]
|
|
tikv-jemallocator = { workspace = true }
|
|
diff --git a/crates/ruff_db/Cargo.toml b/crates/ruff_db/Cargo.toml
|
|
index 3410fe7..d0b4000 100644
|
|
--- a/crates/ruff_db/Cargo.toml
|
|
+++ b/crates/ruff_db/Cargo.toml
|
|
@@ -35,9 +35,6 @@ tracing-tree = { workspace = true, optional = true }
|
|
rustc-hash = { workspace = true }
|
|
zip = { workspace = true }
|
|
|
|
-[target.'cfg(target_arch="wasm32")'.dependencies]
|
|
-web-time = { version = "1.1.0" }
|
|
-
|
|
[dev-dependencies]
|
|
insta = { workspace = true }
|
|
tempfile = { workspace = true }
|
|
diff --git a/crates/ruff_server/Cargo.toml b/crates/ruff_server/Cargo.toml
|
|
index 6f48754..83f1fa5 100644
|
|
--- a/crates/ruff_server/Cargo.toml
|
|
+++ b/crates/ruff_server/Cargo.toml
|
|
@@ -43,8 +43,5 @@ tracing-subscriber = { workspace = true }
|
|
[dev-dependencies]
|
|
insta = { workspace = true }
|
|
|
|
-[target.'cfg(target_vendor = "apple")'.dependencies]
|
|
-libc = { workspace = true }
|
|
-
|
|
[lints]
|
|
workspace = true
|
|
--
|
|
2.46.1
|
|
|