also enhance .spec and .gitignore files. Resolves: rhbz#1632225epel9
parent
e3854a227b
commit
db4650fe0e
@ -1,4 +1,2 @@
|
||||
/cucumber-core-1.4.0.gem
|
||||
/cucumber-core-1.5.0.gem
|
||||
/cucumber-core-3.2.0.gem
|
||||
/rubygem-cucumber-core-3.2.0-spec.tar.gz
|
||||
/cucumber-core-*.gem
|
||||
/rubygem-cucumber-core-*-spec.txz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From a88115f8668ff9c2ca91e11afc0529105c06446f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?David=20Rodr=C3=ADguez?= <deivid.rodriguez@riseup.net>
|
||||
Date: Sun, 12 Jan 2020 13:41:59 +0100
|
||||
Subject: [PATCH] Remove unintended `private` call
|
||||
|
||||
From reading https://bugs.ruby-lang.org/issues/13249, I don't think
|
||||
`private` is having any effect here, since it's only supposed to affect
|
||||
further methods defined inside the current class method (if at all), and
|
||||
this method does not define any method inside itself.
|
||||
---
|
||||
lib/cucumber/core/test/result.rb | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/lib/cucumber/core/test/result.rb b/lib/cucumber/core/test/result.rb
|
||||
index 136002a..21d06c8 100644
|
||||
--- a/lib/cucumber/core/test/result.rb
|
||||
+++ b/lib/cucumber/core/test/result.rb
|
||||
@@ -9,7 +9,6 @@ module Result
|
||||
STRICT_AFFECTED_TYPES = [:flaky, :undefined, :pending].freeze
|
||||
|
||||
def self.ok?(type, be_strict = StrictConfiguration.new)
|
||||
- private
|
||||
class_name = type.to_s.slice(0, 1).capitalize + type.to_s.slice(1..-1)
|
||||
const_get(class_name).ok?(be_strict.strict?(type))
|
||||
end
|
@ -1,2 +1,2 @@
|
||||
SHA512 (cucumber-core-3.2.0.gem) = 98420a6ecde649609c985efb7c4fd5d11646eec587bf98de789174e3918718c3725bfe2dfd16bd62fe515db0b70dec5629ec5efa6f7a9fbbebf657b85a8af6cc
|
||||
SHA512 (rubygem-cucumber-core-3.2.0-spec.tar.gz) = 81df5aa8824e9f4b7fc958a7ff473c9b80a1bcbcc77868f0e2a937fced2e6386cfeef2eababa369f5b78cf89315e4fadc47f42b06176da2b7ac2932ca872e361
|
||||
SHA512 (cucumber-core-10.0.1.gem) = 228408c024b4a13b6144d4b03e35b804e5e53283073a34433eb0beae103aa5d5c278567076b91116e2bc1b1c5067bc2f627400fb97ee3593bada9788e6cad9f6
|
||||
SHA512 (rubygem-cucumber-core-10.0.1-spec.txz) = 599d1432924a0b6e07b209794f4d082c7bb86222318f567cd73e4e75a31572842801953c2a03cedace164b6e32fdaa15792d480181d94747a92782cb4a304609
|
||||
|
Loading…
Reference in new issue