You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
60 lines
2.3 KiB
60 lines
2.3 KiB
From 8af8f327457738620d2c85bd65db8cc5594585db Mon Sep 17 00:00:00 2001
|
|
From: Yuta Saito <kateinoigakukun@gmail.com>
|
|
Date: Wed, 27 Dec 2023 06:22:45 +0000
|
|
Subject: [PATCH 1/2] [Bug #20085] Use consistent default options for
|
|
`-mbranch-protection`
|
|
|
|
We need to use the same options for both C compiler and assembler
|
|
when `-mbranch-protection` is guessed by configure. Otherwise,
|
|
`coroutine/arm64/Context.{h,S}` will use incompatible PAC strategies.
|
|
---
|
|
configure.ac | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 9286946fc1..18b4247991 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -830,7 +830,10 @@ AS_IF([test "$GCC" = yes], [
|
|
AS_FOR(option, opt, [-mbranch-protection=pac-ret -msign-return-address=all], [
|
|
RUBY_TRY_CFLAGS(option, [branch_protection=yes], [branch_protection=no])
|
|
AS_IF([test "x$branch_protection" = xyes], [
|
|
+ # C compiler and assembler must be consistent for -mbranch-protection
|
|
+ # since they both check `__ARM_FEATURE_PAC_DEFAULT` definition.
|
|
RUBY_APPEND_OPTION(XCFLAGS, option)
|
|
+ RUBY_APPEND_OPTION(ASFLAGS, option)
|
|
break
|
|
])
|
|
])
|
|
--
|
|
2.43.0
|
|
|
|
|
|
From 80281e14e411e8e5fe4955effbb2c650a2f52667 Mon Sep 17 00:00:00 2001
|
|
From: Jarek Prokop <jprokop@redhat.com>
|
|
Date: Fri, 12 Jan 2024 18:33:34 +0100
|
|
Subject: [PATCH 2/2] aarch64: Prepend -mbranch-protection=standard option when
|
|
checking branch protection.
|
|
|
|
Related Upstream issue: https://bugs.ruby-lang.org/issues/20154
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 18b4247991..5ea8ada8f7 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -827,7 +827,7 @@ AS_IF([test "$GCC" = yes], [
|
|
|
|
# aarch64 branch protection
|
|
AS_CASE(["$target_cpu"], [aarch64], [
|
|
- AS_FOR(option, opt, [-mbranch-protection=pac-ret -msign-return-address=all], [
|
|
+ AS_FOR(option, opt, [-mbranch-protection=standard -mbranch-protection=pac-ret -msign-return-address=all], [
|
|
RUBY_TRY_CFLAGS(option, [branch_protection=yes], [branch_protection=no])
|
|
AS_IF([test "x$branch_protection" = xyes], [
|
|
# C compiler and assembler must be consistent for -mbranch-protection
|
|
--
|
|
2.43.0
|
|
|