import rubberband-1.9.0-1.el8

i8ce changed/i8ce/rubberband-1.9.0-1.el8
Sergey Cherevko 10 months ago
commit 890ac37488
Signed by: scherevko
GPG Key ID: D87CBBC16D2E4A72

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/rubberband-1.9.0.tar.bz2

@ -0,0 +1 @@
fa6e69b1fabada44cd270cea2911f989c1071f15 SOURCES/rubberband-1.9.0.tar.bz2

@ -0,0 +1,64 @@
# HG changeset patch
# User 'Michel Alexandre Salim <salimma@fedoraproject.org>'
# Date 1605661509 28800
# Tue Nov 17 17:05:09 2020 -0800
# Node ID a5ac0c9466c59d232d77ac2f82be55a1fb76d1d5
# Parent 9df2a19b93a3c4076f2c87cae5022d2b6ae6580e
Make INSTALL_LIBDIR configurable
Some Linux distributions have INSTALL_LIBDIR set to $(PREFIX)/lib64 rather
than $(PREFIX)/lib. Allow overriding this; @libdir@ defaults to '${exec_prefix}/lib'
so this is a no-op unless overridden.
Also use `INSTALL_LIBDIR` to configure `INSTALL_VAMPDIR`, `INSTALL_LADSPADIR` and
`INSTALL_PKGDIR`
diff -r 9df2a19b93a3 -r a5ac0c9466c5 Makefile.in
--- a/Makefile.in Tue Nov 17 16:48:50 2020 -0800
+++ b/Makefile.in Tue Nov 17 17:05:09 2020 -0800
@@ -23,11 +23,11 @@
INSTALL_BINDIR := $(PREFIX)/bin
INSTALL_INCDIR := $(PREFIX)/include/rubberband
-INSTALL_LIBDIR := $(PREFIX)/lib
-INSTALL_VAMPDIR := $(PREFIX)/lib/vamp
-INSTALL_LADSPADIR := $(PREFIX)/lib/ladspa
+INSTALL_LIBDIR := @libdir@
+INSTALL_VAMPDIR := $(INSTALL_LIBDIR)/vamp
+INSTALL_LADSPADIR := $(INSTALL_LIBDIR)/ladspa
INSTALL_LRDFDIR := $(PREFIX)/share/ladspa/rdf
-INSTALL_PKGDIR := $(PREFIX)/lib/pkgconfig
+INSTALL_PKGDIR := $(INSTALL_LIBDIR)/pkgconfig
LIBNAME := librubberband
JNINAME := librubberband-jni
@@ -196,6 +196,7 @@
ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION)
test -f $(JNI_TARGET) && cp -fp $(JNI_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION) || true
sed "s,%PREFIX%,$(PREFIX)," rubberband.pc.in \
+ | sed "s,%LIBDIR%,$(INSTALL_LIBDIR)," \
> $(DESTDIR)$(INSTALL_PKGDIR)/rubberband.pc
ifeq ($(WITH_PROGRAMS), yes)
$(MKDIR) -p $(DESTDIR)$(INSTALL_BINDIR)
diff -r 9df2a19b93a3 -r a5ac0c9466c5 Makefile.osx
--- a/Makefile.osx Tue Nov 17 16:48:50 2020 -0800
+++ b/Makefile.osx Tue Nov 17 17:05:09 2020 -0800
@@ -177,6 +177,7 @@
cp ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
cp ladspa/ladspa-rubberband.rdf $(DESTDIR)$(INSTALL_LRDFDIR)
sed "s,%PREFIX%,$(PREFIX)," rubberband.pc.in \
+ | sed "s,%LIBDIR%,$(INSTALL_LIBDIR)," \
> $(DESTDIR)$(INSTALL_PKGDIR)/rubberband.pc
clean:
diff -r 9df2a19b93a3 -r a5ac0c9466c5 rubberband.pc.in
--- a/rubberband.pc.in Tue Nov 17 16:48:50 2020 -0800
+++ b/rubberband.pc.in Tue Nov 17 17:05:09 2020 -0800
@@ -1,6 +1,6 @@
prefix=%PREFIX%
exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
+libdir=%LIBDIR%
includedir=${prefix}/include
Name: rubberband

@ -0,0 +1,56 @@
# HG changeset patch
# User 'Michel Alexandre Salim <salimma@fedoraproject.org>'
# Date 1605660530 28800
# Tue Nov 17 16:48:50 2020 -0800
# Node ID 9df2a19b93a3c4076f2c87cae5022d2b6ae6580e
# Parent 8f1295fa2ed4178ef84812b9909d2fc90cfa5bff
Preserve permissions when installing files
Use `cp -p` rather than `cp`
diff -r 8f1295fa2ed4 -r 9df2a19b93a3 Makefile.in
--- a/Makefile.in Thu Oct 08 11:20:52 2020 +0100
+++ b/Makefile.in Tue Nov 17 16:48:50 2020 -0800
@@ -186,32 +186,32 @@
$(MKDIR) -p $(DESTDIR)$(INSTALL_INCDIR)
$(MKDIR) -p $(DESTDIR)$(INSTALL_LIBDIR)
$(MKDIR) -p $(DESTDIR)$(INSTALL_PKGDIR)
- cp $(PUBLIC_INCLUDES) $(DESTDIR)$(INSTALL_INCDIR)
- cp $(STATIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)
+ cp -p $(PUBLIC_INCLUDES) $(DESTDIR)$(INSTALL_INCDIR)
+ cp -p $(STATIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)
rm -f $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_ABI_VERSION)
rm -f $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION)
rm -f $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION)
- cp $(DYNAMIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION)
+ cp -p $(DYNAMIC_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION)
ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_ABI_VERSION)
ln -s $(LIBNAME)$(DYNAMIC_EXTENSION).$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)$(DYNAMIC_EXTENSION)
- test -f $(JNI_TARGET) && cp -f $(JNI_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION) || true
+ test -f $(JNI_TARGET) && cp -fp $(JNI_TARGET) $(DESTDIR)$(INSTALL_LIBDIR)/$(JNINAME)$(DYNAMIC_EXTENSION) || true
sed "s,%PREFIX%,$(PREFIX)," rubberband.pc.in \
> $(DESTDIR)$(INSTALL_PKGDIR)/rubberband.pc
ifeq ($(WITH_PROGRAMS), yes)
$(MKDIR) -p $(DESTDIR)$(INSTALL_BINDIR)
- cp $(PROGRAM_TARGET) $(DESTDIR)$(INSTALL_BINDIR)
+ cp -p $(PROGRAM_TARGET) $(DESTDIR)$(INSTALL_BINDIR)
endif
ifeq ($(WITH_VAMP), yes)
$(MKDIR) -p $(DESTDIR)$(INSTALL_VAMPDIR)
- cp $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
- cp vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
+ cp -p $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
+ cp -p vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
endif
ifeq ($(WITH_LADSPA), yes)
$(MKDIR) -p $(DESTDIR)$(INSTALL_LADSPADIR)
$(MKDIR) -p $(DESTDIR)$(INSTALL_LRDFDIR)
- cp $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
- cp ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
- cp ladspa/ladspa-rubberband.rdf $(DESTDIR)$(INSTALL_LRDFDIR)
+ cp -p $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
+ cp -p ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
+ cp -p ladspa/ladspa-rubberband.rdf $(DESTDIR)$(INSTALL_LRDFDIR)
endif
clean:

@ -0,0 +1,164 @@
Name: rubberband
Version: 1.9.0
Release: 1%{?dist}
Summary: Audio time-stretching and pitch-shifting library
License: GPLv2+
URL: http://www.breakfastquay.com/rubberband/
Source0: https://breakfastquay.com/files/releases/%{name}-%{version}.tar.bz2
Patch0: %{name}-1.9.0-permissions.patch
Patch1: %{name}-1.9.0-libdir.patch
BuildRequires: gcc-c++
BuildRequires: ladspa-devel
BuildRequires: pkgconfig(fftw3)
BuildRequires: pkgconfig(samplerate)
BuildRequires: pkgconfig(sndfile)
BuildRequires: vamp-plugin-sdk-devel
Requires: ladspa
%description
Rubber Band is a library and utility program that permits you to change the
tempo and pitch of an audio recording independently of one another.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: pkgconfig
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%autosetup -p1
%build
%configure --disable-static
%make_build
%install
%make_install
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
%files
%license COPYING
%doc README.md
%{_bindir}/rubberband
%{_libdir}/*.so.*
%{_libdir}/ladspa/ladspa-rubberband.*
%{_datadir}/ladspa/rdf/ladspa-rubberband.rdf
%{_libdir}/vamp/vamp-rubberband.*
%files devel
%doc CHANGELOG
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/rubberband.pc
%changelog
* Wed Feb 28 2024 Sergey Cherevko <s.cherevko@msvsphere-os.ru> - 1.9.0-1
- Rebuilt for MSVSphere 8.9
* Tue Nov 17 2020 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.9.0-1
- Update to 1.9.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Wed Oct 17 2018 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.8.2-1
- Update to 1.8.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.8.1-6
- Rebuilt for GCC 5 C++11 ABI change
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Sun Oct 28 2012 Michel Salim <salimma@fedoraproject.org> - 1.8.1-1
- Update to 1.8.1
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
- Rebuilt for c++ ABI breakage
* Tue Jan 31 2012 Michel Salim <salimma@fedoraproject.org> - 1.7.0-1
- Update to 1.7.0
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Thu Jul 14 2011 Michel Salim <salimma@fedoraproject.org> - 1.6.0-1
- Update to 1.6.0
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Sat Jul 3 2010 Michel Salim <salimma@fedoraproject.org> - 1.5.0-2
- Fixed pkg-config version declaration
* Wed Jun 2 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5.0-1
- update to 1.5.0
- disable static libs
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Sun Feb 8 2009 Michel Salim <salimma@fedoraproject.org> - 1.2-3
- Fix compilation problem with GCC 4.4
* Sun Dec 14 2008 Michel Salim <salimma@fedoraproject.org> - 1.2-2
- Rebuild for vamp-plugins-sdk-2.0
* Thu Jul 17 2008 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.2-1
- Update to 1.2
* Sun Mar 30 2008 Michel Salim <michel.sylvan@gmail.com> - 1.0.1-1
- Initial package
Loading…
Cancel
Save