Backport patch to fix build with default GCC 10 options

epel9
Simone Caronni 5 years ago
parent aae5c12507
commit a5c22aad07

@ -0,0 +1,23 @@
diff --git a/src/remmina_stats.c b/src/remmina_stats.c
index a6eb6f609ba7f0a5d444da2eb9f34684725625a5..3b7cbf0bf61964cc027c936b753bece49986c193 100644
--- a/src/remmina_stats.c
+++ b/src/remmina_stats.c
@@ -159,8 +159,6 @@
#endif
#include "remmina_stats.h"
-struct utsname u;
-
struct ProfilesData {
GHashTable *proto_count;
GHashTable *proto_date;
@@ -864,9 +862,6 @@ JsonNode *remmina_stats_get_all()
json_builder_set_member_name(b, "REMMINAVERSION");
json_builder_add_value(b, n);
- if (uname(&u) == -1)
- g_print("uname:");
-
n = remmina_stats_get_os_info();
json_builder_set_member_name(b, "SYSTEM");
json_builder_add_value(b, n);

@ -2,7 +2,7 @@
Name: remmina
Version: 1.3.10
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Remote Desktop Client
License: GPLv2+ and MIT
URL: http://remmina.org
@ -19,6 +19,8 @@ ExcludeArch: aarch64
# So we can't use it directly only as instructions.
Source1: pluginBuild-CMakeLists.txt
Patch0: https://gitlab.com/Remmina/Remmina/commit/27f84d1c0a2e4c2432281f25ef3026bb00bbdc15.diff#/remmina-gcc10.patch
%if 0%{?fedora} || 0%{?rhel} >= 8
BuildRequires: cmake >= 3.0.0
%else
@ -355,6 +357,9 @@ appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/metainfo/*.appdat
%{_mandir}/man1/remmina-gnome.1.*
%changelog
* Sun Feb 09 2020 Simone Caronni <negativo17@gmail.com> - 1.3.10-2
- Backport patch to fix build with default GCC 10 options.
* Fri Feb 07 2020 Simone Caronni <negativo17@gmail.com> - 1.3.10-1
- Update to 1.3.10.

Loading…
Cancel
Save