Merge branch 'rawhide' into epel8

epel8
Phil Wyett 3 years ago
commit 0a37f71461

1
.gitignore vendored

@ -67,3 +67,4 @@ remmina-0.7.5.tar.gz
/remmina-1.4.23.tar.gz
/remmina-1.4.24.tar.gz
/remmina-1.4.25.tar.gz
/remmina-1.4.26.tar.gz

@ -1,38 +0,0 @@
diff --git a/src/rcw.c b/src/rcw.c
index 6f3cb2f18b615185c073fa4fc269804822e1b5df..94cf0d6f87f4ad5c2ffce8083e09ffef030b3c1c 100644
--- a/src/rcw.c
+++ b/src/rcw.c
@@ -3398,6 +3398,10 @@ void rco_closewin(RemminaProtocolWidget *gp)
}
}
if (cnnobj) {
+ if (REMMINA_IS_SCROLLED_VIEWPORT(cnnobj->scrolled_container)) {
+ REMMINA_DEBUG("deleting motion");
+ remmina_scrolled_viewport_remove_motion(REMMINA_SCROLLED_VIEWPORT(cnnobj->scrolled_container));
+ }
cnnobj->remmina_file = NULL;
g_free(cnnobj);
gp->cnnobj = NULL;
diff --git a/src/remmina_scrolled_viewport.c b/src/remmina_scrolled_viewport.c
index 44056519df2ab2430782183c6f820fe5e184cfd2..f42ec99ec20515974673df4090eb2a8becf368dd 100644
--- a/src/remmina_scrolled_viewport.c
+++ b/src/remmina_scrolled_viewport.c
@@ -38,6 +38,7 @@
#include "config.h"
#include "remmina_scrolled_viewport.h"
#include "remmina_pref.h"
+#include "remmina_log.h"
#include "remmina/remmina_trace_calls.h"
G_DEFINE_TYPE( RemminaScrolledViewport, remmina_scrolled_viewport, GTK_TYPE_EVENT_BOX)
@@ -156,6 +157,10 @@ static gboolean remmina_scrolled_viewport_leave(GtkWidget *widget, GdkEventCross
{
TRACE_CALL(__func__);
RemminaScrolledViewport *gsv = REMMINA_SCROLLED_VIEWPORT(widget);
+ if (gsv->viewport_motion_handler) {
+ REMMINA_DEBUG("cleaning motion ...");
+ remmina_scrolled_viewport_remove_motion(gsv);
+ }
gsv->viewport_motion_handler = g_timeout_add(20, remmina_scrolled_viewport_motion_timeout, gsv);
return FALSE;
}

@ -1,13 +0,0 @@
diff --git a/plugins/rdp/rdp_plugin.c b/plugins/rdp/rdp_plugin.c
index 725558cab62f94c64f251ee0770bfa560a614676..a01e4cc683d2788265f02b250cf6cbe6160606dc 100644
--- a/plugins/rdp/rdp_plugin.c
+++ b/plugins/rdp/rdp_plugin.c
@@ -530,7 +530,7 @@ BOOL rf_end_paint(rdpContext *context)
gdi = context->gdi;
rfi = (rfContext *)context;
- if (gdi == NULL || gdi->primary == NULL || gdi->primary->hdc == NULL)
+ if (gdi == NULL || gdi->primary == NULL || gdi->primary->hdc == NULL || gdi->primary->hdc->hwnd == NULL)
return TRUE;
if (gdi->primary->hdc->hwnd->invalid->null)

@ -1,8 +1,8 @@
%global release_commit_hash dd830b5eecaaf62fd84c42503b482b20d446ad97
%global release_commit_hash fa11b6d1c1f20922b594cc2a8c204f9ea6592836
Name: remmina
Version: 1.4.25
Release: 2%{?dist}
Version: 1.4.26
Release: 1%{?dist}
Summary: Remote Desktop Client
License: GPLv2+ and MIT
URL: https://remmina.org
@ -20,10 +20,6 @@ ExcludeArch: aarch64
# So we can't use it directly only as instructions.
Source1: pluginBuild-CMakeLists.txt
# Patches.
Patch0: 0001_vnc_close_all_close_git_55e2324a.patch
Patch1: 0002_rdp_possible_segv_git_3620efda.patch
%if 0%{?fedora} || 0%{?rhel} >= 8
BuildRequires: cmake
%else
@ -39,10 +35,15 @@ BuildRequires: kf5-kwallet-devel
BuildRequires: libappstream-glib
BuildRequires: libgcrypt-devel
BuildRequires: libsodium-devel
BuildRequires: python3-devel
BuildRequires: xdg-utils
%if 0%{?fedora} || 0%{?rhel} <= 8
BuildRequires: pkgconfig(appindicator3-0.1)
%endif
%if 0%{?fedora} || 0%{?rhel} <= 8
BuildRequires: pkgconfig(avahi-ui)
BuildRequires: pkgconfig(avahi-ui-gtk3)
%endif
BuildRequires: pkgconfig(freerdp2)
BuildRequires: pkgconfig(gtk+-3.0)
BuildRequires: pkgconfig(json-glib-1.0)
@ -50,7 +51,9 @@ BuildRequires: pkgconfig(libsecret-1)
BuildRequires: pkgconfig(libsoup-2.4)
BuildRequires: pkgconfig(libssh)
BuildRequires: pkgconfig(libvncserver)
%if 0%{?fedora} || 0%{?rhel} <= 8
BuildRequires: pkgconfig(spice-client-gtk-3.0)
%endif
BuildRequires: pkgconfig(vte-2.91)
BuildRequires: pkgconfig(webkit2gtk-4.0)
BuildRequires: pkgconfig(xkbfile)
@ -141,6 +144,7 @@ computers in front of either large monitors or tiny net-books.
This package contains the VNC plugin for the Remmina remote desktop
client.
%if 0%{?fedora} || 0%{?rhel} <= 8
%package plugins-spice
Summary: SPICE plugin for Remmina Remote Desktop Client
Requires: %{name}%{?_isa} = %{version}-%{release}
@ -152,6 +156,7 @@ computers in front of either large monitors or tiny net-books.
This package contains the SPICE plugin for the Remmina remote desktop
client.
%endif
%package plugins-www
Summary: WWW plugin for Remmina Remote Desktop Client
@ -178,6 +183,7 @@ This package contains the KDE Wallet plugin for the Remmina remote desktop
client. It will be activated automatically if KDE Wallet is installed and
running.
%if 0%{?fedora} || 0%{?rhel} <= 8
%package plugins-x2go
Summary: x2go plugin for Remmina Remote Desktop Client
Requires: %{name}%{?_isa} = %{version}-%{release}
@ -189,6 +195,18 @@ system administrators and travelers, who need to work with lots of remote
computers in front of either large monitors or tiny net-books.
This package contains the x2go plugin for the Remmina remote desktop client.
%endif
%package plugins-python
Summary: Pyhton plugin for Remmina Remote Desktop Client
Requires: %{name}%{?_isa} = %{version}-%{release}
%description plugins-python
Remmina is a remote desktop client written in GTK+, aiming to be useful for
system administrators and travelers, who need to work with lots of remote
computers in front of either large monitors or tiny net-books.
This package contains the python plugin for the Remmina remote desktop client.
%package gnome-session
Summary: Gnome Shell session for Remmina kiosk mode
@ -219,8 +237,16 @@ export CFLAGS="%{optflags} -std=gnu99"
%cmake3 \
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DWITH_APPINDICATOR=ON \
%if 0%{?fedora} || 0%{?rhel} <= 8
-DHAVE_LIBAPPINDICATOR=ON \
%else
-DHAVE_LIBAPPINDICATOR=OFF \
%endif
%if 0%{?fedora} || 0%{?rhel} <= 8
-DWITH_AVAHI=ON \
%else
-DWITH_AVAHI=OFF \
%endif
-DWITH_FREERDP=ON \
-DWITH_GCRYPT=ON \
-DWITH_GETTEXT=ON \
@ -228,10 +254,16 @@ export CFLAGS="%{optflags} -std=gnu99"
-DWITH_KIOSK_SESSION=ON \
-DWITH_LIBSSH=ON \
-DWITH_NEWS=OFF \
-DWITH_PYTHONLIBS=ON \
-DWITH_SPICE=ON \
-DWITH_TELEPATHY=OFF \
-DWITH_VTE=ON \
%if 0%{?fedora} || 0%{?rhel} <= 8
-DWITH_X2GO=ON
%else
-DWITH_X2GO=OFF
%endif
%cmake3_build
%install
@ -303,10 +335,12 @@ fi
%{_datadir}/icons/hicolor/*/emblems/org.remmina.Remmina-vnc-ssh-symbolic.svg
%{_datadir}/icons/hicolor/*/emblems/org.remmina.Remmina-vnc-symbolic.svg
%if 0%{?fedora} || 0%{?rhel} <= 8
%files plugins-spice
%{_libdir}/remmina/plugins/remmina-plugin-spice.so
%{_datadir}/icons/hicolor/*/emblems/org.remmina.Remmina-spice-ssh-symbolic.svg
%{_datadir}/icons/hicolor/*/emblems/org.remmina.Remmina-spice-symbolic.svg
%endif
%files plugins-www
%{_libdir}/remmina/plugins/remmina-plugin-www.so
@ -314,10 +348,15 @@ fi
%files plugins-kwallet
%{_libdir}/remmina/plugins/remmina-plugin-kwallet.so
%files plugins-python
%{_libdir}/remmina/plugins/remmina-plugin-python_wrapper.so
%if 0%{?fedora} || 0%{?rhel} <= 8
%files plugins-x2go
%{_libdir}/remmina/plugins/remmina-plugin-x2go.so
%{_datadir}/icons/hicolor/*/emblems/org.remmina.Remmina-x2go-ssh-symbolic.svg
%{_datadir}/icons/hicolor/*/emblems/org.remmina.Remmina-x2go-symbolic.svg
%endif
%files gnome-session
%{_bindir}/gnome-session-remmina
@ -328,6 +367,16 @@ fi
%{_mandir}/man1/remmina-gnome.1.*
%changelog
* Wed May 18 2022 Phil Wyett <philip.wyett@kathenas.org> - 1.4.26-1
- New upstream version 1.4.26.
- New python plugin enabled.
- Drop patches as no longer needed.
- EL9
- Disable avahi-ui and avahi-ui-gtk support.
- Disable libappindicator support.
- Disable spice plugin.
- Disable x2go plugin.
* Mon Mar 28 2022 Phil Wyett <philip.wyett@kathenas.org> - 1.4.25-2
- Add patch: 0001_vnc_close_all_close_git_55e2324a.patch
- Add patch: 0002_rdp_possible_segv_git_3620efda.patch

@ -1 +1 @@
SHA512 (remmina-1.4.25.tar.gz) = bae3cd59a2af99fec49f21af375030935a363591328ed352687a311324456af82636766bb6e82e214358b414331a23edd8bf3a9413f7f39280573f91a0102f84
SHA512 (remmina-1.4.26.tar.gz) = 4e1e2f4b4bbd14c037e3f93f1813156cdf8c425e553d2a34e44e90c18ba4e88e37a5e0942728926fcd50949972a39219e2d7449139edc46c1adfb59d20c8dd8f

Loading…
Cancel
Save