- Update to 1.0.11

f41
Orcan Ogetbil 15 years ago
parent c7a80982fb
commit 47b9ba5573

1
.gitignore vendored

@ -1 +1,2 @@
redland-1.0.10.tar.gz
/redland-1.0.11.tar.gz

@ -1,33 +0,0 @@
diff -rupN redland-1.0.10.old/src/Makefile.in redland-1.0.10/src/Makefile.in
--- redland-1.0.10.old/src/Makefile.in 2009-12-14 01:53:52.000000000 -0500
+++ redland-1.0.10/src/Makefile.in 2010-02-14 16:48:45.000000000 -0500
@@ -1383,7 +1383,7 @@ rdf_concepts_test: rdf_concepts.c librdf
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_concepts.c librdf.la
rdf_query_test: rdf_query.c rdf_query_results.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_query.c $(srcdir)/rdf_query_results.c librdf.la
+ $(COMPILE_LINK) -lraptor -lrasqal -DSTANDALONE $(srcdir)/rdf_query.c $(srcdir)/rdf_query_results.c librdf.la
rdf_serializer_test: rdf_serializer.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_serializer.c librdf.la
diff -rupN redland-1.0.10.old/utils/Makefile.in redland-1.0.10/utils/Makefile.in
--- redland-1.0.10.old/utils/Makefile.in 2009-12-14 01:53:52.000000000 -0500
+++ redland-1.0.10/utils/Makefile.in 2010-02-14 16:44:20.000000000 -0500
@@ -68,7 +68,7 @@ am__rdfproc_SOURCES_DIST = rdfproc.c get
@GETOPT_TRUE@am__objects_1 = getopt.$(OBJEXT)
am_rdfproc_OBJECTS = rdfproc.$(OBJEXT) $(am__objects_1)
rdfproc_OBJECTS = $(am_rdfproc_OBJECTS)
-rdfproc_LDADD = $(LDADD)
+rdfproc_LDADD = -lraptor -lrasqal $(LDADD)
rdfproc_DEPENDENCIES = $(top_builddir)/src/librdf.la
am_redland_db_upgrade_OBJECTS = db_upgrade.$(OBJEXT)
redland_db_upgrade_OBJECTS = $(am_redland_db_upgrade_OBJECTS)
@@ -317,7 +317,7 @@ LDADD = $(top_builddir)/src/librdf.la
AM_LDFLAGS = @LIBRDF_LDFLAGS@
redland_db_upgrade_SOURCES = db_upgrade.c
redland_virtuoso_test_SOURCES = redland-virtuoso-test.c
-redland_virtuoso_test_LDADD = @LIBRDF_LDFLAGS@ $(top_builddir)/src/librdf.la
+redland_virtuoso_test_LDADD = -lraptor @LIBRDF_LDFLAGS@ $(top_builddir)/src/librdf.la
rdfproc_SOURCES = rdfproc.c $(am__append_1)
all: all-am

@ -1,33 +0,0 @@
diff -up redland-1.0.10/src/Makefile.am.no_undefined redland-1.0.10/src/Makefile.am
--- redland-1.0.10/src/Makefile.am.no_undefined 2009-11-23 00:38:32.000000000 -0600
+++ redland-1.0.10/src/Makefile.am 2010-01-04 12:51:17.245649696 -0600
@@ -152,7 +152,7 @@ if STORAGE_VIRTUOSO
plugin_LTLIBRARIES += librdf_storage_virtuoso.la
librdf_storage_virtuoso_la_SOURCES = rdf_storage_virtuoso.c rdf_storage_virtuoso_internal.h
librdf_storage_virtuoso_la_CPPFLAGS = @ODBC_CFLAGS@
-librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@
+librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la
librdf_storage_virtuoso_la_LDFLAGS = -module -avoid-version
endif
diff -up redland-1.0.10/src/Makefile.in.no_undefined redland-1.0.10/src/Makefile.in
--- redland-1.0.10/src/Makefile.in.no_undefined 2009-12-14 00:53:52.000000000 -0600
+++ redland-1.0.10/src/Makefile.in 2010-01-04 12:56:01.389896396 -0600
@@ -214,7 +214,7 @@ librdf_storage_tstore_la_LINK = $(LIBTOO
$(librdf_storage_tstore_la_LDFLAGS) $(LDFLAGS) -o $@
@MODULAR_LIBRDF_TRUE@@STORAGE_TSTORE_TRUE@am_librdf_storage_tstore_la_rpath = \
@MODULAR_LIBRDF_TRUE@@STORAGE_TSTORE_TRUE@ -rpath $(plugindir)
-librdf_storage_virtuoso_la_DEPENDENCIES =
+librdf_storage_virtuoso_la_DEPENDENCIES = librdf.la
am__librdf_storage_virtuoso_la_SOURCES_DIST = rdf_storage_virtuoso.c \
rdf_storage_virtuoso_internal.h
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@am_librdf_storage_virtuoso_la_OBJECTS = librdf_storage_virtuoso_la-rdf_storage_virtuoso.lo
@@ -570,7 +570,7 @@ plugindir = $(libdir)/redland
@MODULAR_LIBRDF_TRUE@@STORAGE_POSTGRESQL_TRUE@librdf_storage_postgresql_la_LDFLAGS = -module -avoid-version
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_SOURCES = rdf_storage_virtuoso.c rdf_storage_virtuoso_internal.h
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_CPPFLAGS = @ODBC_CFLAGS@
-@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@
+@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la
@MODULAR_LIBRDF_TRUE@@STORAGE_VIRTUOSO_TRUE@librdf_storage_virtuoso_la_LDFLAGS = -module -avoid-version
librdf_la_LIBADD = \
@LTLIBOBJS@ @DIGEST_OBJS@ @HASH_OBJS@ \

@ -1,13 +0,0 @@
diff -up redland-1.0.10/redland-config.in.libs redland-1.0.10/redland-config.in
diff -up redland-1.0.10/redland.pc.in.libs redland-1.0.10/redland.pc.in
--- redland-1.0.10/redland.pc.in.libs 2009-04-12 20:01:30.000000000 -0500
+++ redland-1.0.10/redland.pc.in 2010-01-03 17:55:23.791897828 -0600
@@ -9,7 +9,7 @@ swig=${prefix}/share/redland/Redland.i
Name: Redland RDF API Library
Description: Redland RDF API and triple store library
-Requires: raptor >= @RAPTOR_MIN_VERSION@, rasqal >= @RASQAL_MIN_VERSION@, rasqal <= @RASQAL_MAX_VERSION@
+Requires.private: raptor >= @RAPTOR_MIN_VERSION@, rasqal >= @RASQAL_MIN_VERSION@, rasqal <= @RASQAL_MAX_VERSION@
Version: @VERSION@
Libs: -L${libdir} -lrdf
Libs.private: @LIBRDF_LDFLAGS@ @LIBRDF_PKGCONFIG_PRIVATE_LIBS@

@ -0,0 +1,107 @@
diff -rupN redland-1.0.11.old/src/Makefile.am redland-1.0.11/src/Makefile.am
--- redland-1.0.11.old/src/Makefile.am 2010-08-03 01:52:11.000000000 -0400
+++ redland-1.0.11/src/Makefile.am 2010-10-03 02:04:02.000000000 -0400
@@ -310,10 +310,10 @@ rdf_uri_test: rdf_uri.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_uri.c librdf.la
rdf_statement_test: rdf_statement.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_statement.c librdf.la
+ $(COMPILE_LINK) -lraptor -DSTANDALONE $(srcdir)/rdf_statement.c librdf.la
rdf_model_test: rdf_model.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_model.c librdf.la
+ $(COMPILE_LINK) -lraptor -DSTANDALONE $(srcdir)/rdf_model.c librdf.la
rdf_storage_test: rdf_storage.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_storage.c librdf.la
@@ -334,7 +334,7 @@ rdf_concepts_test: rdf_concepts.c librdf
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_concepts.c librdf.la
rdf_query_test: rdf_query.c rdf_query_results.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_query.c $(srcdir)/rdf_query_results.c librdf.la
+ $(COMPILE_LINK) -lraptor -lrasqal -DSTANDALONE $(srcdir)/rdf_query.c $(srcdir)/rdf_query_results.c librdf.la
rdf_serializer_test: rdf_serializer.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_serializer.c librdf.la
@@ -349,7 +349,7 @@ rdf_avltree_test: rdf_avltree.c librdf.l
$(COMPILE_LINK) -DLIBRDF_DEBUG=2 -DSTANDALONE $(srcdir)/rdf_avltree.c librdf.la
rdf_init_test: rdf_init.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_init.c librdf.la
+ $(COMPILE_LINK) -lrasqal -DSTANDALONE $(srcdir)/rdf_init.c librdf.la
@SET_MAKE@
diff -rupN redland-1.0.11.old/src/Makefile.in redland-1.0.11/src/Makefile.in
--- redland-1.0.11.old/src/Makefile.in 2010-09-25 01:07:21.000000000 -0400
+++ redland-1.0.11/src/Makefile.in 2010-10-03 02:04:17.000000000 -0400
@@ -1405,10 +1405,10 @@ rdf_uri_test: rdf_uri.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_uri.c librdf.la
rdf_statement_test: rdf_statement.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_statement.c librdf.la
+ $(COMPILE_LINK) -lraptor -DSTANDALONE $(srcdir)/rdf_statement.c librdf.la
rdf_model_test: rdf_model.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_model.c librdf.la
+ $(COMPILE_LINK) -lraptor -DSTANDALONE $(srcdir)/rdf_model.c librdf.la
rdf_storage_test: rdf_storage.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_storage.c librdf.la
@@ -1429,7 +1429,7 @@ rdf_concepts_test: rdf_concepts.c librdf
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_concepts.c librdf.la
rdf_query_test: rdf_query.c rdf_query_results.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_query.c $(srcdir)/rdf_query_results.c librdf.la
+ $(COMPILE_LINK) -lraptor -lrasqal -DSTANDALONE $(srcdir)/rdf_query.c $(srcdir)/rdf_query_results.c librdf.la
rdf_serializer_test: rdf_serializer.c librdf.la
$(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_serializer.c librdf.la
@@ -1444,7 +1444,7 @@ rdf_avltree_test: rdf_avltree.c librdf.l
$(COMPILE_LINK) -DLIBRDF_DEBUG=2 -DSTANDALONE $(srcdir)/rdf_avltree.c librdf.la
rdf_init_test: rdf_init.c librdf.la
- $(COMPILE_LINK) -DSTANDALONE $(srcdir)/rdf_init.c librdf.la
+ $(COMPILE_LINK) -lrasqal -DSTANDALONE $(srcdir)/rdf_init.c librdf.la
@SET_MAKE@
diff -rupN redland-1.0.11.old/utils/Makefile.am redland-1.0.11/utils/Makefile.am
--- redland-1.0.11.old/utils/Makefile.am 2010-08-29 22:04:01.000000000 -0400
+++ redland-1.0.11/utils/Makefile.am 2010-10-03 01:44:43.000000000 -0400
@@ -28,12 +28,13 @@ AM_LDFLAGS=@LIBRDF_LDFLAGS@
redland_db_upgrade_SOURCES = db_upgrade.c
redland_virtuoso_test_SOURCES = redland-virtuoso-test.c
-redland_virtuoso_test_LDADD=@LIBRDF_LDFLAGS@ $(top_builddir)/src/librdf.la
+redland_virtuoso_test_LDADD= -lraptor @LIBRDF_LDFLAGS@ $(top_builddir)/src/librdf.la
rdfproc_SOURCES = rdfproc.c
if GETOPT
rdfproc_SOURCES += getopt.c rdfproc_getopt.h
endif
+rdfproc_LDADD = -lraptor
mysql-utils: $(MYSQL_UTILS)
diff -rupN redland-1.0.11.old/utils/Makefile.in redland-1.0.11/utils/Makefile.in
--- redland-1.0.11.old/utils/Makefile.in 2010-09-25 01:07:21.000000000 -0400
+++ redland-1.0.11/utils/Makefile.in 2010-10-03 01:43:51.000000000 -0400
@@ -65,7 +65,7 @@ am__rdfproc_SOURCES_DIST = rdfproc.c get
@GETOPT_TRUE@am__objects_1 = getopt.$(OBJEXT)
am_rdfproc_OBJECTS = rdfproc.$(OBJEXT) $(am__objects_1)
rdfproc_OBJECTS = $(am_rdfproc_OBJECTS)
-rdfproc_LDADD = $(LDADD)
+rdfproc_LDADD = -lraptor $(LDADD)
rdfproc_DEPENDENCIES = $(top_builddir)/src/librdf.la
am_redland_db_upgrade_OBJECTS = db_upgrade.$(OBJEXT)
redland_db_upgrade_OBJECTS = $(am_redland_db_upgrade_OBJECTS)
@@ -325,7 +325,7 @@ LDADD = $(top_builddir)/src/librdf.la
AM_LDFLAGS = @LIBRDF_LDFLAGS@
redland_db_upgrade_SOURCES = db_upgrade.c
redland_virtuoso_test_SOURCES = redland-virtuoso-test.c
-redland_virtuoso_test_LDADD = @LIBRDF_LDFLAGS@ $(top_builddir)/src/librdf.la
+redland_virtuoso_test_LDADD = -lraptor @LIBRDF_LDFLAGS@ $(top_builddir)/src/librdf.la
rdfproc_SOURCES = rdfproc.c $(am__append_1)
all: all-am

@ -1,6 +1,6 @@
Name: redland
Version: 1.0.10
Release: 8%{?dist}
Version: 1.0.11
Release: 1%{?dist}
Summary: RDF Application Framework
Group: System Environment/Libraries
@ -9,12 +9,10 @@ URL: http://librdf.org/
Source0: http://download.librdf.org/source/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch50: redland-1.0.10-pkgconfig_requires_private.patch
Patch51: redland-1.0.10-no_undefined.patch
# Fix DSO linking. Upstream is informed and will most likely do a more
# portable fix than this simple hack in their trunk
# http://bugs.librdf.org/mantis/view.php?id=348
Patch60: redland-1.0.10-linking.patch
Patch60: redland-1.0.11-linking.patch
BuildRequires: curl-devel
BuildRequires: db4-devel
@ -24,7 +22,7 @@ BuildRequires: libxml2-devel >= 2.4.0
BuildRequires: mysql-devel
BuildRequires: postgresql-devel
BuildRequires: raptor-devel >= 1.4.20
BuildRequires: rasqal-devel >= 0.9.17
BuildRequires: rasqal-devel >= 0.9.19
BuildRequires: sqlite-devel
%description
@ -76,8 +74,6 @@ persistently with Virtuoso files or URIs.
%prep
%setup -q
%patch50 -p1 -b .pkgconfig_requires_private
%patch51 -p1 -b .no_undefined
%patch60 -p1 -b .dso_linking
# hack to nuke rpaths
@ -160,6 +156,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sun Oct 03 2010 Orcan Ogetbil <oget[DOT]fedora[AT]gmail[DOT]com> - 1.0.11-1
- Update to 1.0.11
* Wed Sep 29 2010 jkeating - 1.0.10-8
- Rebuilt for gcc bug 634757

@ -1 +1 @@
bdbb9b8dc614fc09a14cd646079619e1 redland-1.0.10.tar.gz
e1769361c907a216c6a75fc692ba412b redland-1.0.11.tar.gz

Loading…
Cancel
Save