You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
realmd/SOURCES/0002-configure-update-some-...

78 lines
2.5 KiB

From cff19e9044e3f389a14fbc5e98366a31107d4a02 Mon Sep 17 00:00:00 2001
From: Sumit Bose <sbose@redhat.com>
Date: Tue, 6 Apr 2021 15:23:54 +0200
Subject: [PATCH 2/2] configure: update some macros for autoconf-2.71
---
configure.ac | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)
diff --git a/configure.ac b/configure.ac
index 05ec1bf..4dac5a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_PREREQ(2.63)
+AC_PREREQ([2.63])
AC_INIT([realmd], [0.17.0],
[https://gitlab.freedesktop.org/realmd/realmd/-/issues],
@@ -69,8 +69,7 @@ AC_ARG_WITH([vendor-error-message],
# -----------------------------------------------------------------------------
# Basic tools
-AC_GNU_SOURCE
-AC_ISC_POSIX
+AC_USE_SYSTEM_EXTENSIONS
AC_PROG_CC
AC_PROG_CPP
AM_PROG_CC_C_O
@@ -109,7 +108,7 @@ AC_SUBST(POLKIT_LIBS)
AC_MSG_CHECKING([systemd unit directory])
AC_ARG_WITH(systemd-unit-dir,
- AC_HELP_STRING([--with-systemd-unit-dir],
+ AS_HELP_STRING([--with-systemd-unit-dir],
[Directory to install systemd service file]))
if test "$with_systemd_unit_dir" = "" -o "$with_systemd_unit_dir" = "yes"; then
@@ -136,7 +135,7 @@ AC_SUBST(dbus_systemd_service)
AC_MSG_RESULT($with_systemd_unit_dir)
AC_ARG_WITH(systemd-journal,
- AC_HELP_STRING([--with-systemd-journal],
+ AS_HELP_STRING([--with-systemd-journal],
[Use systemd's journal for logging]))
if test "$with_systemd_journal" != "no"; then
@@ -245,7 +244,7 @@ AC_SUBST(POLKIT_ACTION_DIR)
AC_MSG_CHECKING([whether to build documentation])
AC_ARG_ENABLE(doc,
- AC_HELP_STRING([--enable-doc],
+ AS_HELP_STRING([--enable-doc],
[Disable building documentation])
)
@@ -314,7 +313,7 @@ AC_SUBST(GENHTML)
AC_MSG_CHECKING([for debug mode])
AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug=no/default/yes],
+ AS_HELP_STRING([--enable-debug=no/default/yes],
[Turn on or off debugging])
)
@@ -397,7 +396,7 @@ AC_SUBST(TEST_MODE)
privatedir='${prefix}/lib/realmd'
AC_MSG_CHECKING([private directory])
AC_ARG_WITH(private-dir,
- AC_HELP_STRING([--with-private-dir=DIR],
+ AS_HELP_STRING([--with-private-dir=DIR],
[Directory to install realmd system defaults (default: ${prefix}/lib/realmd)]))
if test -n "$with_private_dir"; then
--
2.30.2