parent
c3dafed644
commit
021de81696
@ -1 +1 @@
|
||||
504231f87024df9aceb90eb957196b557b4b8e38 SOURCES/raptor2-2.0.15.tar.gz
|
||||
504231f87024df9aceb90eb957196b557b4b8e38 SOURCES/raptor2-2.0.15.tar.gz
|
||||
|
@ -0,0 +1,47 @@
|
||||
commit 567d4d1ab639d924e8d5af459476f331b9af0ce5
|
||||
Author: Dave Beckett <dave@dajobe.org>
|
||||
Date: Tue Nov 4 15:25:20 2014 -0800
|
||||
|
||||
Fix error returns in new world methods
|
||||
|
||||
(raptor_world_get_parser_factory,
|
||||
raptor_world_get_serializers_count): Fix return value in assertions
|
||||
|
||||
diff --git a/src/raptor_parse.c b/src/raptor_parse.c
|
||||
index 26911f47752119c6..6caa7f1c231cc0c3 100644
|
||||
--- a/src/raptor_parse.c
|
||||
+++ b/src/raptor_parse.c
|
||||
@@ -252,12 +252,12 @@ raptor_world_get_parser_factory(raptor_world *world, const char *name)
|
||||
*
|
||||
* Get number of parsers
|
||||
*
|
||||
- * Return value: number of parsers
|
||||
+ * Return value: number of parsers or <0 on failure
|
||||
**/
|
||||
int
|
||||
raptor_world_get_parsers_count(raptor_world* world)
|
||||
{
|
||||
- RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, NULL);
|
||||
+ RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, -1);
|
||||
|
||||
raptor_world_open(world);
|
||||
|
||||
diff --git a/src/raptor_serialize.c b/src/raptor_serialize.c
|
||||
index a1f29d78d33f82ee..a0344418441a2295 100644
|
||||
--- a/src/raptor_serialize.c
|
||||
+++ b/src/raptor_serialize.c
|
||||
@@ -235,12 +235,12 @@ raptor_get_serializer_factory(raptor_world* world, const char *name)
|
||||
*
|
||||
* Get number of serializers
|
||||
*
|
||||
- * Return value: number of serializers
|
||||
+ * Return value: number of serializers or <0 on failure
|
||||
**/
|
||||
int
|
||||
raptor_world_get_serializers_count(raptor_world* world)
|
||||
{
|
||||
- RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, NULL);
|
||||
+ RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, -1);
|
||||
|
||||
raptor_world_open(world);
|
||||
|
@ -0,0 +1,35 @@
|
||||
Include <stdio.h> for printf in __FUNCTION__ check. Otherwise, the
|
||||
check will fail with compilers which do not implement implicit
|
||||
function declarations (a C feature that was removed in 1999 from the
|
||||
language), no matter if the compiler supports FUNCTION or not.
|
||||
|
||||
Submitted upstream: <https://github.com/dajobe/raptor/pull/56>
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index b0091892a210361d..08501ac8ed5e4fe1 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -13747,6 +13747,8 @@ esac
|
||||
$as_echo_n "checking whether __FUNCTION__ is available... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
+
|
||||
+#include <stdio.h>
|
||||
int main() { printf(__FUNCTION__); }
|
||||
_ACEOF
|
||||
if ac_fn_c_try_compile "$LINENO"; then :
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 10ff870805b82e65..40a8548b6406866a 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -312,7 +312,9 @@ AC_C_BIGENDIAN
|
||||
AC_C_INLINE
|
||||
|
||||
AC_MSG_CHECKING(whether __FUNCTION__ is available)
|
||||
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([int main() { printf(__FUNCTION__); }])],
|
||||
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
+#include <stdio.h>
|
||||
+int main() { printf(__FUNCTION__); }])],
|
||||
[AC_DEFINE([HAVE___FUNCTION__], [1], [Is __FUNCTION__ available])
|
||||
AC_MSG_RESULT(yes)],
|
||||
[AC_MSG_RESULT(no)])
|
@ -0,0 +1,28 @@
|
||||
commit 4dbc4c1da2a033c497d84a1291c46f416a9cac51
|
||||
Author: David Anes <david.anes@suse.com>
|
||||
Date: Thu May 4 11:54:02 2023 +0200
|
||||
|
||||
Remove the access to entities 'checked' private symbol for libxml2 2.11.0
|
||||
|
||||
Since version 2.11.0, some private symbols that were never intended
|
||||
as public API/ABI have been removed from libxml2, therefore the field
|
||||
'checked' is no longer present and raptor fails to build in this
|
||||
scenario.
|
||||
|
||||
diff --git a/src/raptor_libxml.c b/src/raptor_libxml.c
|
||||
index cee87a58e02c7e97..ecf76327d212c73a 100644
|
||||
--- a/src/raptor_libxml.c
|
||||
+++ b/src/raptor_libxml.c
|
||||
@@ -246,10 +246,11 @@ raptor_libxml_getEntity(void* user_data, const xmlChar *name)
|
||||
|
||||
ret->owner = 1;
|
||||
|
||||
-#if LIBXML_VERSION >= 20627
|
||||
+#if LIBXML_VERSION >= 20627 && LIBXML_VERSION < 21100
|
||||
/* Checked field was released in 2.6.27 on 2006-10-25
|
||||
* http://git.gnome.org/browse/libxml2/commit/?id=a37a6ad91a61d168ecc4b29263def3363fff4da6
|
||||
*
|
||||
+ * and was later removed in version 2.11.0
|
||||
*/
|
||||
|
||||
/* Mark this entity as having been checked - never do this again */
|
Loading…
Reference in new issue