parent
ee97c61e8e
commit
9320ac1a2e
@ -0,0 +1,26 @@
|
||||
diff -up quazip-0.7.2/quazip/CMakeLists.txt.orig quazip-0.7.2/quazip/CMakeLists.txt
|
||||
--- quazip-0.7.2/quazip/CMakeLists.txt.orig 2016-01-03 07:01:40.000000000 +0100
|
||||
+++ quazip-0.7.2/quazip/CMakeLists.txt 2016-04-27 14:07:12.492586196 +0200
|
||||
@@ -15,17 +15,17 @@ qt_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
|
||||
set(SRCS ${SRCS} ${MOC_SRCS})
|
||||
|
||||
add_library(${QUAZIP_LIB_TARGET_NAME} SHARED ${SRCS})
|
||||
-add_library(quazip_static STATIC ${SRCS})
|
||||
+#add_library(quazip_static STATIC ${SRCS})
|
||||
|
||||
# Windows uses .lib extension for both static and shared library
|
||||
# *nix systems use different extensions for SHARED and STATIC library and by convention both libraries have the same name
|
||||
if (NOT WIN32)
|
||||
- set_target_properties(quazip_static PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
||||
+ set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
||||
endif ()
|
||||
|
||||
-set_target_properties(${QUAZIP_LIB_TARGET_NAME} quazip_static PROPERTIES VERSION 1.0.0 SOVERSION 1 DEBUG_POSTFIX d)
|
||||
+set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES VERSION 1.0.0 SOVERSION 1 DEBUG_POSTFIX d)
|
||||
# Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
|
||||
-target_link_libraries(${QUAZIP_LIB_TARGET_NAME} quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
|
||||
+target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
|
||||
|
||||
install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
||||
-install(TARGETS ${QUAZIP_LIB_TARGET_NAME} quazip_static LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
|
||||
+install(TARGETS ${QUAZIP_LIB_TARGET_NAME} LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
|
Loading…
Reference in new issue