You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
29 lines
2.0 KiB
29 lines
2.0 KiB
diff -Nrup a/quazip/CMakeLists.txt b/quazip/CMakeLists.txt
|
|
--- a/quazip/CMakeLists.txt 2020-05-24 14:02:43.000000000 +0200
|
|
+++ b/quazip/CMakeLists.txt 2020-08-31 06:51:52.147988613 +0200
|
|
@@ -11,21 +11,18 @@ qt_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
|
|
set(SRCS ${SRCS} ${MOC_SRCS})
|
|
|
|
add_library(${QUAZIP_LIB_TARGET_NAME} SHARED ${SRCS})
|
|
-add_library(quazip_static STATIC ${SRCS})
|
|
|
|
# Windows uses .lib extension for both static and shared library
|
|
# *nix systems use different extensions for SHARED and STATIC library and by convention both libraries have the same name
|
|
if (NOT WIN32)
|
|
- set_target_properties(quazip_static PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
|
+ set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
|
endif ()
|
|
|
|
target_include_directories(${QUAZIP_LIB_TARGET_NAME} PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${ZLIB_INCLUDE_DIRS})
|
|
-target_include_directories(quazip_static PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${ZLIB_INCLUDE_DIRS})
|
|
-set_target_properties(${QUAZIP_LIB_TARGET_NAME} quazip_static PROPERTIES VERSION ${QUAZIP_LIB_VERSION} SOVERSION ${QUAZIP_LIB_SOVERSION} DEBUG_POSTFIX d)
|
|
+set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES VERSION ${QUAZIP_LIB_VERSION} SOVERSION ${QUAZIP_LIB_SOVERSION} DEBUG_POSTFIX d)
|
|
|
|
# Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
|
|
target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
|
|
-target_link_libraries(quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
|
|
|
|
install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
|
-install(TARGETS ${QUAZIP_LIB_TARGET_NAME} quazip_static LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
|
|
+install(TARGETS ${QUAZIP_LIB_TARGET_NAME} LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
|