Add patch3 to fix build (missing src file caused by typo) Add missing BuildRequiresepel9
parent
1c99e8c497
commit
320889cc2a
@ -0,0 +1,32 @@
|
||||
Index: qtwebkit-5.212.0-alpha2/CMakeLists.txt
|
||||
===================================================================
|
||||
--- qtwebkit-5.212.0-alpha2.orig/CMakeLists.txt
|
||||
+++ qtwebkit-5.212.0-alpha2/CMakeLists.txt
|
||||
@@ -6,6 +6,11 @@ if (POLICY CMP0058)
|
||||
cmake_policy(SET CMP0058 NEW)
|
||||
endif ()
|
||||
|
||||
+# Explicitly process generated files with AUTOMOC.
|
||||
+if (POLICY CMP0071)
|
||||
+ cmake_policy(SET CMP0071 NEW)
|
||||
+endif ()
|
||||
+
|
||||
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/Source/cmake")
|
||||
|
||||
if (NOT DEFINED ENABLE_WEBKIT)
|
||||
Index: qtwebkit-5.212.0-alpha2/Source/WebKit/CMakeLists.txt
|
||||
===================================================================
|
||||
--- qtwebkit-5.212.0-alpha2.orig/Source/WebKit/CMakeLists.txt
|
||||
+++ qtwebkit-5.212.0-alpha2/Source/WebKit/CMakeLists.txt
|
||||
@@ -1,6 +1,11 @@
|
||||
cmake_minimum_required(VERSION 2.8.12)
|
||||
include(WebKitCommon)
|
||||
|
||||
+# Explicitly process generated files with AUTOMOC.
|
||||
+if (POLICY CMP0071)
|
||||
+ cmake_policy(SET CMP0071 NEW)
|
||||
+endif ()
|
||||
+
|
||||
set(WebKit_SOURCES
|
||||
Storage/StorageAreaImpl.cpp
|
||||
Storage/StorageAreaSync.cpp
|
@ -0,0 +1,20 @@
|
||||
Index: qtwebkit-5.212.0-alpha2/Source/WebKit/PlatformQt.cmake
|
||||
===================================================================
|
||||
--- qtwebkit-5.212.0-alpha2.orig/Source/WebKit/PlatformQt.cmake
|
||||
+++ qtwebkit-5.212.0-alpha2/Source/WebKit/PlatformQt.cmake
|
||||
@@ -786,6 +786,7 @@ if (COMPILER_IS_GCC_OR_CLANG)
|
||||
set_source_files_properties(
|
||||
qt/Api/qwebdatabase.cpp
|
||||
qt/Api/qwebelement.cpp
|
||||
+ qt/Api/qwebfullscreenrequest.cpp
|
||||
qt/Api/qwebhistory.cpp
|
||||
qt/Api/qwebhistoryinterface.cpp
|
||||
qt/Api/qwebpluginfactory.cpp
|
||||
@@ -795,7 +796,6 @@ if (COMPILER_IS_GCC_OR_CLANG)
|
||||
|
||||
qt/WidgetApi/qgraphicswebview.cpp
|
||||
qt/WidgetApi/qwebframe.cpp
|
||||
- qt/WidgetApi/qwebfullscreenrequest.cpp
|
||||
qt/WidgetApi/qwebinspector.cpp
|
||||
qt/WidgetApi/qwebpage.cpp
|
||||
qt/WidgetApi/qwebview.cpp
|
Loading…
Reference in new issue