import qpid-proton-0.40.0-4.el9

i9ce changed/i9ce/qpid-proton-0.40.0-4.el9
MSVSphere Packaging Team 3 weeks ago
parent e95abd05ff
commit d2004851ff
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

3
.gitignore vendored

@ -1 +1,2 @@
SOURCES/qpid-proton-0.38.0.tar.gz
SOURCES/licenses.xml
SOURCES/qpid-proton-0.40.0.tar.gz

@ -1 +1,2 @@
e258816ad34f69577da2c41df77f5d50c112e645 SOURCES/qpid-proton-0.38.0.tar.gz
5f91baa0d79cfcae0ad6d5d4373d0ced13f05036 SOURCES/licenses.xml
82dc7396ca6a822d4226dee6509dda57bb874ed4 SOURCES/qpid-proton-0.40.0.tar.gz

@ -1,15 +0,0 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<licenseSummary>
<dependencies>
<dependency>
<packageName>qpid-proton</packageName>
<version>0.38.0</version>
<licenses>
<license>
<name>ASL 2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0</url>
</license>
</licenses>
</dependency>
</dependencies>
</licenseSummary>

@ -1,56 +1,40 @@
diff -ruN qpid-proton-0.38.0.orig/CMakeLists.txt qpid-proton-0.38.0/CMakeLists.txt
--- qpid-proton-0.38.0.orig/CMakeLists.txt 2022-11-07 11:35:09.000000000 -0500
+++ qpid-proton-0.38.0/CMakeLists.txt 2022-11-23 10:19:17.963751717 -0500
@@ -42,7 +42,7 @@
if (NOT DEFINED Python_FIND_FRAMEWORK)
set(Python_FIND_FRAMEWORK "LAST")
endif ()
-find_package(Python 3.6
+find_package(Python 3.9
REQUIRED COMPONENTS Interpreter
OPTIONAL_COMPONENTS Development)
diff -ruN qpid-proton-0.38.0.orig/cpp/src/map_test.cpp qpid-proton-0.38.0/cpp/src/map_test.cpp
--- qpid-proton-0.38.0.orig/cpp/src/map_test.cpp 2022-11-07 11:35:09.000000000 -0500
+++ qpid-proton-0.38.0/cpp/src/map_test.cpp 2023-01-26 10:49:44.159634165 -0500
@@ -114,6 +114,20 @@
ASSERT_THROWS(conversion_error, m.value(bad));
}
+void test_copy_constructor() {
+ proton::map<string, scalar> m = std::map<string, scalar>{{"a", 2}, {"b", 3}};
+ ASSERT_EQUAL(scalar(2), m.get("a"));
+ ASSERT_EQUAL(scalar(3), m.get("b"));
+ ASSERT_EQUAL(2U, m.size());
+}
+
+void test_initializer_list_constructor() {
+ proton::map<string, scalar> m({{"a", 2}, {"b", 3}});
+ ASSERT_EQUAL(scalar(2), m.get("a"));
+ ASSERT_EQUAL(scalar(3), m.get("b"));
+ ASSERT_EQUAL(2U, m.size());
+}
+
}
int main(int, char**) {
@@ -122,5 +136,7 @@
RUN_TEST(failed, test_use());
RUN_TEST(failed, test_cppmap());
RUN_TEST(failed, test_value());
+ RUN_TEST(failed, test_copy_constructor());
+ RUN_TEST(failed, test_initializer_list_constructor());
return failed;
}
diff -ruN qpid-proton-0.38.0.orig/python/CMakeLists.txt qpid-proton-0.38.0/python/CMakeLists.txt
--- qpid-proton-0.38.0.orig/python/CMakeLists.txt 2022-11-07 11:35:09.000000000 -0500
+++ qpid-proton-0.38.0/python/CMakeLists.txt 2022-11-23 10:20:07.216991810 -0500
@@ -101,7 +101,7 @@
COMMAND ${PN_ENV_SCRIPT} --
PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}:${CMAKE_CURRENT_SOURCE_DIR}
LD_LIBRARY_PATH="${CMAKE_CURRENT_BINARY_DIR}/c"
- ${Python_EXECUTABLE} -m sphinx "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
+ sphinx-build "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
add_dependencies(docs docs-py)
install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/docs/"
DESTINATION "${PROTON_SHARE}/docs/api-py"
diff -rc qpid-proton-0.40.0.orig/CMakeLists.txt qpid-proton-0.40.0/CMakeLists.txt
*** qpid-proton-0.40.0.orig/CMakeLists.txt Fri Nov 29 12:08:10 2024
--- qpid-proton-0.40.0/CMakeLists.txt Fri Nov 29 12:08:31 2024
***************
*** 42,48 ****
if (NOT DEFINED Python_FIND_FRAMEWORK)
set(Python_FIND_FRAMEWORK "LAST")
endif ()
! find_package(Python 3.9
REQUIRED COMPONENTS Interpreter
OPTIONAL_COMPONENTS Development)
--- 42,48 ----
if (NOT DEFINED Python_FIND_FRAMEWORK)
set(Python_FIND_FRAMEWORK "LAST")
endif ()
! find_package(Python 3.12
REQUIRED COMPONENTS Interpreter
OPTIONAL_COMPONENTS Development)
diff -rc qpid-proton-0.40.0.orig/python/CMakeLists.txt qpid-proton-0.40.0/python/CMakeLists.txt
*** qpid-proton-0.40.0.orig/python/CMakeLists.txt Fri Nov 29 12:08:10 2024
--- qpid-proton-0.40.0/python/CMakeLists.txt Fri Nov 29 12:09:04 2024
***************
*** 74,80 ****
COMMAND ${PN_ENV_SCRIPT} --
PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}:${CMAKE_CURRENT_SOURCE_DIR}
LD_LIBRARY_PATH="${CMAKE_CURRENT_BINARY_DIR}/c"
! ${Python_EXECUTABLE} -m sphinx "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
add_dependencies(docs docs-py)
install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/docs/"
DESTINATION "${PROTON_SHARE}/docs/api-py"
--- 74,80 ----
COMMAND ${PN_ENV_SCRIPT} --
PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}:${CMAKE_CURRENT_SOURCE_DIR}
LD_LIBRARY_PATH="${CMAKE_CURRENT_BINARY_DIR}/c"
! sphinx-build "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
add_dependencies(docs docs-py)
install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/docs/"
DESTINATION "${PROTON_SHARE}/docs/api-py"

@ -7,42 +7,41 @@
%undefine __brp_mangle_shebangs
Name: qpid-proton
Version: 0.38.0
Release: 1%{?dist}
Version: 0.40.0
Release: 4%{?dist}
Summary: A high performance, lightweight messaging library
License: ASL 2.0
# Automatically converted from old format: ASL 2.0 - review is highly recommended.
License: Apache-2.0
URL: http://qpid.apache.org/proton/
Source0: %{name}-%{version}.tar.gz
Patch0: proton.patch
Source1: licenses.xml
%global proton_licensedir %{_licensedir}/proton
%{!?_licensedir:%global license %doc}
%{!?_licensedir:%global proton_licensedir %{proton_datadir}}
BuildRequires: make
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: make
BuildRequires: cmake
BuildRequires: swig
BuildRequires: pkgconfig
BuildRequires: doxygen
BuildRequires: libuuid-devel
BuildRequires: openssl-devel
BuildRequires: cyrus-sasl-devel
BuildRequires: cyrus-sasl-plain
BuildRequires: cyrus-sasl-md5
BuildRequires: doxygen
BuildRequires: jsoncpp-devel
BuildRequires: python3-devel
BuildRequires: python3-build
BuildRequires: python3-cffi
BuildRequires: python3-pip
BuildRequires: python3-rpm-macros
BuildRequires: python3-setuptools
BuildRequires: python3-sphinx
BuildRequires: python3-wheel
BuildRequires: glibc-headers
BuildRequires: cyrus-sasl-devel
BuildRequires: jsoncpp-devel
BuildRequires: python3-setuptools
BuildRequires: libuv-devel
BuildRequires: nspr-devel
#BuildRequires: opentelemetry-cpp-devel
BuildRequires: pkgconfig
%description
Proton is a high performance, lightweight messaging library. It can be used in
@ -159,13 +158,12 @@ Obsoletes: qpid-proton-cpp-devel-docs
%files cpp-docs
%license %{proton_licensedir}/LICENSE.txt
%{proton_datadir}/docs/api-cpp
%doc %{proton_datadir}/docs/api-cpp
%doc %{proton_datadir}/examples/cpp/*.cpp
%doc %{proton_datadir}/examples/cpp/*.hpp
%doc %{proton_datadir}/examples/cpp/README.dox
%doc %{proton_datadir}/examples/cpp/CMakeLists.txt
%doc %{proton_datadir}/examples/cpp/ssl-certs
%doc %{proton_datadir}/examples/cpp/tracing.dox
%doc %{proton_datadir}/examples/cpp/tutorial.dox
@ -182,7 +180,7 @@ Requires: python3
%{python3_sitearch}/*.so
%{python3_sitearch}/*.py*
%{python3_sitearch}/proton
%{python3_sitearch}/python_qpid_proton-%{version}.dist-info/*
%{python3_sitearch}/python_qpid_proton-%{version}.dist-info
%package -n python-qpid-proton-docs
@ -212,16 +210,15 @@ BuildArch: noarch
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1
%build
mkdir -p BLD
cd BLD
%cmake \
-DCMAKE_SKIP_RPATH:BOOL=OFF \
"-DCMAKE_C_FLAGS=$CFLAGS -Wno-deprecated-declarations" \
-DENABLE_FUZZ_TESTING=NO \
"-DCMAKE_C_FLAGS=$CFLAGS -Wno-deprecated-declarations" \
-DENABLE_FUZZ_TESTING=NO \
-DENABLE_PYTHON_ISOLATED=NO \
..
make all docs %{?_smp_mflags}
@ -236,15 +233,13 @@ cd BLD
# Need to remove anything built by the python cmake build in proton
# so that we rebuild from scratch
rm -rf build
# Need to do the python package build here as we rely on the qpid-proton-core
# library to be installed so we don't duplicate it inside the extension
# That is also why we have to point pkg-config at the installed library
PKG_CONFIG_PATH=%{buildroot}%{_libdir}/pkgconfig %py3_build_wheel
%py3_install_wheel python_qpid_proton-%{version}-cp39-cp39-linux_%{_arch}.whl
%global whl_tags cp%{python3_version_nodots}-cp%{python3_version_nodots}-%(echo %{python3_platform} | tr -- - _)
cd ..
%py3_install_wheel python_qpid_proton-%{version}-%{whl_tags}.whl
# We seem to need to strip the build extension otherwise it seems to embed a reference to
# the buildroot in the debug info which fails the rpmbuild - probably because we massaged
# the pkgconfig path above
strip %{buildroot}%{python3_sitearch}/_cproton*.so)
strip %{buildroot}%{python3_sitearch}/cproton*.so)
install -dm 755 %{buildroot}%{proton_licensedir}
install -pm 644 %{SOURCE1} %{buildroot}%{proton_licensedir}
@ -313,11 +308,354 @@ rm -f %{buildroot}%{proton_datadir}/CMakeLists.txt
%check
%changelog
* Sat Nov 18 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.38.0-1
* Thu Dec 05 2024 Hirotaka Wakabayashi <hiwkby@yahoo.com> - 0.40.0-4
- Update release version to prevent NVR check error
* Thu Dec 05 2024 Hirotaka Wakabayashi <hiwkby@yahoo.com> - 0.40.0-3
- Downgrade Python version
* Wed Dec 04 2024 Hirotaka Wakabayashi <hiwkby@yahoo.com> - 0.40.0-2
- Update licenses.xml
* Fri Nov 29 2024 Hirotaka Wakabayashi <hiwkby@yahoo.com> - 0.40.0-1
- Rebased to 0.40.0
* Wed Jul 24 2024 Miroslav Suchý <msuchy@redhat.com> - 0.38.0-10
- convert license to SPDX
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.38.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 0.38.0-8
- Rebuilt for Python 3.13
* Thu Mar 14 2024 Hirotaka Wakabayashi <hiwkby@yahoo.com> - 0.38.0-7
- Fixes the "machine-readable provides" bug
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.38.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.38.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Nov 18 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.38.0-4
- Rebuilt for MSVSphere 9.2
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.38.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon Jul 10 2023 Lukáš Zaoral <lzaoral@redhat.com> - 0.38.0-3
- Fix compatibility with Python 3.12 (rhbz#2220586)
* Wed Jun 14 2023 Python Maint <python-maint@redhat.com> - 0.38.0-2
- Rebuilt for Python 3.12
* Fri Mar 31 2023 Kim van der Riet <kvanderr@redhat.com> - 0.38.0-1
- Rebased to 0.38.0, opentelemetry-cpp not included as no pkgs in centos yet.
- Rebased to 0.38.0, opentelemetry-cpp not included as no pkgs in Fedora yet.
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.37.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Wed Jan 04 2023 Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.37.0-4
- Rebuild for https://fedoraproject.org/wiki/Changes/Ruby_3.2
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.37.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 0.37.0-2
- Rebuilt for Python 3.11
* Tue Mar 22 2022 Kim van der Riet <kvanderr@redhat.com> - 0.37.0-1
- Rebased to 0.37.0
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.36.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Jan 13 2022 Irina Boverman <iboverma@redhat.com> - 0.36.0-2
- Removed no longer needed code
* Tue Jan 4 2022 Irina Boverman <iboverma@redhat.com> - 0.36.0-1
- Rebased to 0.36.0
* Wed Nov 03 2021 Björn Esser <besser82@fedoraproject.org> - 0.35.0-4
- Rebuild (jsoncpp)
* Mon Oct 25 2021 Irina Boverman <iboverma@redhat.com> - 0.35.0-3
- Rebuilt with OpenSSL 3.0.0
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.35.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jul 16 2021 Kim van der Riet <kvanderr@redhat.com> - 0.35.0-1
- Rebased to 0.35.0
* Tue May 4 2021 Irina Boverman <iboverma@redhat.com> - 0.34.0-1
- Rebased to 0.34.0
* Tue Jan 19 2021 Irina Boverman <iboverma@redhat.com> - 0.33.0-1
- Rebased to 0.33.0
* Fri Oct 2 2020 Irina Boverman <iboverma@redhat.com> - 0.32.0-2
- Added temp fix to allow building c/cpp examples
* Thu Sep 24 2020 Irina Boverman <iboverma@redhat.com> - 0.32.0-1
- Rebased to 0.32.0
* Tue Jul 28 2020 Irina Boverman <iboverma@redhat.com> - 0.31.0-5
- Added rubygem-qpid_proton subpackage
* Mon Jun 1 2020 Irina Boverman <iboverma@redhat.com> - 0.31.0-4
- Corrected cmake for c/cpp examples
- Resolved PROTON-2228
* Sat May 30 2020 Björn Esser <besser82@fedoraproject.org> - 0.31.0-3
- Rebuild (jsoncpp)
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 0.31.0-2
- Rebuilt for Python 3.9
* Thu May 14 2020 Irina Boverman <iboverma@redhat.com> - 0.30.0-1
- Rebased to 0.31.0
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Mon Jan 20 2020 Irina Boverman <iboverma@redhat.com> - 0.30.0-1
- Rebased to 0.30.0
- Removed python2--qpid-proton
- Replaced epydoc with python3-sphinx
* Thu Nov 14 2019 Björn Esser <besser82@fedoraproject.org> - 0.29.0-2
- Rebuild (jsoncpp)
* Tue Oct 1 2019 Irina Boverman <iboverma@redhat.com> - 0.29.0-1
- Rebased to 0.29.0
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.28.0-4
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.28.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Wed Jul 03 2019 Björn Esser <besser82@fedoraproject.org> - 0.28.0-2
- Rebuild (jsoncpp)
* Tue May 14 2019 Irina Boverman <iboverma@redhat.com> - 0.28.0-1
- Rebased to 0.28.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Mon Jan 7 2019 Irina Boverman <iboverma@redhat.com> - 0.26.0-1
- Rebased to 0.26.0
* Tue Jul 31 2018 Irina Boverman <iboverma@redhat.com> - 0.24.0-4
- Added cmake arguments for python3 build
* Tue Jul 31 2018 Irina Boverman <iboverma@redhat.com> - 0.24.0-3
- Updated spec for %{python3_sitearch}/_cproton.so
* Thu Jul 26 2018 Irina Boverman <iboverma@redhat.com> - 0.24.0-2
- Updated to build both python2- and python3-qpid-proton packages
* Tue Jul 24 2018 Irina Boverman <iboverma@redhat.com> - 0.24.0-1
- Rebased to 0.24.0
* Wed Mar 14 2018 Irina Boverman <iboverma@redhat.com> - 0.21.0-2
- Updated per changes on master
* Tue Mar 13 2018 Irina Boverman <iboverma@redhat.com> - 0.21.0-1
- Rebased to 0.21.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Jan 29 2018 Merlin Mathesius <mmathesi@redhat.com> - 0.18.1-3
- Cleanup spec file conditionals
* Sun Dec 17 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.18.1-2
- Python 2 binary package renamed to python2-qpid-proton
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
* Thu Nov 16 2017 Irina Boverman <iboverma@redhat.com> - 0.18.1-1
- Rebased to 0.18.1
* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.17.0-8
- Python 2 binary package renamed to python2-qpid-proton
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
* Wed Aug 9 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-7
- Resolves: PROTON-1526
* Tue Aug 8 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-6
- Added missing *.hpp files in qpid-proton-cpp-devel package
* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.17.0-5
- Rebuild due to bug in RPM (RHBZ #1468476)
* Fri Jun 23 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-4
- Excluded *.hpp files from qpid-proton-c-devel
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.17.0-3
- Perl 5.26 rebuild
* Wed May 10 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-2
- Added 0001-PROTON-1466-proton-c-mixing-up-links-with-names-that.patch
* Tue Feb 21 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-1
- Rebased to 0.17.0
- Added *cpp* packages
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.14.0-3
- Rebuild for Python 3.6
* Wed Nov 9 2016 Irina Boverman <iboverma@redhat.com> - 0.14.0-2
- Renamed sub-packages qpid-proton-c-devel-docs/qpid-proton-cpp-devel-docs
to qpid-proton-c-docs/qpid-proton-cpp-docs
- Removed binary and derived files from qpid-proton-cpp-docs package
* Tue Sep 6 2016 Irina Boverman <iboverma@redhat.com> - 0.14.0-1
- Added "-std=c++11" flag
- Rebased to 0.14.0
* Mon Aug 1 2016 Irina Boverman <iboverma@redhat.com> - 0.13.1-1
- Rebased to 0.13.1
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13.0-2
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
* Wed Jun 22 2016 Irina Boverman <iboverma@redhat.com> - 0.13.0-1
- Rebased to 0.13.0
- Changed *doc to *docs, moved examples to *docs
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.12.1-2
- Perl 5.24 rebuild
* Wed Mar 23 2016 Irina Boverman <iboverma@redhat.com> - 0.12.1-1
- Rebased to 0.12.1
- Added python3 installation
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Tue Sep 8 2015 Irina Boverman <iboverma@redhat.com> - 0.10-2
- Added dependency on cyrus-sasl-devel and cyrus-sasl-lib
- Added 0001-PROTON-974-Accept-a-single-symbol-in-SASL-mechs-fram.patch
* Wed Sep 2 2015 Irina Boverman <iboverma@redhat.com> - 0.10-1
- Rebased to 0.10
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.9-4
- Perl 5.22 rebuild
* Wed Apr 8 2015 Darryl L. Pierce <dpierce@redhat.com> - 0.9-3
- Added a global excludes macro to fix EL6 issues with example Perl modules.
* Wed Apr 8 2015 Darryl L. Pierce <dpierce@redhat.com> - 0.9-2
- Marked the examples in -c-devel as doc.
- Turned off the executable flag on all files under examples.
* Mon Apr 6 2015 Darryl L. Pierce <dpierce@redhat.com> - 0.9-1
- Rebased on Proton 0.9.
- Removed the proton binary from qpid-proton-c.
- Added the perl-qpid-proton subpackage.
* Tue Nov 18 2014 Darryl L. Pierce <dpierce@redhat.com> - 0.8-1
- Rebased on Proton 0.8.
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Tue Jul 8 2014 Darryl L. Pierce <dpierce@redhat.com> - 0.7-3
- Removed intra-package comments which cause error messages on package uninstall.
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Tue Apr 29 2014 Darryl L. Pierce <dpierce@redhat.com> - 0.7-1
- Rebased on Proton 0.7
- Added new CMake modules for Proton to qpid-proton-c-devel.
* Mon Feb 24 2014 Darryl L. Pierce <dpierce@redhat.com> - 0.6-2
- Reorganized the subpackages.
- Merged up branches to get things back into sync.
* Thu Jan 16 2014 Darryl L. Pierce <dpierce@redhat.com> - 0.6-1
- Rebased on Proton 0.6.
- Update spec to delete ruby and perl5 directories if Cmake creates them.
- Removed Java sub-packages - those will be packaged separate in future.
* Fri Sep 6 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.5-2
- Made python-qpid-proton-doc a noarch package.
- Resolves: BZ#1005058
* Wed Aug 28 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.5-1
- Rebased on Proton 0.5.
- Resolves: BZ#1000620
* Mon Aug 26 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.4-4
- Created the qpid-proton-c-devel-doc subpackage.
- Resolves: BZ#1000615
* Wed Jul 24 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.4-3
- Provide examples for qpid-proton-c
- Resolves: BZ#975723
* Fri Apr 5 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.4-2.2
- Added Obsoletes and Provides for packages whose names changed.
- Resolves: BZ#948784
* Mon Apr 1 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.4-2.1
- Fixed the dependencies for qpid-proton-devel and python-qpid-proton.
* Thu Mar 28 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.4-2
- Moved all C libraries to the new qpid-proton-c subpackage.
* Tue Feb 26 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.4-1
- Rebased on Proton 0.4.
* Thu Feb 21 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.3-4
- Fixes copying nested data.
- PROTON-246, PROTON-230
* Mon Jan 28 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.3-3
- Fixes build failure on non-x86 platforms.
- Resolves: BZ#901526
* Fri Jan 25 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.3-2
- Fixes build failure on non-x86 platforms.
- Resolves: BZ#901526
* Wed Jan 16 2013 Darryl L. Pierce <dpierce@redhat.com> - 0.3-1
- Rebased on Proton 0.3.
* Fri Dec 28 2012 Darryl L. Pierce <dpierce@redhat.com> - 0.2-2.4
- Moved ownership of the docs dir to the docs package.
* Wed Dec 19 2012 Darryl L. Pierce <dpierce@redhat.com> - 0.2-2.3
- Fixed package dependencies, adding the release macro.
* Mon Dec 17 2012 Darryl L. Pierce <dpierce@redhat.com> - 0.2-2.2
- Fixed subpackage dependencies on main package.
- Removed accidental ownership of /usr/include.
* Thu Dec 13 2012 Darryl L. Pierce <dpierce@redhat.com> - 0.2-2.1
- Remove BR for ruby-devel.
- Removed redundant package name from summary.
- Removed debugging artifacts from specfile.
- Moved unversioned library to the -devel package.
- Added dependency on main package to -devel.
- Fixed directory ownerships.
* Fri Nov 30 2012 Darryl L. Pierce <dpierce@redhat.com> - 0.2-2
- Removed BR on help2man.
- Added patch for generated manpage.
* Tue Jul 12 2022 Irina Boverman <iboverma@redhat.com> - 0.37.0-1
- Initial build for EPEL 9
* Mon Nov 5 2012 Darryl L. Pierce <dpierce@redhat.com> - 0.2-1
- Initial packaging of the Qpid Proton.

Loading…
Cancel
Save