You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
783 lines
26 KiB
783 lines
26 KiB
From 003f37e17fb03b8977effd968426a0aeb5855028 Mon Sep 17 00:00:00 2001
|
|
From: Miroslav Rezanina <mrezanin@redhat.com>
|
|
Date: Wed, 7 Dec 2022 03:05:48 -0500
|
|
Subject: Enable/disable devices for RHEL
|
|
|
|
This commit adds all changes related to changes in supported devices.
|
|
|
|
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
|
|
|
---
|
|
Rebase notes (9.1.0 rc0):
|
|
- Return value added for kvm_s390_apply_cpu_model
|
|
- Added new USB_HID and USB_HUB options
|
|
|
|
Rebase notes (9.1.0 rc1):
|
|
- Fixing valid_cpu_types preprocessing
|
|
|
|
Rebase notes (9.1.0 rc4):
|
|
- Moved x86 cpu deprecation from x86 machine type patch
|
|
- Removed unnecessary chunk in cirrus_vga.c
|
|
- Not needed hack removal of cpu-v7m.c from build
|
|
|
|
Rebase notes (9.1.0):
|
|
- Remove ppc64 device configuration
|
|
- Remove unnecessary chunks
|
|
- Removed CONFIG_VHOST_USER_SCMI and CONFIG_VHOST_USER_SND from some archs
|
|
|
|
Merged commits (9.1.0 rc0):
|
|
- f24c7a1fee Disable FDC devices
|
|
- fe8c6cb1ce Disable vga-cirrus device
|
|
- fccd117a12 Enable vhost-user-snd-pci device
|
|
- c0b40cc648 target/cpu-models/x86: Remove the existing deprecated CPU models on c10s
|
|
- ce42b3da0e x86/cpu: deprecate cpu models that do not support x86-64-v3
|
|
- 01ffa96c3b target/s390x/cpu_models: Disable everything up to the z12 CPU model
|
|
- cd57d17e3c target/s390x: Revert the old s390x CPU model disablement code
|
|
- 42af7b3ad5 Enable vhost-user-scmi devices
|
|
|
|
Merged commits (9.1.0 rc4):
|
|
- aa374ce5ea x86/cpu: update deprecation string to match lowest undeprecated model
|
|
---
|
|
.distro/qemu-kvm.spec.template | 20 +--
|
|
.../aarch64-softmmu/aarch64-rh-devices.mak | 46 +++++++
|
|
configs/devices/rh-virtio.mak | 10 ++
|
|
.../s390x-softmmu/s390x-rh-devices.mak | 19 +++
|
|
.../x86_64-softmmu/x86_64-rh-devices.mak | 114 ++++++++++++++++++
|
|
hw/arm/virt.c | 4 +
|
|
hw/cxl/meson.build | 3 +-
|
|
hw/ide/piix.c | 5 +-
|
|
hw/input/pckbd.c | 2 +
|
|
hw/net/e1000.c | 2 +
|
|
hw/usb/meson.build | 2 +-
|
|
hw/virtio/meson.build | 6 +-
|
|
target/arm/arm-qmp-cmds.c | 2 +
|
|
target/arm/cpu.c | 4 +
|
|
target/arm/cpu.h | 3 +
|
|
target/arm/cpu64.c | 12 +-
|
|
target/arm/tcg/cpu32.c | 2 +
|
|
target/arm/tcg/cpu64.c | 8 ++
|
|
target/arm/tcg/meson.build | 2 +-
|
|
target/i386/cpu.c | 19 +++
|
|
target/s390x/cpu_models.c | 2 +-
|
|
tests/qtest/arm-cpu-features.c | 4 +
|
|
22 files changed, 275 insertions(+), 16 deletions(-)
|
|
create mode 100644 configs/devices/aarch64-softmmu/aarch64-rh-devices.mak
|
|
create mode 100644 configs/devices/rh-virtio.mak
|
|
create mode 100644 configs/devices/s390x-softmmu/s390x-rh-devices.mak
|
|
create mode 100644 configs/devices/x86_64-softmmu/x86_64-rh-devices.mak
|
|
|
|
diff --git a/configs/devices/aarch64-softmmu/aarch64-rh-devices.mak b/configs/devices/aarch64-softmmu/aarch64-rh-devices.mak
|
|
new file mode 100644
|
|
index 0000000000..58075e2812
|
|
--- /dev/null
|
|
+++ b/configs/devices/aarch64-softmmu/aarch64-rh-devices.mak
|
|
@@ -0,0 +1,46 @@
|
|
+include ../rh-virtio.mak
|
|
+
|
|
+CONFIG_ARM_GIC_KVM=y
|
|
+CONFIG_ARM_GICV3_TCG=y
|
|
+CONFIG_ARM_GIC=y
|
|
+CONFIG_ARM_SMMUV3=y
|
|
+CONFIG_ARM_VIRT=y
|
|
+CONFIG_CXL=y
|
|
+CONFIG_CXL_MEM_DEVICE=y
|
|
+CONFIG_EDID=y
|
|
+CONFIG_PCIE_PORT=y
|
|
+CONFIG_PCIE_PCI_BRIDGE=y
|
|
+CONFIG_PCI_DEVICES=y
|
|
+CONFIG_PCI_TESTDEV=y
|
|
+CONFIG_PFLASH_CFI01=y
|
|
+CONFIG_SCSI=y
|
|
+CONFIG_SEMIHOSTING=y
|
|
+CONFIG_USB=y
|
|
+CONFIG_USB_XHCI=y
|
|
+CONFIG_USB_XHCI_PCI=y
|
|
+CONFIG_USB_STORAGE_CORE=y
|
|
+CONFIG_USB_STORAGE_CLASSIC=y
|
|
+CONFIG_USB_HUB=y
|
|
+CONFIG_USB_HID=y
|
|
+CONFIG_VFIO=y
|
|
+CONFIG_VFIO_PCI=y
|
|
+CONFIG_VIRTIO_MMIO=y
|
|
+CONFIG_VIRTIO_PCI=y
|
|
+CONFIG_VIRTIO_MEM=y
|
|
+CONFIG_VIRTIO_IOMMU=y
|
|
+CONFIG_XIO3130=y
|
|
+CONFIG_NVDIMM=y
|
|
+CONFIG_ACPI_APEI=y
|
|
+CONFIG_TPM=y
|
|
+CONFIG_TPM_EMULATOR=y
|
|
+CONFIG_TPM_TIS_SYSBUS=y
|
|
+CONFIG_PTIMER=y
|
|
+CONFIG_ARM_COMPATIBLE_SEMIHOSTING=y
|
|
+CONFIG_PVPANIC_PCI=y
|
|
+CONFIG_PXB=y
|
|
+CONFIG_VHOST_VSOCK=y
|
|
+CONFIG_VHOST_USER_VSOCK=y
|
|
+CONFIG_VHOST_USER_FS=y
|
|
+CONFIG_IOMMUFD=y
|
|
+CONFIG_VHOST_USER_SND=y
|
|
+CONFIG_VHOST_USER_SCMI=y
|
|
diff --git a/configs/devices/rh-virtio.mak b/configs/devices/rh-virtio.mak
|
|
new file mode 100644
|
|
index 0000000000..94ede1b5f6
|
|
--- /dev/null
|
|
+++ b/configs/devices/rh-virtio.mak
|
|
@@ -0,0 +1,10 @@
|
|
+CONFIG_VIRTIO=y
|
|
+CONFIG_VIRTIO_BALLOON=y
|
|
+CONFIG_VIRTIO_BLK=y
|
|
+CONFIG_VIRTIO_GPU=y
|
|
+CONFIG_VIRTIO_INPUT=y
|
|
+CONFIG_VIRTIO_INPUT_HOST=y
|
|
+CONFIG_VIRTIO_NET=y
|
|
+CONFIG_VIRTIO_RNG=y
|
|
+CONFIG_VIRTIO_SCSI=y
|
|
+CONFIG_VIRTIO_SERIAL=y
|
|
diff --git a/configs/devices/s390x-softmmu/s390x-rh-devices.mak b/configs/devices/s390x-softmmu/s390x-rh-devices.mak
|
|
new file mode 100644
|
|
index 0000000000..24cf6dbd03
|
|
--- /dev/null
|
|
+++ b/configs/devices/s390x-softmmu/s390x-rh-devices.mak
|
|
@@ -0,0 +1,19 @@
|
|
+include ../rh-virtio.mak
|
|
+
|
|
+CONFIG_PCI=y
|
|
+CONFIG_S390_CCW_VIRTIO=y
|
|
+CONFIG_S390_FLIC=y
|
|
+CONFIG_S390_FLIC_KVM=y
|
|
+CONFIG_SCLPCONSOLE=y
|
|
+CONFIG_SCSI=y
|
|
+CONFIG_VFIO=y
|
|
+CONFIG_VFIO_AP=y
|
|
+CONFIG_VFIO_CCW=y
|
|
+CONFIG_VFIO_PCI=y
|
|
+CONFIG_VHOST_USER=y
|
|
+CONFIG_VIRTIO_CCW=y
|
|
+CONFIG_WDT_DIAG288=y
|
|
+CONFIG_VHOST_VSOCK=y
|
|
+CONFIG_VHOST_USER_VSOCK=y
|
|
+CONFIG_VHOST_USER_FS=y
|
|
+CONFIG_IOMMUFD=y
|
|
diff --git a/configs/devices/x86_64-softmmu/x86_64-rh-devices.mak b/configs/devices/x86_64-softmmu/x86_64-rh-devices.mak
|
|
new file mode 100644
|
|
index 0000000000..45a8a15291
|
|
--- /dev/null
|
|
+++ b/configs/devices/x86_64-softmmu/x86_64-rh-devices.mak
|
|
@@ -0,0 +1,114 @@
|
|
+include ../rh-virtio.mak
|
|
+
|
|
+CONFIG_ACPI=y
|
|
+CONFIG_ACPI_PCI=y
|
|
+CONFIG_ACPI_CPU_HOTPLUG=y
|
|
+CONFIG_ACPI_MEMORY_HOTPLUG=y
|
|
+CONFIG_ACPI_NVDIMM=y
|
|
+CONFIG_ACPI_SMBUS=y
|
|
+CONFIG_ACPI_VMGENID=y
|
|
+CONFIG_ACPI_X86=y
|
|
+CONFIG_ACPI_ICH9=y
|
|
+CONFIG_AHCI=y
|
|
+CONFIG_APIC=y
|
|
+CONFIG_APM=y
|
|
+CONFIG_BOCHS_DISPLAY=y
|
|
+CONFIG_CXL=y
|
|
+CONFIG_CXL_MEM_DEVICE=y
|
|
+CONFIG_DIMM=y
|
|
+CONFIG_E1000E_PCI_EXPRESS=y
|
|
+CONFIG_E1000_PCI=y
|
|
+CONFIG_EDU=y
|
|
+#CONFIG_FDC=y
|
|
+#CONFIG_FDC_SYSBUS=y
|
|
+#CONFIG_FDC_ISA=y
|
|
+CONFIG_FW_CFG_DMA=y
|
|
+CONFIG_HDA=y
|
|
+CONFIG_HYPERV=y
|
|
+CONFIG_HYPERV_TESTDEV=y
|
|
+CONFIG_I2C=y
|
|
+CONFIG_I440FX=y
|
|
+CONFIG_I8254=y
|
|
+CONFIG_I8257=y
|
|
+CONFIG_I8259=y
|
|
+CONFIG_I82801B11=y
|
|
+CONFIG_IDE_CORE=y
|
|
+CONFIG_IDE_PCI=y
|
|
+CONFIG_IDE_PIIX=y
|
|
+CONFIG_IDE_DEV=y
|
|
+CONFIG_IDE_BUS=y
|
|
+CONFIG_IGB_PCI_EXPRESS=y
|
|
+CONFIG_IOAPIC=y
|
|
+CONFIG_IOH3420=y
|
|
+CONFIG_ISA_BUS=y
|
|
+CONFIG_ISA_DEBUG=y
|
|
+CONFIG_ISA_TESTDEV=y
|
|
+CONFIG_LPC_ICH9=y
|
|
+CONFIG_MC146818RTC=y
|
|
+CONFIG_MEM_DEVICE=y
|
|
+CONFIG_NVDIMM=y
|
|
+CONFIG_PAM=y
|
|
+CONFIG_PC=y
|
|
+CONFIG_PCI=y
|
|
+CONFIG_PCIE_PORT=y
|
|
+CONFIG_PCI_DEVICES=y
|
|
+CONFIG_PCI_EXPRESS=y
|
|
+CONFIG_PCI_EXPRESS_Q35=y
|
|
+CONFIG_PCI_I440FX=y
|
|
+CONFIG_PCI_TESTDEV=y
|
|
+CONFIG_PCKBD=y
|
|
+CONFIG_PCSPK=y
|
|
+CONFIG_PC_ACPI=y
|
|
+CONFIG_PC_PCI=y
|
|
+CONFIG_PCIE_PCI_BRIDGE=y
|
|
+CONFIG_PFLASH_CFI01=y
|
|
+CONFIG_PVPANIC_ISA=y
|
|
+CONFIG_PXB=y
|
|
+CONFIG_Q35=y
|
|
+CONFIG_RTL8139_PCI=y
|
|
+CONFIG_SCSI=y
|
|
+CONFIG_SERIAL=y
|
|
+CONFIG_SERIAL_ISA=y
|
|
+CONFIG_SERIAL_PCI=y
|
|
+CONFIG_SEV=y
|
|
+CONFIG_SMBIOS=y
|
|
+CONFIG_SMBUS_EEPROM=y
|
|
+CONFIG_TEST_DEVICES=y
|
|
+CONFIG_USB=y
|
|
+CONFIG_USB_EHCI=y
|
|
+CONFIG_USB_EHCI_PCI=y
|
|
+CONFIG_USB_SMARTCARD=y
|
|
+CONFIG_USB_STORAGE_CORE=y
|
|
+CONFIG_USB_STORAGE_CLASSIC=y
|
|
+CONFIG_USB_UHCI=y
|
|
+CONFIG_USB_XHCI=y
|
|
+CONFIG_USB_XHCI_NEC=y
|
|
+CONFIG_USB_XHCI_PCI=y
|
|
+CONFIG_USB_HUB=y
|
|
+CONFIG_USB_HID=y
|
|
+CONFIG_VFIO=y
|
|
+CONFIG_VFIO_PCI=y
|
|
+CONFIG_VGA=y
|
|
+CONFIG_VGA_PCI=y
|
|
+CONFIG_VHOST_USER=y
|
|
+CONFIG_VHOST_USER_BLK=y
|
|
+CONFIG_VIRTIO_MEM=y
|
|
+CONFIG_VIRTIO_PCI=y
|
|
+CONFIG_VIRTIO_VGA=y
|
|
+CONFIG_VIRTIO_IOMMU=y
|
|
+CONFIG_VMMOUSE=y
|
|
+CONFIG_VMPORT=y
|
|
+CONFIG_VTD=y
|
|
+CONFIG_WDT_IB6300ESB=y
|
|
+CONFIG_WDT_IB700=y
|
|
+CONFIG_XIO3130=y
|
|
+CONFIG_TPM=y
|
|
+CONFIG_TPM_CRB=y
|
|
+CONFIG_TPM_TIS_ISA=y
|
|
+CONFIG_TPM_EMULATOR=y
|
|
+CONFIG_SGX=y
|
|
+CONFIG_VHOST_VSOCK=y
|
|
+CONFIG_VHOST_USER_VSOCK=y
|
|
+CONFIG_VHOST_USER_FS=y
|
|
+CONFIG_IOMMUFD=y
|
|
+CONFIG_VHOST_USER_SND=y
|
|
diff --git a/hw/arm/virt.c b/hw/arm/virt.c
|
|
index 687fe0bb8b..eea7d2d038 100644
|
|
--- a/hw/arm/virt.c
|
|
+++ b/hw/arm/virt.c
|
|
@@ -3032,6 +3032,7 @@ static void virt_machine_class_init(ObjectClass *oc, void *data)
|
|
MachineClass *mc = MACHINE_CLASS(oc);
|
|
HotplugHandlerClass *hc = HOTPLUG_HANDLER_CLASS(oc);
|
|
static const char * const valid_cpu_types[] = {
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
#ifdef CONFIG_TCG
|
|
ARM_CPU_TYPE_NAME("cortex-a7"),
|
|
ARM_CPU_TYPE_NAME("cortex-a15"),
|
|
@@ -3047,8 +3048,11 @@ static void virt_machine_class_init(ObjectClass *oc, void *data)
|
|
ARM_CPU_TYPE_NAME("neoverse-n2"),
|
|
#endif /* TARGET_AARCH64 */
|
|
#endif /* CONFIG_TCG */
|
|
+#endif /* disabled for RHEL */
|
|
#ifdef TARGET_AARCH64
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
ARM_CPU_TYPE_NAME("cortex-a53"),
|
|
+#endif /* disabled for RHEL */
|
|
ARM_CPU_TYPE_NAME("cortex-a57"),
|
|
#if defined(CONFIG_KVM) || defined(CONFIG_HVF)
|
|
ARM_CPU_TYPE_NAME("host"),
|
|
diff --git a/hw/cxl/meson.build b/hw/cxl/meson.build
|
|
index 3e375f61a9..613adb3ebb 100644
|
|
--- a/hw/cxl/meson.build
|
|
+++ b/hw/cxl/meson.build
|
|
@@ -6,7 +6,8 @@ system_ss.add(when: 'CONFIG_CXL',
|
|
'cxl-host.c',
|
|
'cxl-cdat.c',
|
|
'cxl-events.c',
|
|
- 'switch-mailbox-cci.c',
|
|
+# Disabled for 8.2.0 rebase for RHEL 9.4.0
|
|
+# 'switch-mailbox-cci.c',
|
|
),
|
|
if_false: files(
|
|
'cxl-host-stubs.c',
|
|
diff --git a/hw/ide/piix.c b/hw/ide/piix.c
|
|
index 80efc633d3..9cb82b8eea 100644
|
|
--- a/hw/ide/piix.c
|
|
+++ b/hw/ide/piix.c
|
|
@@ -191,7 +191,8 @@ static void piix3_ide_class_init(ObjectClass *klass, void *data)
|
|
k->device_id = PCI_DEVICE_ID_INTEL_82371SB_1;
|
|
k->class_id = PCI_CLASS_STORAGE_IDE;
|
|
set_bit(DEVICE_CATEGORY_STORAGE, dc->categories);
|
|
- dc->hotpluggable = false;
|
|
+ /* Disabled for Red Hat Enterprise Linux: */
|
|
+ dc->user_creatable = false;
|
|
}
|
|
|
|
static const TypeInfo piix3_ide_info = {
|
|
@@ -215,6 +216,8 @@ static void piix4_ide_class_init(ObjectClass *klass, void *data)
|
|
k->class_id = PCI_CLASS_STORAGE_IDE;
|
|
set_bit(DEVICE_CATEGORY_STORAGE, dc->categories);
|
|
dc->hotpluggable = false;
|
|
+ /* Disabled for Red Hat Enterprise Linux: */
|
|
+ dc->user_creatable = false;
|
|
}
|
|
|
|
static const TypeInfo piix4_ide_info = {
|
|
diff --git a/hw/input/pckbd.c b/hw/input/pckbd.c
|
|
index 74f10b640f..2e85ecf476 100644
|
|
--- a/hw/input/pckbd.c
|
|
+++ b/hw/input/pckbd.c
|
|
@@ -952,6 +952,8 @@ static void i8042_class_initfn(ObjectClass *klass, void *data)
|
|
dc->vmsd = &vmstate_kbd_isa;
|
|
adevc->build_dev_aml = i8042_build_aml;
|
|
set_bit(DEVICE_CATEGORY_INPUT, dc->categories);
|
|
+ /* Disabled for Red Hat Enterprise Linux: */
|
|
+ dc->user_creatable = false;
|
|
}
|
|
|
|
static const TypeInfo i8042_info = {
|
|
diff --git a/hw/net/e1000.c b/hw/net/e1000.c
|
|
index 5012b96464..b435e54228 100644
|
|
--- a/hw/net/e1000.c
|
|
+++ b/hw/net/e1000.c
|
|
@@ -1746,6 +1746,7 @@ static const E1000Info e1000_devices[] = {
|
|
.revision = 0x03,
|
|
.phy_id2 = E1000_PHY_ID2_8254xx_DEFAULT,
|
|
},
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux 7 */
|
|
{
|
|
.name = "e1000-82544gc",
|
|
.device_id = E1000_DEV_ID_82544GC_COPPER,
|
|
@@ -1758,6 +1759,7 @@ static const E1000Info e1000_devices[] = {
|
|
.revision = 0x03,
|
|
.phy_id2 = E1000_PHY_ID2_8254xx_DEFAULT,
|
|
},
|
|
+#endif
|
|
};
|
|
|
|
static void e1000_register_types(void)
|
|
diff --git a/hw/usb/meson.build b/hw/usb/meson.build
|
|
index d7de1003e3..1cdc0a1ba0 100644
|
|
--- a/hw/usb/meson.build
|
|
+++ b/hw/usb/meson.build
|
|
@@ -55,7 +55,7 @@ system_ss.add(when: 'CONFIG_USB_SMARTCARD', if_true: files('dev-smartcard-reader
|
|
if cacard.found()
|
|
usbsmartcard_ss = ss.source_set()
|
|
usbsmartcard_ss.add(when: 'CONFIG_USB_SMARTCARD',
|
|
- if_true: [cacard, files('ccid-card-emulated.c', 'ccid-card-passthru.c')])
|
|
+ if_true: [cacard, files('ccid-card-passthru.c')])
|
|
hw_usb_modules += {'smartcard': usbsmartcard_ss}
|
|
endif
|
|
|
|
diff --git a/hw/virtio/meson.build b/hw/virtio/meson.build
|
|
index 621fc65454..c38bdd6fa4 100644
|
|
--- a/hw/virtio/meson.build
|
|
+++ b/hw/virtio/meson.build
|
|
@@ -20,7 +20,8 @@ if have_vhost
|
|
system_virtio_ss.add(files('vhost-user-base.c'))
|
|
|
|
# MMIO Stubs
|
|
- system_virtio_ss.add(files('vhost-user-device.c'))
|
|
+# Disabled for 8.2.0 rebase for RHEL 9.4.0
|
|
+# system_virtio_ss.add(files('vhost-user-device.c'))
|
|
system_virtio_ss.add(when: 'CONFIG_VHOST_USER_GPIO', if_true: files('vhost-user-gpio.c'))
|
|
system_virtio_ss.add(when: 'CONFIG_VHOST_USER_I2C', if_true: files('vhost-user-i2c.c'))
|
|
system_virtio_ss.add(when: 'CONFIG_VHOST_USER_RNG', if_true: files('vhost-user-rng.c'))
|
|
@@ -28,7 +29,8 @@ if have_vhost
|
|
system_virtio_ss.add(when: 'CONFIG_VHOST_USER_INPUT', if_true: files('vhost-user-input.c'))
|
|
|
|
# PCI Stubs
|
|
- system_virtio_ss.add(when: 'CONFIG_VIRTIO_PCI', if_true: files('vhost-user-device-pci.c'))
|
|
+# Disabled for 8.2.0 rebase for RHEL 9.4.0
|
|
+# system_virtio_ss.add(when: 'CONFIG_VIRTIO_PCI', if_true: files('vhost-user-device-pci.c'))
|
|
system_virtio_ss.add(when: ['CONFIG_VIRTIO_PCI', 'CONFIG_VHOST_USER_GPIO'],
|
|
if_true: files('vhost-user-gpio-pci.c'))
|
|
system_virtio_ss.add(when: ['CONFIG_VIRTIO_PCI', 'CONFIG_VHOST_USER_I2C'],
|
|
diff --git a/target/arm/arm-qmp-cmds.c b/target/arm/arm-qmp-cmds.c
|
|
index 3cc8cc738b..6f21fea1f5 100644
|
|
--- a/target/arm/arm-qmp-cmds.c
|
|
+++ b/target/arm/arm-qmp-cmds.c
|
|
@@ -223,6 +223,7 @@ CpuModelExpansionInfo *qmp_query_cpu_model_expansion(CpuModelExpansionType type,
|
|
static void arm_cpu_add_definition(gpointer data, gpointer user_data)
|
|
{
|
|
ObjectClass *oc = data;
|
|
+ CPUClass *cc = CPU_CLASS(oc);
|
|
CpuDefinitionInfoList **cpu_list = user_data;
|
|
CpuDefinitionInfo *info;
|
|
const char *typename;
|
|
@@ -231,6 +232,7 @@ static void arm_cpu_add_definition(gpointer data, gpointer user_data)
|
|
info = g_malloc0(sizeof(*info));
|
|
info->name = cpu_model_from_type(typename);
|
|
info->q_typename = g_strdup(typename);
|
|
+ info->deprecated = !!cc->deprecation_note;
|
|
|
|
QAPI_LIST_PREPEND(*cpu_list, info);
|
|
}
|
|
diff --git a/target/arm/cpu.c b/target/arm/cpu.c
|
|
index 19191c2391..465f423d25 100644
|
|
--- a/target/arm/cpu.c
|
|
+++ b/target/arm/cpu.c
|
|
@@ -2726,6 +2726,10 @@ static void cpu_register_class_init(ObjectClass *oc, void *data)
|
|
|
|
acc->info = data;
|
|
cc->gdb_core_xml_file = "arm-core.xml";
|
|
+
|
|
+ if (acc->info->deprecation_note) {
|
|
+ cc->deprecation_note = acc->info->deprecation_note;
|
|
+ }
|
|
}
|
|
|
|
void arm_cpu_register(const ARMCPUInfo *info)
|
|
diff --git a/target/arm/cpu.h b/target/arm/cpu.h
|
|
index 9a3fd59562..1261eae94d 100644
|
|
--- a/target/arm/cpu.h
|
|
+++ b/target/arm/cpu.h
|
|
@@ -35,6 +35,8 @@
|
|
#define KVM_HAVE_MCE_INJECTION 1
|
|
#endif
|
|
|
|
+#define RHEL_CPU_DEPRECATION "use 'host' / 'max'"
|
|
+
|
|
#define EXCP_UDEF 1 /* undefined instruction */
|
|
#define EXCP_SWI 2 /* software interrupt */
|
|
#define EXCP_PREFETCH_ABORT 3
|
|
@@ -1110,6 +1112,7 @@ typedef struct ARMCPUInfo {
|
|
const char *name;
|
|
void (*initfn)(Object *obj);
|
|
void (*class_init)(ObjectClass *oc, void *data);
|
|
+ const char *deprecation_note;
|
|
} ARMCPUInfo;
|
|
|
|
/**
|
|
diff --git a/target/arm/cpu64.c b/target/arm/cpu64.c
|
|
index 262a1d6c0b..800514d3fc 100644
|
|
--- a/target/arm/cpu64.c
|
|
+++ b/target/arm/cpu64.c
|
|
@@ -653,6 +653,7 @@ static void aarch64_a57_initfn(Object *obj)
|
|
define_cortex_a72_a57_a53_cp_reginfo(cpu);
|
|
}
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
static void aarch64_a53_initfn(Object *obj)
|
|
{
|
|
ARMCPU *cpu = ARM_CPU(obj);
|
|
@@ -710,6 +711,7 @@ static void aarch64_a53_initfn(Object *obj)
|
|
cpu->gic_pribits = 5;
|
|
define_cortex_a72_a57_a53_cp_reginfo(cpu);
|
|
}
|
|
+#endif
|
|
|
|
static void aarch64_host_initfn(Object *obj)
|
|
{
|
|
@@ -748,8 +750,11 @@ static void aarch64_max_initfn(Object *obj)
|
|
}
|
|
|
|
static const ARMCPUInfo aarch64_cpus[] = {
|
|
- { .name = "cortex-a57", .initfn = aarch64_a57_initfn },
|
|
+ { .name = "cortex-a57", .initfn = aarch64_a57_initfn,
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION },
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
{ .name = "cortex-a53", .initfn = aarch64_a53_initfn },
|
|
+#endif /* disabled for RHEL */
|
|
{ .name = "max", .initfn = aarch64_max_initfn },
|
|
#if defined(CONFIG_KVM) || defined(CONFIG_HVF)
|
|
{ .name = "host", .initfn = aarch64_host_initfn },
|
|
@@ -820,8 +825,13 @@ static void aarch64_cpu_instance_init(Object *obj)
|
|
static void cpu_register_class_init(ObjectClass *oc, void *data)
|
|
{
|
|
ARMCPUClass *acc = ARM_CPU_CLASS(oc);
|
|
+ CPUClass *cc = CPU_CLASS(oc);
|
|
|
|
acc->info = data;
|
|
+
|
|
+ if (acc->info->deprecation_note) {
|
|
+ cc->deprecation_note = acc->info->deprecation_note;
|
|
+ }
|
|
}
|
|
|
|
void aarch64_cpu_register(const ARMCPUInfo *info)
|
|
diff --git a/target/arm/tcg/cpu32.c b/target/arm/tcg/cpu32.c
|
|
index 20c2737f17..7e66fb6f14 100644
|
|
--- a/target/arm/tcg/cpu32.c
|
|
+++ b/target/arm/tcg/cpu32.c
|
|
@@ -120,6 +120,7 @@ void aa32_max_features(ARMCPU *cpu)
|
|
cpu->isar.id_dfr1 = t;
|
|
}
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
/* CPU models. These are not needed for the AArch64 linux-user build. */
|
|
#if !defined(CONFIG_USER_ONLY) || !defined(TARGET_AARCH64)
|
|
|
|
@@ -1066,3 +1067,4 @@ static void arm_tcg_cpu_register_types(void)
|
|
type_init(arm_tcg_cpu_register_types)
|
|
|
|
#endif /* !CONFIG_USER_ONLY || !TARGET_AARCH64 */
|
|
+#endif /* disabled for RHEL */
|
|
diff --git a/target/arm/tcg/cpu64.c b/target/arm/tcg/cpu64.c
|
|
index fe232eb306..2678047488 100644
|
|
--- a/target/arm/tcg/cpu64.c
|
|
+++ b/target/arm/tcg/cpu64.c
|
|
@@ -29,6 +29,7 @@
|
|
#include "cpu-features.h"
|
|
#include "cpregs.h"
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
static uint64_t make_ccsidr64(unsigned assoc, unsigned linesize,
|
|
unsigned cachesize)
|
|
{
|
|
@@ -135,6 +136,7 @@ static void aarch64_a35_initfn(Object *obj)
|
|
/* These values are the same with A53/A57/A72. */
|
|
define_cortex_a72_a57_a53_cp_reginfo(cpu);
|
|
}
|
|
+#endif
|
|
|
|
static void cpu_max_get_sve_max_vq(Object *obj, Visitor *v, const char *name,
|
|
void *opaque, Error **errp)
|
|
@@ -224,6 +226,7 @@ static void cpu_max_get_l0gptsz(Object *obj, Visitor *v, const char *name,
|
|
static Property arm_cpu_lpa2_property =
|
|
DEFINE_PROP_BOOL("lpa2", ARMCPU, prop_lpa2, true);
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
static void aarch64_a55_initfn(Object *obj)
|
|
{
|
|
ARMCPU *cpu = ARM_CPU(obj);
|
|
@@ -1074,6 +1077,7 @@ static void aarch64_neoverse_n2_initfn(Object *obj)
|
|
aarch64_add_pauth_properties(obj);
|
|
aarch64_add_sve_properties(obj);
|
|
}
|
|
+#endif
|
|
|
|
/*
|
|
* -cpu max: a CPU with as many features enabled as our emulation supports.
|
|
@@ -1295,6 +1299,7 @@ void aarch64_max_tcg_initfn(Object *obj)
|
|
qdev_property_add_static(DEVICE(obj), &arm_cpu_lpa2_property);
|
|
}
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
static const ARMCPUInfo aarch64_cpus[] = {
|
|
{ .name = "cortex-a35", .initfn = aarch64_a35_initfn },
|
|
{ .name = "cortex-a55", .initfn = aarch64_a55_initfn },
|
|
@@ -1306,14 +1311,17 @@ static const ARMCPUInfo aarch64_cpus[] = {
|
|
{ .name = "neoverse-v1", .initfn = aarch64_neoverse_v1_initfn },
|
|
{ .name = "neoverse-n2", .initfn = aarch64_neoverse_n2_initfn },
|
|
};
|
|
+#endif
|
|
|
|
static void aarch64_cpu_register_types(void)
|
|
{
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
size_t i;
|
|
|
|
for (i = 0; i < ARRAY_SIZE(aarch64_cpus); ++i) {
|
|
aarch64_cpu_register(&aarch64_cpus[i]);
|
|
}
|
|
+#endif
|
|
}
|
|
|
|
type_init(aarch64_cpu_register_types)
|
|
diff --git a/target/arm/tcg/meson.build b/target/arm/tcg/meson.build
|
|
index 508932a249..1293647501 100644
|
|
--- a/target/arm/tcg/meson.build
|
|
+++ b/target/arm/tcg/meson.build
|
|
@@ -58,5 +58,5 @@ arm_system_ss.add(files(
|
|
'psci.c',
|
|
))
|
|
|
|
-arm_system_ss.add(when: 'CONFIG_ARM_V7M', if_true: files('cpu-v7m.c'))
|
|
+#arm_system_ss.add(when: 'CONFIG_ARM_V7M', if_true: files('cpu-v7m.c'))
|
|
arm_user_ss.add(when: 'TARGET_AARCH64', if_false: files('cpu-v7m.c'))
|
|
diff --git a/target/i386/cpu.c b/target/i386/cpu.c
|
|
index 85ef7452c0..34e0ce5e62 100644
|
|
--- a/target/i386/cpu.c
|
|
+++ b/target/i386/cpu.c
|
|
@@ -2411,9 +2411,13 @@ static const CPUCaches epyc_genoa_cache_info = {
|
|
* PT in VMX operation
|
|
*/
|
|
|
|
+#define RHEL_CPU_DEPRECATION \
|
|
+ "use at least 'Haswell' / 'EPYC', or 'host' / 'max'"
|
|
+
|
|
static const X86CPUDefinition builtin_x86_defs[] = {
|
|
{
|
|
.name = "qemu64",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 0xd,
|
|
.vendor = CPUID_VENDOR_AMD,
|
|
.family = 15,
|
|
@@ -2432,6 +2436,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
.xlevel = 0x8000000A,
|
|
.model_id = "QEMU Virtual CPU version " QEMU_HW_VERSION,
|
|
},
|
|
+#if 0 // Deprecated CPU models are removed in RHEL-10
|
|
{
|
|
.name = "phenom",
|
|
.level = 5,
|
|
@@ -2796,8 +2801,10 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
.xlevel = 0x80000008,
|
|
.model_id = "Intel Core 2 Duo P9xxx (Penryn Class Core 2)",
|
|
},
|
|
+#endif // Removal of deprecated CPU models in RHEL-10
|
|
{
|
|
.name = "Nehalem",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 11,
|
|
.vendor = CPUID_VENDOR_INTEL,
|
|
.family = 6,
|
|
@@ -2875,6 +2882,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "Westmere",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 11,
|
|
.vendor = CPUID_VENDOR_INTEL,
|
|
.family = 6,
|
|
@@ -2956,6 +2964,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "SandyBridge",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 0xd,
|
|
.vendor = CPUID_VENDOR_INTEL,
|
|
.family = 6,
|
|
@@ -3042,6 +3051,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "IvyBridge",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 0xd,
|
|
.vendor = CPUID_VENDOR_INTEL,
|
|
.family = 6,
|
|
@@ -4469,6 +4479,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "Denverton",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 21,
|
|
.vendor = CPUID_VENDOR_INTEL,
|
|
.family = 6,
|
|
@@ -4579,6 +4590,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "Snowridge",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 27,
|
|
.vendor = CPUID_VENDOR_INTEL,
|
|
.family = 6,
|
|
@@ -4760,8 +4772,10 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
.xlevel = 0x80000008,
|
|
.model_id = "Intel Xeon Phi Processor (Knights Mill)",
|
|
},
|
|
+#if 0 // Deprecated CPU models are removed in RHEL-10
|
|
{
|
|
.name = "Opteron_G1",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 5,
|
|
.vendor = CPUID_VENDOR_AMD,
|
|
.family = 15,
|
|
@@ -4782,6 +4796,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "Opteron_G2",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 5,
|
|
.vendor = CPUID_VENDOR_AMD,
|
|
.family = 15,
|
|
@@ -4804,6 +4819,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "Opteron_G3",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 5,
|
|
.vendor = CPUID_VENDOR_AMD,
|
|
.family = 16,
|
|
@@ -4827,8 +4843,10 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
.xlevel = 0x80000008,
|
|
.model_id = "AMD Opteron 23xx (Gen 3 Class Opteron)",
|
|
},
|
|
+#endif
|
|
{
|
|
.name = "Opteron_G4",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 0xd,
|
|
.vendor = CPUID_VENDOR_AMD,
|
|
.family = 21,
|
|
@@ -4861,6 +4879,7 @@ static const X86CPUDefinition builtin_x86_defs[] = {
|
|
},
|
|
{
|
|
.name = "Opteron_G5",
|
|
+ .deprecation_note = RHEL_CPU_DEPRECATION,
|
|
.level = 0xd,
|
|
.vendor = CPUID_VENDOR_AMD,
|
|
.family = 21,
|
|
diff --git a/target/s390x/cpu_models.c b/target/s390x/cpu_models.c
|
|
index a27f4b6f79..798c18f940 100644
|
|
--- a/target/s390x/cpu_models.c
|
|
+++ b/target/s390x/cpu_models.c
|
|
@@ -72,7 +72,6 @@ static S390CPUDef s390_cpu_defs[] = {
|
|
CPUDEF_INIT(0x2096, 9, 2, 40, 0x00000000U, "z9BC", "IBM System z9 BC GA1"),
|
|
CPUDEF_INIT(0x2094, 9, 3, 40, 0x00000000U, "z9EC.3", "IBM System z9 EC GA3"),
|
|
CPUDEF_INIT(0x2096, 9, 3, 40, 0x00000000U, "z9BC.2", "IBM System z9 BC GA2"),
|
|
-#endif
|
|
CPUDEF_INIT(0x2097, 10, 1, 43, 0x00000000U, "z10EC", "IBM System z10 EC GA1"),
|
|
CPUDEF_INIT(0x2097, 10, 2, 43, 0x00000000U, "z10EC.2", "IBM System z10 EC GA2"),
|
|
CPUDEF_INIT(0x2098, 10, 2, 43, 0x00000000U, "z10BC", "IBM System z10 BC GA1"),
|
|
@@ -81,6 +80,7 @@ static S390CPUDef s390_cpu_defs[] = {
|
|
CPUDEF_INIT(0x2817, 11, 1, 44, 0x08000000U, "z196", "IBM zEnterprise 196 GA1"),
|
|
CPUDEF_INIT(0x2817, 11, 2, 44, 0x08000000U, "z196.2", "IBM zEnterprise 196 GA2"),
|
|
CPUDEF_INIT(0x2818, 11, 2, 44, 0x08000000U, "z114", "IBM zEnterprise 114 GA1"),
|
|
+#endif
|
|
CPUDEF_INIT(0x2827, 12, 1, 44, 0x08000000U, "zEC12", "IBM zEnterprise EC12 GA1"),
|
|
CPUDEF_INIT(0x2827, 12, 2, 44, 0x08000000U, "zEC12.2", "IBM zEnterprise EC12 GA2"),
|
|
CPUDEF_INIT(0x2828, 12, 2, 44, 0x08000000U, "zBC12", "IBM zEnterprise BC12 GA1"),
|
|
diff --git a/tests/qtest/arm-cpu-features.c b/tests/qtest/arm-cpu-features.c
|
|
index cfd6f77353..3016e6233c 100644
|
|
--- a/tests/qtest/arm-cpu-features.c
|
|
+++ b/tests/qtest/arm-cpu-features.c
|
|
@@ -452,8 +452,10 @@ static void test_query_cpu_model_expansion(const void *data)
|
|
assert_error(qts, "host", "The CPU type 'host' requires KVM", NULL);
|
|
|
|
/* Test expected feature presence/absence for some cpu types */
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
assert_has_feature_enabled(qts, "cortex-a15", "pmu");
|
|
assert_has_not_feature(qts, "cortex-a15", "aarch64");
|
|
+#endif /* disabled for RHEL */
|
|
|
|
/* Enabling and disabling pmu should always work. */
|
|
assert_has_feature_enabled(qts, "max", "pmu");
|
|
@@ -470,6 +472,7 @@ static void test_query_cpu_model_expansion(const void *data)
|
|
assert_has_feature_enabled(qts, "cortex-a57", "pmu");
|
|
assert_has_feature_enabled(qts, "cortex-a57", "aarch64");
|
|
|
|
+#if 0 /* Disabled for Red Hat Enterprise Linux */
|
|
assert_has_feature_enabled(qts, "a64fx", "pmu");
|
|
assert_has_feature_enabled(qts, "a64fx", "aarch64");
|
|
/*
|
|
@@ -482,6 +485,7 @@ static void test_query_cpu_model_expansion(const void *data)
|
|
"{ 'sve384': true }");
|
|
assert_error(qts, "a64fx", "cannot enable sve640",
|
|
"{ 'sve640': true }");
|
|
+#endif /* disabled for RHEL */
|
|
|
|
sve_tests_default(qts, "max");
|
|
pauth_tests_default(qts, "max");
|
|
--
|
|
2.39.3
|
|
|