You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
80 lines
3.0 KiB
80 lines
3.0 KiB
From 99f27e14856c528f442b628e8f4a7881e6e63179 Mon Sep 17 00:00:00 2001
|
|
From: Stefano Garzarella <sgarzare@redhat.com>
|
|
Date: Tue, 30 May 2023 09:19:41 +0200
|
|
Subject: [PATCH 4/5] qapi: add '@fdset' feature for
|
|
BlockdevOptionsVirtioBlkVhostVdpa
|
|
|
|
RH-Author: Stefano Garzarella <sgarzare@redhat.com>
|
|
RH-MergeRequest: 169: block/blkio: support fd passing for virtio-blk-vhost-vdpa driver
|
|
RH-Bugzilla: 2180076
|
|
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
|
|
RH-Acked-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
RH-Commit: [2/2] abee2a542e41f9eaa17dd204b74778e232d1eb60 (sgarzarella/qemu-kvm-c-9-s)
|
|
|
|
The virtio-blk-vhost-vdpa driver in libblkio 1.3.0 supports the fd
|
|
passing through the new 'fd' property.
|
|
|
|
Since now we are using qemu_open() on '@path' if the virtio-blk driver
|
|
supports the fd passing, let's announce it.
|
|
In this way, the management layer can pass the file descriptor of an
|
|
already opened vhost-vdpa character device. This is useful especially
|
|
when the device can only be accessed with certain privileges.
|
|
|
|
Add the '@fdset' feature only when the virtio-blk-vhost-vdpa driver
|
|
in libblkio supports it.
|
|
|
|
Suggested-by: Markus Armbruster <armbru@redhat.com>
|
|
Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
Signed-off-by: Stefano Garzarella <sgarzare@redhat.com>
|
|
Message-id: 20230530071941.8954-3-sgarzare@redhat.com
|
|
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
(cherry picked from commit 98b126f5e3228a346c774e569e26689943b401dd)
|
|
- changed doc indentantion since QAPI parser failed downstream because
|
|
we don't have commit 08349786c84306863a3b659c8a9b28bb74c405c6
|
|
downstream. It relaxed the indentation rules.
|
|
Signed-off-by: Stefano Garzarella <sgarzare@redhat.com>
|
|
---
|
|
meson.build | 4 ++++
|
|
qapi/block-core.json | 6 ++++++
|
|
2 files changed, 10 insertions(+)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index d964e741e7..a18cc64531 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1843,6 +1843,10 @@ config_host_data.set('CONFIG_LZO', lzo.found())
|
|
config_host_data.set('CONFIG_MPATH', mpathpersist.found())
|
|
config_host_data.set('CONFIG_MPATH_NEW_API', mpathpersist_new_api)
|
|
config_host_data.set('CONFIG_BLKIO', blkio.found())
|
|
+if blkio.found()
|
|
+ config_host_data.set('CONFIG_BLKIO_VHOST_VDPA_FD',
|
|
+ blkio.version().version_compare('>=1.3.0'))
|
|
+endif
|
|
config_host_data.set('CONFIG_CURL', curl.found())
|
|
config_host_data.set('CONFIG_CURSES', curses.found())
|
|
config_host_data.set('CONFIG_GBM', gbm.found())
|
|
diff --git a/qapi/block-core.json b/qapi/block-core.json
|
|
index c05ad0c07e..81b48a8d3b 100644
|
|
--- a/qapi/block-core.json
|
|
+++ b/qapi/block-core.json
|
|
@@ -3841,10 +3841,16 @@
|
|
#
|
|
# @path: path to the vhost-vdpa character device.
|
|
#
|
|
+# Features:
|
|
+# @fdset: Member @path supports the special "/dev/fdset/N" path
|
|
+# (since 8.1)
|
|
+#
|
|
# Since: 7.2
|
|
##
|
|
{ 'struct': 'BlockdevOptionsVirtioBlkVhostVdpa',
|
|
'data': { 'path': 'str' },
|
|
+ 'features': [ { 'name' :'fdset',
|
|
+ 'if': 'CONFIG_BLKIO_VHOST_VDPA_FD' } ],
|
|
'if': 'CONFIG_BLKIO' }
|
|
|
|
##
|
|
--
|
|
2.39.3
|
|
|