You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
qaccessibilityclient/libqaccessibilityclient-0.1...

23 lines
810 B

diff -up libqaccessibilityclient-0.1.1/CMakeLists.txt.qt4 libqaccessibilityclient-0.1.1/CMakeLists.txt
--- libqaccessibilityclient-0.1.1/CMakeLists.txt.qt4 2014-02-07 10:24:10.000000000 -0600
+++ libqaccessibilityclient-0.1.1/CMakeLists.txt 2014-02-12 22:13:56.002246423 -0600
@@ -14,15 +14,17 @@ set(CMAKE_AUTOMOC TRUE)
# override the KDE defaults and build tests unless explicitly disabled
option(KDE4_BUILD_TESTS "Build the tests" ON)
+option(QT4_BUILD "Force building with Qt4 even if Qt5 is found")
include_directories(
${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR}
)
+if (NOT QT4_BUILD)
find_package(Qt5Widgets QUIET)
find_package(Qt5DBus QUIET)
-
+endif()
if (${Qt5Widgets_FOUND} AND ${Qt5DBus_FOUND})
set(QT5_BUILD True)