You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
qaccessibilityclient/0001-introduce-QT4_BUILD-op...

37 lines
1002 B

From c3e78300b1f6f460f6c9458c2d989a4498edc0fa Mon Sep 17 00:00:00 2001
From: Rex Dieter <rdieter@math.unl.edu>
Date: Thu, 27 Mar 2014 07:21:01 -0500
Subject: [PATCH 01/12] introduce QT4_BUILD option (default OFF)
Allows builders to control building against Qt4 or Qt5, similar to how
attica is handled.
---
CMakeLists.txt | 3 +++
1 file changed, 3 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75c7b58..233a765 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,14 +14,17 @@ set(CMAKE_AUTOMOC TRUE)
# override the KDE defaults and build tests unless explicitly disabled
option(KDE4_BUILD_TESTS "Build the tests" ON)
+option(QT4_BUILD "Force building with Qt4 even if Qt5 is found")
include_directories(
${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR}
)
+if (NOT QT4_BUILD)
find_package(Qt5Widgets QUIET)
find_package(Qt5DBus QUIET)
+endif()
if (${Qt5Widgets_FOUND} AND ${Qt5DBus_FOUND})
--
2.9.4