From d25cb067bd31ba08dff69547c27d504c482513fd Mon Sep 17 00:00:00 2001
From: tigro <arkadiy.sheyn@softline.com>
Date: Tue, 15 Aug 2023 17:31:40 +0300
Subject: [PATCH] enable tests only for x86_64

---
 SPECS/python3.spec | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/SPECS/python3.spec b/SPECS/python3.spec
index 0917433..133346b 100644
--- a/SPECS/python3.spec
+++ b/SPECS/python3.spec
@@ -1497,6 +1497,7 @@ bash -c "strip -p -R .gnu.lto_* -R .gnu.debuglto_* -N __gnu_lto_v1 \"\$@\"" ARG0
 
 %check
 # first of all, check timestamps of bytecode files
+%ifarch x86_64
 find %{buildroot} -type f -a -name "*.py" -print0 | \
     LD_LIBRARY_PATH="%{buildroot}%{dynload_dir}/:%{buildroot}%{_libdir}" \
     PYTHONPATH="%{buildroot}%{_libdir}/python%{pybasever} %{buildroot}%{_libdir}/python%{pybasever}/site-packages" \
@@ -1569,6 +1570,7 @@ CheckPython optimized
 
 %endif # with tests
 
+%endif # ifarch x86_64
 
 %post -n platform-python
 # Default with no /usr/bin/python symlink