You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
52 lines
1.3 KiB
52 lines
1.3 KiB
diff --git a/pycparser/c_lexer.py b/pycparser/c_lexer.py
|
|
index 045d24e..9b3cbf2 100644
|
|
--- a/pycparser/c_lexer.py
|
|
+++ b/pycparser/c_lexer.py
|
|
@@ -9,8 +9,8 @@
|
|
import re
|
|
import sys
|
|
|
|
-from .ply import lex
|
|
-from .ply.lex import TOKEN
|
|
+from ply import lex
|
|
+from ply.lex import TOKEN
|
|
|
|
|
|
class CLexer(object):
|
|
diff --git a/pycparser/c_parser.py b/pycparser/c_parser.py
|
|
index 744ede8..50156a3 100644
|
|
--- a/pycparser/c_parser.py
|
|
+++ b/pycparser/c_parser.py
|
|
@@ -8,7 +8,7 @@
|
|
#------------------------------------------------------------------------------
|
|
import re
|
|
|
|
-from .ply import yacc
|
|
+from ply import yacc
|
|
|
|
from . import c_ast
|
|
from .c_lexer import CLexer
|
|
diff --git a/setup.py b/setup.py
|
|
index 6dce89c..b3dbfb4 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -8,6 +8,8 @@ except ImportError:
|
|
from distutils.command.install import install as _install
|
|
from distutils.command.sdist import sdist as _sdist
|
|
|
|
+import ply
|
|
+
|
|
|
|
def _run_build_tables(dir):
|
|
from subprocess import check_call
|
|
@@ -60,7 +62,8 @@ setup(
|
|
'Programming Language :: Python :: 3.6',
|
|
],
|
|
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
|
|
- packages=['pycparser', 'pycparser.ply'],
|
|
+ packages=['pycparser'],
|
|
+ install_requires=['ply==' + ply.__version__],
|
|
package_data={'pycparser': ['*.cfg']},
|
|
cmdclass={'install': install, 'sdist': sdist},
|
|
)
|