You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
python-zstandard/SOURCES/python-zstandard-deps.patch

19 lines
857 B

diff -up zstandard-0.23.0/pyproject.toml.orig zstandard-0.23.0/pyproject.toml
--- zstandard-0.23.0/pyproject.toml.orig 2024-07-14 23:58:50.000000000 +0200
+++ zstandard-0.23.0/pyproject.toml 2024-10-03 16:27:20.742934487 +0200
@@ -1,12 +1,12 @@
[build-system]
requires = [
"cffi>=1.16.0; python_version <= '3.12'",
- "cffi==1.17.0rc1; python_version >= '3.13'",
+ "cffi>=1.17.0; python_version >= '3.13'",
# 69.0.0 breaks handling of --config-settings=--build-option, which our CI
# relies on. So constrained to an older version until we figure out a
# workaround. See comment at
# https://github.com/pypa/pip/issues/11859#issuecomment-2132287974.
- "setuptools<69.0.0",
+ "setuptools",
]
# Need to use legacy backend because setup_zstd.py breaks build isolation.
build-backend = "setuptools.build_meta:__legacy__"