You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
python-xxhash/SPECS/python-xxhash.spec

142 lines
4.5 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.6.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 7;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
Name: python-xxhash
Version: 3.4.1
Release: %autorelease
Summary: Python Binding for xxHash
# The entire source is BSD-2-Clause. When the PyPI sdist is used (vs. the
# GitHub archive), a bundled copy of portions of the xxhash C library is also
# present in the source archive; it is under the same license and is removed in
# %%prep.
License: BSD-2-Clause
URL: https://github.com/ifduyue/python-xxhash
Source: %{pypi_source xxhash}
BuildRequires: python3-devel
BuildRequires: gcc
BuildRequires: pkgconfig(libxxhash) >= 0.8.2
%global common_description %{expand:
xxhash is a Python binding for the xxHash library by Yann Collet.}
%description %{common_description}
%package -n python3-xxhash
Summary: %{summary}
%description -n python3-xxhash %{common_description}
%prep
%autosetup -n xxhash-%{version}
# Remove bundled xxhash library
rm -rvf deps
%generate_buildrequires
%pyproject_buildrequires
%build
# Normally, no extra flags are required to link the xxhash shared library, but
# we are prepared:
export CFLAGS="${CFLAGS} $(pkgconf --cflags libxxhash)"
export LDFLAGS="${LDFLAGS} $(pkgconf --libs-only-L libxxhash)"
export LDFLAGS="${LDFLAGS} $(pkgconf --libs-only-other libxxhash)"
export XXHASH_LINK_SO='1'
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files -l xxhash
%check
cd tests
%{py3_test_envvars} %{python3} -m unittest discover
%files -n python3-xxhash -f %{pyproject_files}
%doc CHANGELOG.rst
%doc README.rst
%changelog
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.4.1-7
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 3.4.1-6
- Rebuilt for Python 3.13
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Tue Dec 19 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 3.4.1-3
- Assert that %%pyproject_files contains a license file
* Thu Oct 12 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 3.4.1-2
- F38+: Use %%{py3_test_envvars} to run the tests
* Thu Oct 05 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 3.4.1-1
- Update to 3.4.1 (close RHBZ#2242295)
* Sun Jul 30 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 3.3.0-1
- Update to 3.3.0 (close RHBZ#2227488)
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 3.2.0-5
- Rebuilt for Python 3.12
* Sat Jun 03 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 3.2.0-4
- Remove explicit %%set_build_flags, not needed since F36
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Thu Dec 29 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 3.2.0-1
- Update to 3.2.0 (close RHBZ#2156793)
* Fri Oct 21 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 3.1.0-1
- Update to 3.1.0 (close RHBZ#2136692)
- Convert License to SPDX
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 3.0.0-2
- Rebuilt for Python 3.11
* Sat Feb 26 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 3.0.0-1
- Update to 3.0.0 (close RHBZ#2058811)
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Mon Oct 25 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 2.0.2-2
- Use %%%%python3 macro instead of %%%%__python3
* Fri Sep 17 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 2.0.2-1
- Initial package
## END: Generated by rpmautospec