commit
cdc12006c7
@ -0,0 +1 @@
|
||||
SOURCES/python-xmp-toolkit-2.0.2.tar.gz
|
@ -0,0 +1 @@
|
||||
1ad1db0df5d7797f95f8419dd9c6f4b3dcbbd1c0 SOURCES/python-xmp-toolkit-2.0.2.tar.gz
|
@ -0,0 +1,54 @@
|
||||
From 0cbdae107d9b8e825511c6a6833d47923208ed7d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?J=C3=A9r=C3=B4me=20Carretero?= <cJ@zougloub.eu>
|
||||
Date: Mon, 8 Jan 2024 10:40:00 -0500
|
||||
Subject: [PATCH] enable pypi upload of v2.0.2
|
||||
|
||||
---
|
||||
README.rst | 4 ++--
|
||||
libxmp/version.py | 2 +-
|
||||
setup.py | 1 +
|
||||
3 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/README.rst b/README.rst
|
||||
index 95f7c1f..5e73947 100644
|
||||
--- a/README.rst
|
||||
+++ b/README.rst
|
||||
@@ -24,7 +24,7 @@ Python XMP Toolkit has been developed by:
|
||||
* CRS4 - Centre for Advanced Studies, Research and Development in Sardinia
|
||||
|
||||
Documentation
|
||||
-============
|
||||
+=============
|
||||
Documentation is available at <http://python-xmp-toolkit.readthedocs.org> or can be build using Sphinx: ::
|
||||
|
||||
pip install Sphinx
|
||||
@@ -42,4 +42,4 @@ or (to also show test coverage) ::
|
||||
|
||||
.. image:: https://d2weczhvl823v0.cloudfront.net/python-xmp-toolkit/python-xmp-toolkit/trend.png
|
||||
:alt: Bitdeli badge
|
||||
- :target: https://bitdeli.com/free
|
||||
\ No newline at end of file
|
||||
+ :target: https://bitdeli.com/free
|
||||
diff --git a/libxmp/version.py b/libxmp/version.py
|
||||
index bf1034f..d2aa557 100644
|
||||
--- a/libxmp/version.py
|
||||
+++ b/libxmp/version.py
|
||||
@@ -40,5 +40,5 @@
|
||||
|
||||
# Do not change the format of this next line! Doing so risks breaking
|
||||
# setup.py
|
||||
-VERSION = "2.0.1"
|
||||
+VERSION = "2.0.2"
|
||||
VERSION_TUPLE = LooseVersion(VERSION).version
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 684066f..98b6783 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -58,6 +58,7 @@
|
||||
'author_email': 'lars@hankat.dk',
|
||||
'url': 'https://github.com/python-xmp-toolkit/python-xmp-toolkit',
|
||||
'long_description': open('README.rst').read(),
|
||||
+ 'long_description_content_type': 'text/x-rst',
|
||||
'download_url': 'https://pypi.python.org/pypi/python-xmp-toolkit',
|
||||
'license': 'New BSD License',
|
||||
'install_requires': ['pytz'],
|
After Width: | Height: | Size: 3.8 KiB |
@ -0,0 +1,176 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.6.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
%global pypi_name python-xmp-toolkit
|
||||
%global srcname xmp-toolkit
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 2.0.2
|
||||
Release: %autorelease
|
||||
Summary: Python XMP Toolkit for working with metadata
|
||||
|
||||
License: BSD-3-Clause
|
||||
URL: https://github.com/python-xmp-toolkit/python-xmp-toolkit
|
||||
# Can't use pypi_source due to https://github.com/python-xmp-toolkit/python-xmp-toolkit/issues/91
|
||||
Source0: https://github.com/python-xmp-toolkit/python-xmp-toolkit/archive/v%{version}/%{pypi_name}-%{version}.tar.gz
|
||||
# https://github.com/python-xmp-toolkit/python-xmp-toolkit/pull/84
|
||||
Source1: https://github.com/python-xmp-toolkit/python-xmp-toolkit/raw/e0f42af4a731ac1eea2977895f2c8dd0264304c3/test/samples/BlueSquare.gif
|
||||
Patch: https://github.com/python-xmp-toolkit/python-xmp-toolkit/commit/0cbdae107d9b8e825511c6a6833d47923208ed7d.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
# https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
|
||||
ExcludeArch: %{ix86}
|
||||
|
||||
BuildRequires: exempi
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3dist(sphinx)
|
||||
|
||||
%description
|
||||
Python XMP Toolkit Python XMP Toolkit is a library for working with XMP
|
||||
metadata, as well as reading/writing XMP metadata stored in many different file
|
||||
formats.
|
||||
|
||||
%package -n python3-%{srcname}
|
||||
Summary: %{summary}
|
||||
|
||||
Requires: exempi
|
||||
|
||||
%description -n python3-%{srcname}
|
||||
Python XMP Toolkit Python XMP Toolkit is a library for working with XMP
|
||||
metadata, as well as reading/writing XMP metadata stored in many different file
|
||||
formats.
|
||||
|
||||
|
||||
%package -n python-%{srcname}-doc
|
||||
Summary: python-xmp-toolkit documentation
|
||||
|
||||
%description -n python-%{srcname}-doc
|
||||
Documentation for python-xmp-toolkit
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -n %{pypi_name}-%{version} -p1
|
||||
cp %SOURCE1 test/samples/
|
||||
|
||||
%generate_buildrequires
|
||||
%pyproject_buildrequires
|
||||
|
||||
%build
|
||||
%pyproject_wheel
|
||||
|
||||
# generate html docs
|
||||
PYTHONPATH="$PWD/build/lib" sphinx-build-3 docs html
|
||||
# remove the sphinx-build leftovers
|
||||
rm -rf html/.{doctrees,buildinfo}
|
||||
|
||||
|
||||
%install
|
||||
%pyproject_install
|
||||
%pyproject_save_files -l libxmp
|
||||
|
||||
|
||||
%check
|
||||
%{python3} setup.py test
|
||||
|
||||
|
||||
%files -n python3-%{srcname} -f %{pyproject_files}
|
||||
#license LICENSE
|
||||
%doc README.rst
|
||||
|
||||
%files -n python-%{srcname}-doc
|
||||
%doc html
|
||||
%license LICENSE
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Dec 29 2024 Dmitriy Samoylik <samoylikdv@msvsphere-os.ru> - 2.0.2-3
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 2.0.2-2
|
||||
- Rebuilt for Python 3.13
|
||||
|
||||
* Tue Jan 30 2024 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.0.2-1
|
||||
- Update to latest version (#2257286)
|
||||
|
||||
* Tue Jan 30 2024 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.0.1-24
|
||||
- Switch to latest Python macros
|
||||
|
||||
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Wed Jun 14 2023 Python Maint <python-maint@redhat.com> - 2.0.1-19
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
* Sat Apr 08 2023 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.0.1-18
|
||||
- Switch to SPDX license
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Mon Dec 19 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.0.1-16
|
||||
- Drop support for i686
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 2.0.1-14
|
||||
- Rebuilt for Python 3.11
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.0.1-11
|
||||
- Rebuilt for Python 3.10
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jun 22 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.0.1-8
|
||||
- Backport fixed GIF89a test file for new exempi
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.0.1-7
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 2.0.1-5
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.0.1-4
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Aug 21 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.0.1-1
|
||||
- Initial package.
|
||||
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue