i10ce
changed/i10ce/python-service-identity-24.2.0-1.el10
parent
443e58a583
commit
f5d6858c86
@ -1,4 +1 @@
|
||||
/service_identity-14.0.0.tar.gz
|
||||
/service_identity-16.0.0.tar.gz
|
||||
/service-identity-16.0.0.tar.gz
|
||||
/service-identity-18.1.0.tar.gz
|
||||
SOURCES/service_identity-24.2.0.tar.gz
|
||||
|
@ -0,0 +1 @@
|
||||
bf805eb2e4987b9a9ffd59f62094ec84b529dd84 SOURCES/service_identity-24.2.0.tar.gz
|
@ -0,0 +1,61 @@
|
||||
From 5ab6102dbf6429fe63b2db6f0f6b43a125efe3b5 Mon Sep 17 00:00:00 2001
|
||||
From: Carl George <carlwgeorge@gmail.com>
|
||||
Date: Wed, 6 Nov 2024 18:30:12 -0600
|
||||
Subject: [PATCH 1/2] Remove coverage[toml] test dependency
|
||||
|
||||
---
|
||||
pyproject.toml | 31 +------------------------------
|
||||
1 file changed, 1 insertion(+), 30 deletions(-)
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index dabd973..a43705c 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -36,7 +36,7 @@ dynamic = ["version", "readme"]
|
||||
|
||||
[project.optional-dependencies]
|
||||
idna = ["idna"]
|
||||
-tests = ["coverage[toml]>=5.0.2", "pytest"]
|
||||
+tests = ["pytest"]
|
||||
docs = ["sphinx", "furo", "myst-parser", "sphinx-notfound-page", "pyOpenSSL"]
|
||||
mypy = ["mypy", "types-pyOpenSSL", "idna"]
|
||||
dev = ["service-identity[tests,mypy,idna]", "pyOpenSSL"]
|
||||
@@ -93,35 +93,6 @@ filterwarnings = ["once::Warning"]
|
||||
norecursedirs = ["tests/typing"]
|
||||
|
||||
|
||||
-[tool.coverage.run]
|
||||
-parallel = true
|
||||
-branch = true
|
||||
-source = ["service_identity"]
|
||||
-
|
||||
-[tool.coverage.paths]
|
||||
-source = ["src", ".tox/py*/**/site-packages"]
|
||||
-
|
||||
-[tool.coverage.report]
|
||||
-show_missing = true
|
||||
-skip_covered = true
|
||||
-exclude_lines = [
|
||||
- # a more strict default pragma
|
||||
- "\\# pragma: no cover\\b",
|
||||
-
|
||||
- # allow defensive code
|
||||
- "^\\s*raise AssertionError\\b",
|
||||
- "^\\s*raise NotImplementedError\\b",
|
||||
- "^\\s*return NotImplemented\\b",
|
||||
- "^\\s*raise$",
|
||||
-
|
||||
- # typing-related code
|
||||
- "^if (False|TYPE_CHECKING):",
|
||||
- ": \\.\\.\\.(\\s*#.*)?$",
|
||||
- "^ +\\.\\.\\.$",
|
||||
- "-> ['\"]?NoReturn['\"]?:",
|
||||
-]
|
||||
-
|
||||
-
|
||||
[tool.interrogate]
|
||||
omit-covered-files = true
|
||||
verbose = 2
|
||||
--
|
||||
2.47.0
|
||||
|
@ -0,0 +1,59 @@
|
||||
From d8ef2148b09d6bfa5a6b9c5b025961ad40993e91 Mon Sep 17 00:00:00 2001
|
||||
From: Carl George <carlwgeorge@gmail.com>
|
||||
Date: Wed, 6 Nov 2024 18:27:44 -0600
|
||||
Subject: [PATCH 2/2] Remove hatch-fancy-pypi-readme build-system dependency
|
||||
|
||||
---
|
||||
pyproject.toml | 31 +------------------------------
|
||||
1 file changed, 1 insertion(+), 30 deletions(-)
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index a43705c..3d76d43 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -1,5 +1,5 @@
|
||||
[build-system]
|
||||
-requires = ["hatchling", "hatch-vcs", "hatch-fancy-pypi-readme"]
|
||||
+requires = ["hatchling", "hatch-vcs"]
|
||||
build-backend = "hatchling.build"
|
||||
|
||||
[project]
|
||||
@@ -55,35 +55,6 @@ Twitter = "https://twitter.com/hynek"
|
||||
source = "vcs"
|
||||
raw-options = { local_scheme = "no-local-version" }
|
||||
|
||||
-[tool.hatch.metadata.hooks.fancy-pypi-readme]
|
||||
-content-type = "text/markdown"
|
||||
-
|
||||
-[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
|
||||
-text = "# Service Identity Verification for pyOpenSSL & *cryptography*\n"
|
||||
-
|
||||
-[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
|
||||
-path = "README.md"
|
||||
-start-after = "spiel-begin -->\n"
|
||||
-
|
||||
-[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
|
||||
-text = """
|
||||
-
|
||||
-
|
||||
-## Release Information
|
||||
-
|
||||
-"""
|
||||
-
|
||||
-[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
|
||||
-path = "CHANGELOG.md"
|
||||
-pattern = "\n(###.+?\n)## "
|
||||
-
|
||||
-[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
|
||||
-text = """
|
||||
-----
|
||||
-
|
||||
-[Complete Changelog →](https://service-identity.readthedocs.io/en/stable/changelog.html)
|
||||
-"""
|
||||
-
|
||||
|
||||
[tool.pytest.ini_options]
|
||||
addopts = ["-ra", "--strict-markers", "--strict-config"]
|
||||
--
|
||||
2.47.0
|
||||
|
Loading…
Reference in new issue