You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
178 lines
6.2 KiB
178 lines
6.2 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.6.5)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 8;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
%global pypiname Send2Trash
|
|
|
|
Name: python-send2trash
|
|
Version: 1.8.2
|
|
Release: %autorelease
|
|
Summary: Python library to natively send files to Trash
|
|
|
|
License: BSD-3-Clause
|
|
URL: https://github.com/hsoft/send2trash
|
|
|
|
# PyPI sdist lacks tests
|
|
Source0: %url/archive/%{version}/%{pypiname}-%{version}.tar.gz
|
|
|
|
BuildArch: noarch
|
|
|
|
BuildRequires: python3-devel
|
|
BuildRequires: python3-pytest
|
|
|
|
%description
|
|
Send2Trash is a small package that sends files to the Trash (or Recycle Bin)
|
|
natively and on all platforms. On OS X, it uses native FSMoveObjectToTrashSync
|
|
Cocoa calls, on Windows, it uses native (and ugly) SHFileOperation win32 calls.
|
|
On other platforms, if PyGObject and GIO are available, it will use this.
|
|
Otherwise, it will fallback to its own implementation of the trash specifications
|
|
from freedesktop.org.
|
|
|
|
%package -n python3-send2trash
|
|
|
|
Summary: Python library to natively send files to Trash
|
|
Provides: python3-%{pypiname} == %{version}-%{release}
|
|
|
|
%{?python_provide:%python_provide python3-%{pypiname}}
|
|
%{?python_provide:%python_provide python3-send2trash}
|
|
|
|
%description -n python3-send2trash
|
|
Send2Trash is a small package that sends files to the Trash (or Recycle Bin)
|
|
natively and on all platforms. On OS X, it uses native FSMoveObjectToTrashSync
|
|
Cocoa calls, on Windows, it uses native (and ugly) SHFileOperation win32 calls.
|
|
On other platforms, if PyGObject and GIO are available, it will use this.
|
|
Otherwise, it will fallback to its own implementation of the trash specifications
|
|
from freedesktop.org.
|
|
|
|
%generate_buildrequires
|
|
%pyproject_buildrequires
|
|
|
|
%prep
|
|
%setup -q -n send2trash-%{version}
|
|
|
|
%build
|
|
%pyproject_wheel
|
|
|
|
%install
|
|
%pyproject_install
|
|
%pyproject_save_files send2trash
|
|
|
|
%check
|
|
%pytest
|
|
|
|
%files -n python3-send2trash -f %{pyproject_files}
|
|
%doc README.rst CHANGES.rst
|
|
%{_bindir}/send2trash
|
|
|
|
%changelog
|
|
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.8.2-8
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 1.8.2-7
|
|
- Rebuilt for Python 3.13
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 1.8.2-2
|
|
- Rebuilt for Python 3.12
|
|
|
|
* Fri Apr 28 2023 Lumír Balhar <lbalhar@redhat.com> - 1.8.2-1
|
|
- Update to 1.8.2 (rhbz#1996282)
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.0-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.0-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 1.8.0-3
|
|
- Rebuilt for Python 3.11
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Wed Aug 11 2021 Tomas Hrnciar <thrnciar@redhat.com> - 1.8.0-1
|
|
- Update to 1.8.0
|
|
- Fixes: rhbz#1991779
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Fri Jun 25 2021 Tomas Hrnciar <thrnciar@redhat.com> - 1.7.1-1
|
|
- Update to 1.7.1
|
|
|
|
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 1.5.0-2
|
|
- Rebuilt for Python 3.10
|
|
|
|
* Thu Feb 18 2021 Lumír Balhar <lbalhar@redhat.com> - 1.5.0-1
|
|
- Update to 1.5.0
|
|
Resolves: rhbz#1697055
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-15
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-14
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Sun May 24 2020 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-13
|
|
- Rebuilt for Python 3.9
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-12
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-11
|
|
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
|
|
|
* Sun Aug 18 2019 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-10
|
|
- Rebuilt for Python 3.8
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Tue Jun 18 2019 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-8
|
|
- Subpackage python2-send2trash has been removed
|
|
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
|
|
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-5
|
|
- Rebuilt for Python 3.7
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.2-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Tue Jan 09 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-3
|
|
- Run tests, use GH tarball
|
|
- Be more explicit in %%files
|
|
- Add plain pythonX-%%{pypiname} provides
|
|
- Correct a typo in Python 2 python_provide
|
|
|
|
* Sat Jan 06 2018 williamjmorenor@gmail.com - 1.4.2-2
|
|
- Initial import of BZ#1529027
|
|
|
|
* Tue Dec 26 2017 williamjmorenor@gmail.com - 1.4.2-1
|
|
- Initial Packaging
|
|
|
|
## END: Generated by rpmautospec
|