Remove merged patch

epel9
Fabio Alessandro Locati 9 years ago
parent 0da6546869
commit f038075355

@ -19,7 +19,6 @@ Summary: Pure-Python RSA implementation
License: ASL 2.0
URL: http://stuvel.eu/rsa
Source0: https://pypi.python.org/packages/source/r/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
Patch0: rsa-3.1.4-debian-804430.patch
BuildArch: noarch
BuildRequires: python2-devel
@ -68,11 +67,8 @@ well as on the command-line.
%prep
%setup -q -n %{pypi_name}-%{version}
# Fix FTBFS (https://bitbucket.org/sybren/python-rsa/pull-requests/15/)
%patch0
rm -rf %{pypi_name}.egg-info
# This is a dirty workaround for EL6. I'm copying as is from a 2014 commit.
# I'll try to improve it ASAP
# This is a dirty workaround for EL6
%{?el6:rm -rf %{pypi_name}.egg-info}
%{?el6:sed -i "s/pyasn1 >= 0.1.3/pyasn1 >= 0/" setup.py}
%build
@ -161,6 +157,7 @@ cp %{buildroot}%{_bindir}/pyrsa-decrypt-bigfile %{buildroot}%{_bindir}/pyrsa-dec
%changelog
* Fri Mar 18 2016 Fabio Alessandro Locati <fabio@locati.cc> - 3.4-1
- Bump to 3.4
- Remove the patch that is no longer needed since it has been merged upstream
* Tue Feb 09 2016 Fabio Alessandro Locati <fabio@locati.cc> - 3.3-5
- Fix bug #1305644

@ -1,38 +0,0 @@
--- rsa/_version133.py
+++ rsa/_version133.py
@@ -18,7 +18,12 @@ __version__ = '1.3.3'
# NOTE: Python's modulo can return negative numbers. We compensate for
# this behaviour using the abs() function
-from cPickle import dumps, loads
+try:
+ import cPickle as pickle
+except:
+ import pickle
+from pickle import dumps, loads
+
import base64
import math
import os
--- tests/constants.py
+++ tests/constants.py
@@ -3,7 +3,7 @@
from rsa._compat import have_python3
if have_python3:
- from py3kconstants import *
+ from tests.py3kconstants import *
else:
from py2kconstants import *
--- tests/test_strings.py
+++ tests/test_strings.py
@@ -6,7 +6,7 @@ import unittest2
import rsa
-from constants import unicode_string
+from tests.constants import unicode_string
class StringTest(unittest2.TestCase):
Loading…
Cancel
Save