You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
191 lines
7.1 KiB
191 lines
7.1 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.2)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 5;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
%global pypi_name requests-cache
|
|
%global mod_name requests_cache
|
|
|
|
Name: python-%{pypi_name}
|
|
Version: 1.2.0
|
|
Release: %autorelease
|
|
Summary: Persistent cache for requests library
|
|
|
|
# Automatically converted from old format: BSD - review is highly recommended.
|
|
License: LicenseRef-Callaway-BSD
|
|
URL: https://github.com/reclosedev/requests-cache
|
|
Source0: https://files.pythonhosted.org/packages/source/r/%{pypi_name}/requests_cache-%{version}.tar.gz
|
|
BuildArch: noarch
|
|
|
|
BuildRequires: python3-devel
|
|
BuildRequires: python3-sphinx
|
|
|
|
%description
|
|
requests-cache is a persistent HTTP cache that provides an easy way
|
|
to get better performance with the python requests library.
|
|
|
|
%package -n python3-%{pypi_name}
|
|
Summary: Persistent cache for requests library
|
|
Requires: python3-requests
|
|
|
|
%description -n python3-%{pypi_name}
|
|
requests-cache is a persistent HTTP cache that provides an easy way
|
|
to get better performance with the python requests library.
|
|
|
|
%generate_buildrequires
|
|
%pyproject_buildrequires
|
|
|
|
%prep
|
|
%autosetup -n requests_cache-%{version}
|
|
|
|
%build
|
|
%pyproject_wheel
|
|
|
|
%install
|
|
%pyproject_install
|
|
%pyproject_save_files %{mod_name}
|
|
|
|
%check
|
|
%pyproject_check_import -t
|
|
|
|
%files -n python3-%{pypi_name} -f %{pyproject_files}
|
|
%doc README.md
|
|
%license LICENSE
|
|
|
|
%changelog
|
|
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.2.0-5
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Wed Sep 04 2024 Miroslav Suchý <msuchy@redhat.com> - 1.2.0-5
|
|
- convert license to SPDX
|
|
|
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Mon Jun 17 2024 Python Maint <python-maint@redhat.com> - 1.2.0-3
|
|
- Rebuilt for Python 3.13
|
|
|
|
* Fri May 03 2024 Frantisek Zatloukal <fzatlouk@redhat.com> - 1.2.0-1
|
|
- Rebase to 1.2.0
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-18
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-17
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-16
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Wed Jun 14 2023 Python Maint <python-maint@redhat.com> - 0.5.1-15
|
|
- Rebuilt for Python 3.12
|
|
|
|
* Wed Mar 22 2023 Andrew Bauer <zonexpertconsulting@outlook.com> - 0.5.1-14
|
|
- Latest sphinx no longer bundles jquery. Fixes BZ 2180485
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-13
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-12
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 0.5.1-11
|
|
- Rebuilt for Python 3.11
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 0.5.1-8
|
|
- Rebuilt for Python 3.10
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 0.5.1-5
|
|
- Rebuilt for Python 3.9
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.5.1-3
|
|
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
|
|
|
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.5.1-2
|
|
- Rebuilt for Python 3.8
|
|
|
|
* Wed Aug 14 2019 Richard Shaw <hobbes1069@gmail.com> - 0.5.1-1
|
|
- Update to 0.5.1.
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.13-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Thu Feb 14 2019 Richard Shaw <hobbes1069@gmail.com> - 0.4.13-7
|
|
- Build both python2 and python3 packages.
|
|
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.13-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Fri Oct 12 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.4.13-5
|
|
- Python2 binary package has been removed
|
|
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
|
|
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.13-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.4.13-3
|
|
- Rebuilt for Python 3.7
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.13-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Sun Sep 17 2017 Miro Hrončok <mhroncok@redhat.com> - 0.4.13-1
|
|
- Updated to 0.4.13 (#1324920)
|
|
- Fixed Source0 URL
|
|
- Use python2- (Build)Requires
|
|
|
|
* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.4.6-10
|
|
- Python 2 binary package renamed to python2-requests-cache
|
|
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.6-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.6-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.4.6-7
|
|
- Rebuild for Python 3.6
|
|
|
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.6-6
|
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.6-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.6-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.6-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Thu Oct 30 2014 Ricky Elrod <relrod@redhat.com> - 0.4.6-2
|
|
- Fix rpmlint warnings: line endings in docs/license
|
|
- Fix rpmlint warnings: shebang line in non-scripts
|
|
|
|
* Wed Oct 29 2014 Ricky Elrod <relrod@redhat.com> - 0.4.6-1
|
|
- Initial package.
|
|
|
|
## END: Generated by rpmautospec
|