Adds RDF 1.1 feature support, RDFa, Microdata, and TriG parsers, HTML5 handling. The tools originally provided by python-rdfextras are now provided as part of python-rdflib itself, so we add an Obsoletes line accordingly. We also make SPARQLWrapper an "extras_require" for 4.1; per upstream discussion, SPARQLWrapper can be an optional dependency for 4.1 but will be made mandatory for 4.2. This gives us time to ensure SPARQLWrapper is packaged while providing all of the rest of the bug fixes and additional functionality in RDFLib 4.1. Signed-off-by: Dan Scott <dan@coffeecode.net>epel9
parent
d0db4c0fd7
commit
499cd94260
@ -0,0 +1,40 @@
|
||||
From 7b69cb5f2fe46d46814712cdc43123807c681dc3 Mon Sep 17 00:00:00 2001
|
||||
From: Dan Scott <dan@coffeecode.net>
|
||||
Date: Sun, 2 Mar 2014 19:55:08 -0500
|
||||
Subject: [PATCH] Make SPARQLWrapper an extra_requires for now
|
||||
|
||||
Per discussion in https://github.com/RDFLib/rdflib/pull/359
|
||||
|
||||
Signed-off-by: Dan Scott <dan@coffeecode.net>
|
||||
---
|
||||
setup.py | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index c00a978..380d449 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -41,8 +41,8 @@ if sys.version_info[0] >= 3:
|
||||
kwargs['install_requires'] = ['isodate', 'pyparsing']
|
||||
kwargs['tests_require'] = ['html5lib']
|
||||
kwargs['requires'] = [
|
||||
- 'isodate', 'pyparsing',
|
||||
- 'SPARQLWrapper']
|
||||
+ 'isodate', 'pyparsing']
|
||||
+ kwargs['extras_require'] = {'SPARQLStore': 'SPARQLWrapper'}
|
||||
kwargs['src_root'] = setup_python3()
|
||||
assert setup
|
||||
else:
|
||||
@@ -52,7 +52,8 @@ else:
|
||||
kwargs['test_suite'] = "nose.collector"
|
||||
kwargs['install_requires'] = [
|
||||
'isodate',
|
||||
- 'pyparsing', 'SPARQLWrapper']
|
||||
+ 'pyparsing']
|
||||
+ kwargs['extras_require'] = {'SPARQLStore': 'SPARQLWrapper'}
|
||||
|
||||
if sys.version_info[1]<7: # Python 2.6
|
||||
kwargs['install_requires'].append('ordereddict')
|
||||
--
|
||||
1.8.5.3
|
||||
|
Loading…
Reference in new issue