i10ce
changed/i10ce/python-pytest-httpserver-1.0.8-5.el10
commit
6520251bda
@ -0,0 +1 @@
|
||||
SOURCES/pytest-httpserver-1.0.8.tar.gz
|
@ -0,0 +1 @@
|
||||
41652ab4a5719ad40c183b9f282eb117b7045a59 SOURCES/pytest-httpserver-1.0.8.tar.gz
|
@ -0,0 +1,16 @@
|
||||
--- a/pyproject.toml 2022-06-30 14:59:14.129513366 +0300
|
||||
+++ b/pyproject.toml 2022-06-30 14:59:48.066496449 +0300
|
||||
@@ -15,13 +15,6 @@ classifiers = [
|
||||
]
|
||||
repository = "https://github.com/csernazs/pytest-httpserver"
|
||||
|
||||
-include = [
|
||||
- { path = "tests", format = "sdist" },
|
||||
- { path = "CHANGES.rst", format = "sdist" },
|
||||
- { path = "CONTRIBUTION.md", format = "sdist" },
|
||||
- { path = "example*.py", format = "sdist" },
|
||||
- { path = "doc", format = "sdist" },
|
||||
-]
|
||||
|
||||
[tool.poetry.dependencies]
|
||||
python = ">=3.8,<4.0"
|
@ -0,0 +1,94 @@
|
||||
%global srcname pytest-httpserver
|
||||
|
||||
%global desc %{expand: \
|
||||
This library is designed to help to test http clients without contacting
|
||||
the real http server. In other words, it is a fake http server which is
|
||||
accessible via localhost can be started with the pre-defined expected
|
||||
http requests and their responses.}
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 1.0.8
|
||||
Release: 5%{?dist}
|
||||
Summary: HTTP server for pytest
|
||||
|
||||
License: MIT
|
||||
URL: https://github.com/csernazs/pytest-httpserver
|
||||
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
|
||||
|
||||
Patch0: pyproject.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-pytest
|
||||
BuildRequires: python3-requests
|
||||
BuildRequires: python3-toml
|
||||
BuildRequires: pyproject-rpm-macros
|
||||
|
||||
%description
|
||||
%{desc}
|
||||
|
||||
%package -n python3-%{srcname}
|
||||
Summary: %{summary}
|
||||
|
||||
%description -n python3-%{srcname} %desc
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{srcname}-%{version}
|
||||
|
||||
# Remove unnecessary dependencies
|
||||
sed -i '/flake8/d' pyproject.toml
|
||||
sed -i '/pytest-cov/d' pyproject.toml
|
||||
sed -i '/coverage/d' pyproject.toml
|
||||
sed -i '/mypy/d' pyproject.toml
|
||||
sed -i '/types-requests/d' pyproject.toml
|
||||
|
||||
%generate_buildrequires
|
||||
%pyproject_buildrequires -x test
|
||||
|
||||
%build
|
||||
%pyproject_wheel
|
||||
|
||||
%install
|
||||
%pyproject_install
|
||||
%pyproject_save_files pytest_httpserver
|
||||
|
||||
%check
|
||||
%pytest
|
||||
|
||||
%files -n python3-%{srcname} -f %{pyproject_files}
|
||||
%doc README.md CHANGES.rst CONTRIBUTION.md
|
||||
|
||||
%changelog
|
||||
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.0.8-5
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Sat Jun 08 2024 Python Maint <python-maint@redhat.com> - 1.0.8-4
|
||||
- Rebuilt for Python 3.13
|
||||
|
||||
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Thu Dec 07 2023 Frantisek Zatloukal <fzatlouk@redhat.com> - 1.0.8-1
|
||||
- pytest-httpserver 1.0.8
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Jun 22 2023 Python Maint <python-maint@redhat.com> - 1.0.4-4
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Thu Jun 30 2022 Ali Erdinc Koroglu <aekoroglu@fedorapackage.org> - 1.0.4-1
|
||||
- Initial package
|
Loading…
Reference in new issue