commit
7c3c94e31c
@ -0,0 +1 @@
|
||||
SOURCES/pycurl-7.43.0.2.tar.gz
|
@ -0,0 +1 @@
|
||||
cd617ed4e40a3b8f5ca5bf54aba7f35ed25afa46 SOURCES/pycurl-7.43.0.2.tar.gz
|
@ -0,0 +1,93 @@
|
||||
From 047bd00ee53a722eaf46e58e330888cf628d5a7c Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 14 Jan 2019 16:54:19 +0100
|
||||
Subject: [PATCH 1/2] do_curl_setopt_httppost: do not use uninitialized stack
|
||||
variable
|
||||
|
||||
Detected by Coverity Analysis and Clang:
|
||||
|
||||
Error: UNINIT (CWE-457):
|
||||
pycurl-7.43.0.2/src/easyopt.c:493: var_decl: Declaring variable "res" without initializer.
|
||||
pycurl-7.43.0.2/src/easyopt.c:524: uninit_use_in_call: Using uninitialized value "(int)res" when calling "create_and_set_error_object".
|
||||
522| if (PyText_AsStringAndSize(httppost_option, &cstr, &clen, &cencoded_obj)) {
|
||||
523| PyText_EncodedDecref(nencoded_obj);
|
||||
524|-> CURLERROR_SET_RETVAL();
|
||||
525| goto error;
|
||||
526| }
|
||||
|
||||
Error: CLANG_WARNING:
|
||||
pycurl-7.43.0.2/src/easyopt.c:524:17: warning: 2nd function call argument is an uninitialized value
|
||||
pycurl-7.43.0.2/src/pycurl.h:286:5: note: expanded from macro 'CURLERROR_SET_RETVAL'
|
||||
pycurl-7.43.0.2/src/easyopt.c:493:5: note: 'res' declared without an initial value
|
||||
pycurl-7.43.0.2/src/easyopt.c:496:9: note: Assuming 'len' is not equal to 0
|
||||
pycurl-7.43.0.2/src/easyopt.c:496:5: note: Taking false branch
|
||||
pycurl-7.43.0.2/src/easyopt.c:499:17: note: Assuming 'i' is < 'len'
|
||||
pycurl-7.43.0.2/src/easyopt.c:499:5: note: Loop condition is true. Entering loop body
|
||||
pycurl-7.43.0.2/src/easyopt.c:505:13: note: Assuming 'which_httppost_item' is not equal to 0
|
||||
pycurl-7.43.0.2/src/easyopt.c:505:9: note: Taking false branch
|
||||
pycurl-7.43.0.2/src/easyopt.c:509:13: note: Assuming the condition is false
|
||||
pycurl-7.43.0.2/src/easyopt.c:509:9: note: Taking false branch
|
||||
pycurl-7.43.0.2/src/easyopt.c:513:13: note: Assuming the condition is false
|
||||
pycurl-7.43.0.2/src/easyopt.c:513:9: note: Taking false branch
|
||||
pycurl-7.43.0.2/src/easyopt.c:519:13: note: Assuming the condition is true
|
||||
pycurl-7.43.0.2/src/easyopt.c:519:9: note: Taking true branch
|
||||
pycurl-7.43.0.2/src/easyopt.c:522:17: note: Assuming the condition is true
|
||||
pycurl-7.43.0.2/src/easyopt.c:522:13: note: Taking true branch
|
||||
pycurl-7.43.0.2/src/easyopt.c:524:17: note: 2nd function call argument is an uninitialized value
|
||||
pycurl-7.43.0.2/src/pycurl.h:286:5: note: expanded from macro 'CURLERROR_SET_RETVAL'
|
||||
---
|
||||
src/easyopt.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/easyopt.c b/src/easyopt.c
|
||||
index 015fa93..471400c 100644
|
||||
--- a/src/easyopt.c
|
||||
+++ b/src/easyopt.c
|
||||
@@ -521,7 +521,7 @@ do_curl_setopt_httppost(CurlObject *self, int option, int which, PyObject *obj)
|
||||
|
||||
if (PyText_AsStringAndSize(httppost_option, &cstr, &clen, &cencoded_obj)) {
|
||||
PyText_EncodedDecref(nencoded_obj);
|
||||
- CURLERROR_SET_RETVAL();
|
||||
+ create_and_set_error_object(self, CURLE_BAD_FUNCTION_ARGUMENT);
|
||||
goto error;
|
||||
}
|
||||
/* INFO: curl_formadd() internally does memdup() the data, so
|
||||
--
|
||||
2.17.2
|
||||
|
||||
|
||||
From 6f0f7896412c107c390f4967dcdf94fd14d52047 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 14 Jan 2019 16:57:14 +0100
|
||||
Subject: [PATCH 2/2] do_multi_add_handle: execute clean-up code before return
|
||||
|
||||
Detected by Coverity Analysis:
|
||||
|
||||
Error: UNREACHABLE (CWE-561):
|
||||
pycurl-7.43.0.2/src/multi.c:631: unreachable: This code cannot be reached: "PyDict_DelItem(self->easy_o...".
|
||||
629| if (res != CURLM_OK) {
|
||||
630| CURLERROR_MSG("curl_multi_add_handle() failed due to internal errors");
|
||||
631|-> PyDict_DelItem(self->easy_object_dict, (PyObject *) obj);
|
||||
632| }
|
||||
633| obj->multi_stack = self;
|
||||
---
|
||||
src/multi.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/multi.c b/src/multi.c
|
||||
index 7ecedbf..3407423 100644
|
||||
--- a/src/multi.c
|
||||
+++ b/src/multi.c
|
||||
@@ -627,8 +627,8 @@ do_multi_add_handle(CurlMultiObject *self, PyObject *args)
|
||||
assert(obj->multi_stack == NULL);
|
||||
res = curl_multi_add_handle(self->multi_handle, obj->handle);
|
||||
if (res != CURLM_OK) {
|
||||
- CURLERROR_MSG("curl_multi_add_handle() failed due to internal errors");
|
||||
PyDict_DelItem(self->easy_object_dict, (PyObject *) obj);
|
||||
+ CURLERROR_MSG("curl_multi_add_handle() failed due to internal errors");
|
||||
}
|
||||
obj->multi_stack = self;
|
||||
Py_INCREF(self);
|
||||
--
|
||||
2.17.2
|
||||
|
@ -0,0 +1,54 @@
|
||||
From 36dcccb94bef72a7c4cf6acf7479f18568e545bb Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 2 May 2017 17:19:20 +0200
|
||||
Subject: [PATCH] module: drop link-time vs. run-time TLS backend check
|
||||
|
||||
This effectively reverts the following commit:
|
||||
8891398a31119ce7c872509ed60328926c51cdfb
|
||||
|
||||
Bug: https://bugzilla.redhat.com/1446850
|
||||
---
|
||||
src/module.c | 20 +-------------------
|
||||
1 file changed, 1 insertion(+), 19 deletions(-)
|
||||
|
||||
diff --git a/src/module.c b/src/module.c
|
||||
index a7108a0..af79875 100644
|
||||
--- a/src/module.c
|
||||
+++ b/src/module.c
|
||||
@@ -322,7 +322,7 @@ initpycurl(void)
|
||||
{
|
||||
PyObject *m, *d;
|
||||
const curl_version_info_data *vi;
|
||||
- const char *libcurl_version, *runtime_ssl_lib;
|
||||
+ const char *libcurl_version;
|
||||
size_t libcurl_version_len, pycurl_version_len;
|
||||
PyObject *xio_module = NULL;
|
||||
PyObject *collections_module = NULL;
|
||||
@@ -345,24 +345,6 @@ initpycurl(void)
|
||||
goto error;
|
||||
}
|
||||
|
||||
- /* Our compiled crypto locks should correspond to runtime ssl library. */
|
||||
- if (vi->ssl_version == NULL) {
|
||||
- runtime_ssl_lib = "none/other";
|
||||
- } else if (!strncmp(vi->ssl_version, "OpenSSL/", 8) || !strncmp(vi->ssl_version, "LibreSSL/", 9) ||
|
||||
- !strncmp(vi->ssl_version, "BoringSSL", 9)) {
|
||||
- runtime_ssl_lib = "openssl";
|
||||
- } else if (!strncmp(vi->ssl_version, "GnuTLS/", 7)) {
|
||||
- runtime_ssl_lib = "gnutls";
|
||||
- } else if (!strncmp(vi->ssl_version, "NSS/", 4)) {
|
||||
- runtime_ssl_lib = "nss";
|
||||
- } else {
|
||||
- runtime_ssl_lib = "none/other";
|
||||
- }
|
||||
- if (strcmp(runtime_ssl_lib, COMPILE_SSL_LIB)) {
|
||||
- PyErr_Format(PyExc_ImportError, "pycurl: libcurl link-time ssl backend (%s) is different from compile-time ssl backend (%s)", runtime_ssl_lib, COMPILE_SSL_LIB);
|
||||
- goto error;
|
||||
- }
|
||||
-
|
||||
/* Initialize the type of the new type objects here; doing it here
|
||||
* is required for portability to Windows without requiring C++. */
|
||||
p_Curl_Type = &Curl_Type;
|
||||
--
|
||||
2.10.2
|
||||
|
@ -0,0 +1,32 @@
|
||||
From f5141d34f54ec2ae3309324a99f0f5887f0a8201 Mon Sep 17 00:00:00 2001
|
||||
From: Dmitriy Taychenachev <dmitriy.taychenachev@skypicker.com>
|
||||
Date: Tue, 9 Apr 2019 11:23:58 +0200
|
||||
Subject: [PATCH] decode_string_list: fix populating list of decoded strings
|
||||
|
||||
Under Python3 the call curl.getinfo(pycurl.INFO_COOKIELIST) returns
|
||||
invalid list (for example [<NULL>]), which cases segmentation fault.
|
||||
The cause is in function decode_string_list() (Python3 only) which
|
||||
creates new list without populating it with elements. This commit
|
||||
adds the setting of elements fixing the behaviour.
|
||||
|
||||
Upstream-commit: 5df7a0e5bb38a3db5f04721add571cd32c5e3eb8
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
src/easyinfo.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/easyinfo.c b/src/easyinfo.c
|
||||
index b3d731b..3712646 100644
|
||||
--- a/src/easyinfo.c
|
||||
+++ b/src/easyinfo.c
|
||||
@@ -277,6 +277,7 @@ decode_string_list(PyObject *list)
|
||||
if (decoded_item == NULL) {
|
||||
goto err;
|
||||
}
|
||||
+ PyList_SetItem(decoded_list, i, decoded_item);
|
||||
}
|
||||
|
||||
return decoded_list;
|
||||
--
|
||||
2.21.1
|
||||
|
@ -0,0 +1,401 @@
|
||||
# python3 is not available on RHEL <= 7
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%bcond_without python3
|
||||
%else
|
||||
%bcond_with python3
|
||||
%endif
|
||||
|
||||
# python2 is not available on RHEL > 7 and not needed on Fedora > 29
|
||||
%if 0%{?rhel} > 7 || 0%{?fedora} > 29
|
||||
%bcond_with python2
|
||||
%else
|
||||
%bcond_without python2
|
||||
%endif
|
||||
|
||||
%global modname pycurl
|
||||
|
||||
Name: python-%{modname}
|
||||
Version: 7.43.0.2
|
||||
Release: 4%{?dist}
|
||||
Summary: A Python interface to libcurl
|
||||
|
||||
License: LGPLv2+ or MIT
|
||||
URL: http://pycurl.sourceforge.net/
|
||||
Source0: https://dl.bintray.com/pycurl/pycurl/pycurl-%{version}.tar.gz
|
||||
|
||||
# fix programming mistakes detected by static analyzers
|
||||
# upstream pull request: https://github.com/pycurl/pycurl/pull/550
|
||||
Patch1: 0001-python-pycurl-7.43.0.2-static-analysis.patch
|
||||
|
||||
# drop link-time vs. run-time TLS backend check (#1446850)
|
||||
Patch2: 0002-python-pycurl-7.43.0-tls-backend.patch
|
||||
|
||||
# fix populating list of decoded strings (#1792213)
|
||||
Patch3: 0003-python-pycurl-7.43.0.2-decode-cookie-info.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: vsftpd
|
||||
|
||||
# During its initialization, PycURL checks that the actual libcurl version
|
||||
# is not lower than the one used when PycURL was built.
|
||||
# Yes, that should be handled by library versioning (which would then get
|
||||
# automatically reflected by rpm).
|
||||
# For now, we have to reflect that dependency.
|
||||
%global libcurl_sed '/^#define LIBCURL_VERSION "/!d;s/"[^"]*$//;s/.*"//;q'
|
||||
%global curlver_h /usr/include/curl/curlver.h
|
||||
%global libcurl_ver %(sed %{libcurl_sed} %{curlver_h} 2>/dev/null || echo 0)
|
||||
|
||||
%description
|
||||
PycURL is a Python interface to libcurl. PycURL can be used to fetch
|
||||
objects identified by a URL from a Python program, similar to the
|
||||
urllib Python module. PycURL is mature, very fast, and supports a lot
|
||||
of features.
|
||||
|
||||
%if %{with python2}
|
||||
%package -n python2-%{modname}
|
||||
Summary: Python interface to libcurl for Python 2
|
||||
%{?python_provide:%python_provide python2-%{modname}}
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python2-bottle
|
||||
BuildRequires: python2-nose
|
||||
Requires: libcurl%{?_isa} >= %{libcurl_ver}
|
||||
|
||||
Provides: %{modname} = %{version}-%{release}
|
||||
|
||||
%description -n python2-%{modname}
|
||||
PycURL is a Python interface to libcurl. PycURL can be used to fetch
|
||||
objects identified by a URL from a Python program, similar to the
|
||||
urllib Python module. PycURL is mature, very fast, and supports a lot
|
||||
of features.
|
||||
|
||||
Python 2 version.
|
||||
%endif
|
||||
|
||||
%if %{with python3}
|
||||
%package -n python3-%{modname}
|
||||
Summary: Python interface to libcurl for Python 3
|
||||
%{?python_provide:%python_provide python3-%{modname}}
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-bottle
|
||||
BuildRequires: python3-nose
|
||||
Requires: libcurl%{?_isa} >= %{libcurl_ver}
|
||||
|
||||
%description -n python3-%{modname}
|
||||
PycURL is a Python interface to libcurl. PycURL can be used to fetch
|
||||
objects identified by a URL from a Python program, similar to the
|
||||
urllib Python module. PycURL is mature, very fast, and supports a lot
|
||||
of features.
|
||||
|
||||
Python 3 version.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -n %{modname}-%{version} -p1
|
||||
|
||||
# remove binaries packaged by upstream
|
||||
rm -f tests/fake-curl/libcurl/*.so
|
||||
|
||||
# remove a test-case that relies on sftp://web.sourceforge.net being available
|
||||
rm -f tests/ssh_key_cb_test.py
|
||||
|
||||
# remove a test-case that fails in Koji
|
||||
rm -f tests/seek_cb_test.py
|
||||
|
||||
# remove tests depending on the 'flaky' nose plug-in (not available in Fedora)
|
||||
grep '^import flaky' -r tests | cut -d: -f1 | xargs rm -fv
|
||||
|
||||
# drop options that are not supported by nose in Fedora
|
||||
sed -e 's/ --show-skipped//' \
|
||||
-e 's/ --with-flaky//' \
|
||||
-i tests/run.sh
|
||||
|
||||
%build
|
||||
%if %{with python2}
|
||||
%py2_build -- --with-openssl
|
||||
%endif
|
||||
%if %{with python3}
|
||||
%py3_build -- --with-openssl
|
||||
%endif
|
||||
|
||||
%install
|
||||
export PYCURL_SSL_LIBRARY=openssl
|
||||
%if %{with python2}
|
||||
%py2_install
|
||||
%endif
|
||||
%if %{with python3}
|
||||
%py3_install
|
||||
%endif
|
||||
rm -rf %{buildroot}%{_datadir}/doc/pycurl
|
||||
|
||||
%if %{with python3}
|
||||
%check
|
||||
export PYTHONPATH=%{buildroot}%{python3_sitearch}
|
||||
export PYCURL_SSL_LIBRARY=openssl
|
||||
export PYCURL_VSFTPD_PATH=vsftpd
|
||||
|
||||
# relax crypto policy for the test-suite to make it pass again (#1611739)
|
||||
export OPENSSL_SYSTEM_CIPHERS_OVERRIDE=XXX
|
||||
export OPENSSL_CONF=
|
||||
|
||||
make test PYTHON=%{__python3} NOSETESTS="nosetests-%{python3_version} -v" PYFLAKES=:
|
||||
rm -fv tests/fake-curl/libcurl/*.so
|
||||
%endif
|
||||
|
||||
%if %{with python2}
|
||||
%files -n python2-%{modname}
|
||||
%license COPYING-LGPL COPYING-MIT
|
||||
%doc ChangeLog README.rst examples doc tests
|
||||
%{python2_sitearch}/curl/
|
||||
%{python2_sitearch}/%{modname}.so
|
||||
%{python2_sitearch}/%{modname}-%{version}-*.egg-info
|
||||
%endif
|
||||
|
||||
%if %{with python3}
|
||||
%files -n python3-%{modname}
|
||||
%license COPYING-LGPL COPYING-MIT
|
||||
%doc ChangeLog README.rst examples doc tests
|
||||
%{python3_sitearch}/curl/
|
||||
%{python3_sitearch}/%{modname}.*.so
|
||||
%{python3_sitearch}/%{modname}-%{version}-*.egg-info
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 22 2020 Kamil Dudka <kdudka@redhat.com> - 7.43.0.2-4
|
||||
- fix populating list of decoded strings (#1792213)
|
||||
- fix programming mistakes detected by static analyzers (#1666003)
|
||||
|
||||
* Thu Dec 20 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0.2-3
|
||||
- drop build-time (%%check-only) dependency on pyflakes (#1661168)
|
||||
|
||||
* Tue Aug 07 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0.2-2
|
||||
- relax crypto policy for the test-suite to make it pass again (#1611739)
|
||||
|
||||
* Mon Jun 04 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0.2-1
|
||||
- update to 7.43.0.2
|
||||
|
||||
* Wed May 30 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0-17
|
||||
- make the python2 and python3 subpackages optional
|
||||
|
||||
* Wed May 23 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0-16
|
||||
- fix build failure caused by NotImplemented exceptions in winbuild.py
|
||||
|
||||
* Wed Mar 14 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0-15
|
||||
- enable vsftpd-based tests
|
||||
- run the test-suite for Python 3 only
|
||||
- do not disable TLS-SRP test because it is now supported by OpenSSL in Fedora
|
||||
|
||||
* Mon Feb 19 2018 Kamil Dudka <kdudka@redhat.com> - 7.43.0-14
|
||||
- add explicit BR for the gcc compiler
|
||||
|
||||
* Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 7.43.0-13
|
||||
- Update Python 2 dependency declarations to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 7.43.0-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.43.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.43.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue May 02 2017 Kamil Dudka <kdudka@redhat.com> - 7.43.0-9
|
||||
- drop link-time vs. run-time TLS backend check (#1446850)
|
||||
|
||||
* Thu Apr 27 2017 Kamil Dudka <kdudka@redhat.com> - 7.43.0-8
|
||||
- make pycurl compile against libcurl-openssl (#1445153)
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.43.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Dec 12 2016 Stratakis Charalampos <cstratak@redhat.com> - 7.43.0-6
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
* Tue Nov 29 2016 Charalampos Stratakis <cstratak@redhat.com> - 7.43.0-5
|
||||
- Fix python2 subpackage name
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.43.0-4
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 7.43.0-3
|
||||
- Follow new packaging guidelines
|
||||
|
||||
* Fri Feb 26 2016 Kamil Dudka <kdudka@redhat.com> - 7.43.0-2
|
||||
- require libcurl of the same architecture as python-pycurl
|
||||
|
||||
* Sat Feb 06 2016 Kamil Dudka <kdudka@redhat.com> - 7.43.0-1
|
||||
- update to 7.43.0
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.21.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jan 06 2016 Kamil Dudka <kdudka@redhat.com> - 7.21.5-3
|
||||
- remove explicit dependency on keyutils-libs (reported by rpmlint)
|
||||
- update FSF address in COPYING-LGPL (detected by rpmlint)
|
||||
|
||||
* Tue Jan 05 2016 Kamil Dudka <kdudka@redhat.com> - 7.21.5-2
|
||||
- avoid installing binaries generated in %%check to /usr/share
|
||||
|
||||
* Tue Jan 05 2016 Kamil Dudka <kdudka@redhat.com> - 7.21.5-1
|
||||
- update to 7.21.5
|
||||
|
||||
* Sat Nov 14 2015 Toshio Kuratomi <toshio@fedoraproject.org> - - 7.19.5.3-3
|
||||
- Remove build dependency on cherrypy as it's no longer needed for testing
|
||||
|
||||
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.5.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
* Tue Nov 03 2015 Kamil Dudka <kdudka@redhat.com> - 7.19.5.3-1
|
||||
- update to 7.19.5.3
|
||||
|
||||
* Mon Nov 02 2015 Kamil Dudka <kdudka@redhat.com> - 7.19.5.2-1
|
||||
- update to 7.19.5.2
|
||||
|
||||
* Mon Sep 07 2015 Kamil Dudka <kdudka@redhat.com> - 7.19.5.1-3
|
||||
- introduce CURL_SSLVERSION_TLSv1_[0-2] (#1260408)
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon Jan 12 2015 Kamil Dudka <kdudka@redhat.com> - 7.19.5.1-1
|
||||
- update to 7.19.5.1
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Aug 3 2014 Tom Callaway <spot@fedoraproject.org> - 7.19.5-2
|
||||
- fix license handling
|
||||
|
||||
* Mon Jul 14 2014 Kamil Dudka <kdudka@redhat.com> - 7.19.5-1
|
||||
- update to 7.19.5
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.3.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon May 19 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 7.19.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
|
||||
|
||||
* Thu Feb 06 2014 Kamil Dudka <kdudka@redhat.com> - 7.19.3.1-1
|
||||
- update to 7.19.3.1
|
||||
|
||||
* Fri Jan 10 2014 Kamil Dudka <kdudka@redhat.com> - 7.19.3-2
|
||||
- add python3 subpackage (#1014583)
|
||||
|
||||
* Fri Jan 10 2014 Kamil Dudka <kdudka@redhat.com> - 7.19.3-1
|
||||
- update to 7.19.3
|
||||
|
||||
* Thu Jan 02 2014 Kamil Dudka <kdudka@redhat.com> - 7.19.0.3-1
|
||||
- update to 7.19.0.3
|
||||
|
||||
* Tue Oct 08 2013 Kamil Dudka <kdudka@redhat.com> - 7.19.0.2-1
|
||||
- update to 7.19.0.2
|
||||
|
||||
* Wed Sep 25 2013 Kamil Dudka <kdudka@redhat.com> - 7.19.0.1-1
|
||||
- update to 7.19.0.1
|
||||
|
||||
* Thu Aug 08 2013 Kamil Dudka <kdudka@redhat.com> - 7.19.0-18.20130315git8d654296
|
||||
- sync with upstream 8d654296
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-17.20120408git9b8f4e38
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Apr 09 2013 Kamil Dudka <kdudka@redhat.com> - 7.19.0-16.20120408git9b8f4e38
|
||||
- sync with upstream 9b8f4e38 (fixes #928370)
|
||||
- add the GLOBAL_ACK_EINTR constant to the list of exported symbols (#920589)
|
||||
- temporarily disable tests/multi_socket_select_test.py
|
||||
|
||||
* Wed Mar 06 2013 Kamil Dudka <kdudka@redhat.com> - 7.19.0-15
|
||||
- allow to return -1 from the write callback (#857875)
|
||||
- remove the patch for curl-config --static-libs no longer needed
|
||||
- run the tests against the just built pycurl, not the system one
|
||||
|
||||
* Mon Feb 25 2013 Kamil Dudka <kdudka@redhat.com> - 7.19.0-14
|
||||
- apply bug-fixes committed to upstream CVS since 7.19.0 (fixes #896025)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Aug 22 2012 Jan Synáček <jsynacek@redhat.com> - 7.19.0-12
|
||||
- Improve spec
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Dec 20 2010 Dennis Gilmore <dennis@ausil.us> - 7.19.0-8
|
||||
- add Missing Requires on keyutils-libs
|
||||
|
||||
* Tue Aug 17 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-7
|
||||
- Add patch developed by David Malcolm to fix segfaults caused by a missing incref
|
||||
|
||||
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 7.19.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||
|
||||
* Tue Mar 2 2010 Karel Klic <kklic@redhat.com> - 7.19.0-5
|
||||
- Package COPYING2 file
|
||||
- Added MIT as a package license
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-3
|
||||
- fix typo in the previous change
|
||||
|
||||
* Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-2
|
||||
- add a require to reflect a dependency on libcurl version (#496308)
|
||||
|
||||
* Thu Mar 5 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-1
|
||||
- Update to 7.19.0
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.18.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 7.18.2-2
|
||||
- Rebuild for Python 2.6
|
||||
|
||||
* Thu Jul 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.2-1
|
||||
- Update to 7.18.2
|
||||
- Thanks to Ville Skyttä re-enable the tests and fix a minor problem
|
||||
with the setup.py. (Bug # 45400)
|
||||
|
||||
* Thu Jun 5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.1-1
|
||||
- Update to 7.18.1
|
||||
- Disable tests because it's not testing the built library, it's trying to
|
||||
test an installed library.
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.16.4-3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Jan 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-2
|
||||
- BR openssl-devel
|
||||
|
||||
* Wed Aug 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-1
|
||||
- Update to 7.16.4
|
||||
- Update license tag.
|
||||
|
||||
* Sat Jun 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.2.1-1
|
||||
- Update to released version.
|
||||
|
||||
* Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.0-0.1.20061207
|
||||
- Update to a CVS snapshot since development has a newer version of curl than is in FC <= 6
|
||||
|
||||
* Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-4
|
||||
- Add -DHAVE_CURL_OPENSSL to fix PPC build problem.
|
||||
|
||||
* Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-3
|
||||
- Don't forget to Provide: pycurl!!!
|
||||
|
||||
* Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-2
|
||||
- Remove INSTALL from the list of documentation
|
||||
- Use python_sitearch for all of the files
|
||||
|
||||
* Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-1
|
||||
- First version for Fedora Extras
|
Loading…
Reference in new issue