parent
876b5e8f12
commit
038654736e
@ -1,34 +0,0 @@
|
||||
diff -rupN python-imaging-Pillow-75af7e0/setup.py python-imaging-Pillow-75af7e0-new/setup.py
|
||||
--- python-imaging-Pillow-75af7e0/setup.py 2013-07-02 14:52:49.000000000 +0200
|
||||
+++ python-imaging-Pillow-75af7e0-new/setup.py 2013-07-03 20:12:40.793669521 +0200
|
||||
@@ -184,6 +184,30 @@ class pil_build_ext(build_ext):
|
||||
elif platform_ in ["i386", "i686", "32bit"]:
|
||||
_add_directory(library_dirs, "/usr/lib/i386-linux-gnu")
|
||||
break
|
||||
+ elif platform_ in ["aarch64", "64bit"]:
|
||||
+ _add_directory(library_dirs, "/lib64")
|
||||
+ _add_directory(library_dirs, "/usr/lib64")
|
||||
+ _add_directory(library_dirs, "/usr/lib/aarch64-linux-gnu")
|
||||
+ break
|
||||
+ elif platform_ in ["arm", "armv7l", "32bit"]:
|
||||
+ _add_directory(library_dirs, "/usr/lib/arm-linux-gnueabi")
|
||||
+ break
|
||||
+ elif platform_ in ["ppc64", "64bit"]:
|
||||
+ _add_directory(library_dirs, "/lib64")
|
||||
+ _add_directory(library_dirs, "/usr/lib64")
|
||||
+ _add_directory(library_dirs, "/usr/lib/ppc64-linux-gnu")
|
||||
+ break
|
||||
+ elif platform_ in ["ppc", "32bit"]:
|
||||
+ _add_directory(library_dirs, "/usr/lib/ppc-linux-gnu")
|
||||
+ break
|
||||
+ elif platform_ in ["s390x", "64bit"]:
|
||||
+ _add_directory(library_dirs, "/lib64")
|
||||
+ _add_directory(library_dirs, "/usr/lib64")
|
||||
+ _add_directory(library_dirs, "/usr/lib/s390x-linux-gnu")
|
||||
+ break
|
||||
+ elif platform_ in ["s390", "32bit"]:
|
||||
+ _add_directory(library_dirs, "/usr/lib/s390-linux-gnu")
|
||||
+ break
|
||||
else:
|
||||
raise ValueError(
|
||||
"Unable to identify Linux platform: `%s`" % platform_)
|
@ -1,12 +0,0 @@
|
||||
diff -rupN python-imaging-Pillow-b1b88cf/Tests/test_file_webp.py python-imaging-Pillow-b1b88cf-new/Tests/test_file_webp.py
|
||||
--- python-imaging-Pillow-b1b88cf/Tests/test_file_webp.py 2014-01-01 22:10:13.000000000 +0100
|
||||
+++ python-imaging-Pillow-b1b88cf-new/Tests/test_file_webp.py 2014-01-03 01:14:58.873000325 +0100
|
||||
@@ -28,7 +28,7 @@ def test_read_rgb():
|
||||
|
||||
# generated with: dwebp -ppm ../../Images/lena.webp -o lena_webp_bits.ppm
|
||||
target = Image.open('Tests/images/lena_webp_bits.ppm')
|
||||
- assert_image_equal(image, target)
|
||||
+ assert_image_similar(image, target, 20.0)
|
||||
|
||||
|
||||
def test_write_rgb():
|
Loading…
Reference in new issue