Update to version 0.9.1

epel9
Petr Viktorin 4 years ago
parent 55577a6690
commit c050894c4d

1
.gitignore vendored

@ -1,3 +1,4 @@
/pep517-0.5.0.tar.gz
/pep517-0.7.0.tar.gz
/pep517-0.8.2.tar.gz
/pep517-0.9.1.tar.gz

@ -0,0 +1,20 @@
From f972e39c168065cdf4eba8b3334e743886bd3c10 Mon Sep 17 00:00:00 2001
From: Petr Viktorin <encukou@gmail.com>
Date: Fri, 13 Nov 2020 15:12:05 +0100
Subject: [PATCH] Allow building with Flit 3.x
---
pyproject.toml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pyproject.toml b/pyproject.toml
index 65d764c..9c1661c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["flit_core >=2,<3"]
+requires = ["flit_core >=2,<4"]
build-backend = "flit_core.buildapi"
[tool.flit.metadata]

@ -1,36 +0,0 @@
commit 187fedd9e1d91ee835b60d6c21a31c85f2eda719
Author: Petr Viktorin <encukou@gmail.com>
Date: Wed Nov 13 14:35:24 2019 +0100
Don't pull in importlib_metadata & zipp backports for Python 3.8+
The Python 3.8+ standard library importlib.metadata and zipfile.Path
are preferred over the backports.
diff --git a/pyproject.toml b/pyproject.toml
index 7c6e1d2..cb2dc76 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -10,8 +10,8 @@ home-page = "https://github.com/pypa/pep517"
description-file = "README.rst"
requires = [
"toml",
- "importlib_metadata",
- "zipp",
+ "importlib_metadata;python_version<'3.8'",
+ "zipp;python_version<'3.8'",
]
classifiers = ["License :: OSI Approved :: MIT License"]
diff --git a/dev-requirements.txt b/dev-requirements.txt
index 4e62f58..ecbaa9b 100644
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -4,5 +4,5 @@ mock
testpath
toml
setuptools>=30
-importlib_metadata
-zipp
+importlib_metadata ; python_version<'3.8'
+zipp ; python_version<'3.8'

@ -1,7 +1,7 @@
%global pypi_name pep517
Name: python-%{pypi_name}
Version: 0.8.2
Version: 0.9.1
Release: 1%{?dist}
Summary: Wrappers to build Python packages using PEP 517 hooks
@ -13,9 +13,9 @@ URL: https://github.com/takluyver/pep517
Source0: %{pypi_source}
BuildArch: noarch
# Don't require stdlib backport modules on Python 3.8+
# Submitted upstream: https://github.com/pypa/pep517/pull/70
Patch0: no-backports.patch
# Allow building with flit 3.x
# Upstream PR: https://github.com/pypa/pep517/pull/102
Patch1: 102.patch
BuildRequires: python3-devel
BuildRequires: pyproject-rpm-macros
@ -45,7 +45,6 @@ for systems which build Python packages, specified in PEP 517.
sed -i '/^addopts=--flake8$/d' pytest.ini
sed -i '/flake8/d' tox.ini
%generate_buildrequires
%pyproject_buildrequires %{?with_tests:-t}
@ -73,6 +72,9 @@ sed -i '/flake8/d' tox.ini
%changelog
* Fri Nov 13 2020 Petr Viktorin <pviktori@redhat.com> - 0.9.1-1
- Update to version 0.9.1
* Fri Oct 09 2020 Petr Viktorin <pviktori@redhat.com> - 0.8.2-1
- Update to version 0.8.2

@ -1 +1 @@
SHA512 (pep517-0.8.2.tar.gz) = 668569a26a4c21a1b8d6828a26bdcdab62b8c4d5fcaba8d9f9a4740e0fce7f071295e28d91349500b4c7be05ab2c2670986de18f01e2afafc1878101e5ef9af2
SHA512 (pep517-0.9.1.tar.gz) = 7c7d181d52a6d042ad432c4366021f9b2364c77193d99066668acd4c6967dab299644febf0dc4a6efb9a777a0aaae7df2687191cba3f3b93e6bf06ee0769a7df

Loading…
Cancel
Save